problem facing self inteface

Unanswered Question
May 31st, 2010

Hi

I have a 3825 router runnning code:c3825-spservicesk9-mz.124-15.T9.bin

I am facing a starange problem.

my problem is when i configure my gi 0/0 or gi 0/1 for testing with ip ip address 220.225.33.217 255.255.255.252 , i cant able to ping my self ip

but if i chnage the ip to some other range like "ip address 202.225.33.217 255.255.255.252" . i can able to ping the self interface ip which is 202.225.33.217 . how srtange is it a ios bug

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Federico Coto F... Mon, 05/31/2010 - 06:56

Hi,

I assume you're connecting the router to the Internet directly.

Can you connect a computer (instead than the router) and assign that same IP to the computer and see if you can PING the computer itself?

Federico.

rupam_chakra1983 Mon, 05/31/2010 - 08:13

I found a culprit the problem is  one user ip is statically natted to  the WAN interface ip using ip nat inside source < IP_host > interfcace gi0/1( WAn interface)

but after i have removed the entry i can ping the self IP of the WAN interface.

Why this is so i cannt understand.

Federico Coto F... Mon, 05/31/2010 - 08:18

If you had a user statically NATed to the WAN IP, it means that when you attempt to PING the WAN IP, traffic will be sent to the inside user.

If the inside user does not respond to the PING, then you won't get a response.

If you need a static NAT, have a different IP for the WAN IP (or use static PAT)

Federico.

Actions

This Discussion