Band Selection on WLC

Endorsed Question
May 31st, 2010

Hi,

I have installed one 5508 with 3 AP in lwapp mode for use with a band selection features, but my client with a linksys WUSB600N

use connection to 2.4Ghz.

Why ? Can you help me ?

Thanks in advance

I have this problem too.
0 votes
Cisco Endorsed by josuhr
leejohns about 6 years 6 months ago

Also remember that band select must be enabled globally on the WLC regardless of whether or not it is enabled on the individual WLAN:

Step 1 To globally enable or disable band selection on the controller, enter this command:

config band-select probe-response {enable | disable}

The default value is disabled. .

There are few bugs, CSCtf03958 and CSCtg94454, to add a note to the WLAN config (think MFP) and the documentatoin to make this more clear.

Thanks,

Lee

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Scott Fella Mon, 05/31/2010 - 13:43

Check your setting on the client device.  Band select tries to make the 5ghz side preferable compared to the 2.4ghz.  In the end, the client still makes the decision.

Scott

Mazzola68 Tue, 06/01/2010 - 00:53

Hi Scott

Thanks for your answer, I want use a band selection because in a site I have hundreds  of clients and I don't want modify the client configuration, and I need that the prefered  band selection must be 5Ghz over a 2.4Ghz.

Thanks in advance

Mazzola68 Tue, 06/01/2010 - 03:59

Hi Scott, my client need move in  a 5Ghz the notebook a,N and use a 2.4 Ghz only for a old notebook 802.11 b,g.

Cisco have ensured  that the band selection works fine but when I have tested it with a linksys it connect over 2.4.

Bye

Scott Fella Tue, 06/01/2010 - 04:56

Client devices make the final decisIon.  It doesn't mean it will work for every type of client device.  If you have a bunch of useres already on the 5ghz, then iI can see why other devices use the 2.4ghz.  Band select doesntdoesn't force or make devices use the 5ghz band, it just make it look more preferable.

Mazzola68 Thu, 06/03/2010 - 02:37

Hi Scott thanks for all and have a good day

ps:I have opened a ticket c/o Linksys support

leejohns Sat, 06/05/2010 - 07:22

Also remember that band select must be enabled globally on the WLC regardless of whether or not it is enabled on the individual WLAN:

Step 1 To globally enable or disable band selection on the controller, enter this command:

config band-select probe-response {enable | disable}

The default value is disabled. .

There are few bugs, CSCtf03958 and CSCtg94454, to add a note to the WLAN config (think MFP) and the documentatoin to make this more clear.

Thanks,

Lee

Mazzola68 Mon, 06/07/2010 - 15:52

Hi

I tried the band selection and I can not see the effects.
With some clients I always connect to 2.4Ghz and still others at 5 with Band Selection enabled and disabled.

Can you help me ?

leejohns Tue, 06/08/2010 - 04:57

What model of APs are you using?  Band select only works with 1140 and 1250 series APs.

Did you globally enable band select on the WLC:  config band-select probe-response {enable | disable} or from the GUI:  WIRELESS>Advanced>Band Select.

Thanks,

Lee

Mazzola68 Tue, 06/08/2010 - 11:11

Hi Lee

Thanks for your support.

I test a solution with a 1142 but configure a band selection only from a Gui

Wireless advanced band select.

Is not Correct ?

Thanks

leejohns Tue, 06/08/2010 - 11:13

No, unless you have globally enabled the feature in the two ways I mentioned, the config on the WLAN is irrelevant.

Lee

Mazzola68 Tue, 06/08/2010 - 11:32

Ok then also gui is enabled globally but then why not work?
Security is also enabled for each WLAN

Today I tried with 4 clients
3 11n and a 11a but work equally at 2.4 well with the band select enabled or sometimes to 5

with another client with a linksys wusb600n work only at 2.4 Ghz

leejohns Tue, 06/08/2010 - 11:51

Provided everything is enabled,  the radio policy is set to ALL on the WLAN, etc, all band select does is try and nudge a dual band client to try and see if they will associate on the 5Ghz band.  Delays the probe repsonse on the 2.4 band accoring to the number of probe cycles you configured for it to do so, but it doesn't mean that it never lets a dual band client associate at 2.4.  In the end, the client is the one that is going to make that decision.  You would need to get a wireless packet capture to see if the band select is actually working, i.e. delaying the probe response on 2.4.

If you go to MONITOR>Access Points>Radios>802.11b/g/n and then Details, do you see any band select statistics?  If not, then I would say get a wireless packet capture to see what is happening and then open a TAC case so one of us can take a look.

Thanks,

Lee

Mazzola68 Tue, 06/08/2010 - 11:57

Ok in monitor radio 802.11n detail I can see some statistics about a band selection but without effect over my client.

How I can capture a wireless packet ?

Thanks

ps:Unfortunately my client buy the solution only if the band selection work

leejohns Tue, 06/08/2010 - 12:07

OK, so since you see some band select stats, that would indicate that the WLC is performing band select, but for you test client, it is not associating on 5GHz for some reason.  In order to get a wireless sniffer capture, you would need to run something like Omnipeek on a laptop and recreate the issue. Is the linksys client running the latest drivers? If not, you might want to upgrade them and see if that makes a difference.  Have you tried using another dual-band capable client to see if this is just an issue with the Linksys client?

Lee

Mazzola68 Tue, 06/08/2010 - 12:16

Ok

I have downloaded the latest version driver of the Lynksys but the other client is a Lenovo and a Compaq dual band 11N  but I don't now a chipset of a radio.  I have try also a 3945abg with different driver version and one aironet cb21ag-e-k9 with different driver version.

Work either over 2.4 with a band select enable or over 5 with band select disable.

Today I have also installed a secondary WLC for failover but behavior is identical

leejohns Tue, 06/08/2010 - 13:07

You need to open a TAC case so that we can verify your configurations, etc and possibly get a wireless sniffer capture to see what is going on in the air when your clients are trying to connect.

Lee

Mazzola68 Tue, 06/15/2010 - 04:32

Hi, we have opened a TAC .

Do You now how I can debug a beacon over 2,5 and 5 Ghz and a probe request of my client over the AP ?

Thanks

leejohns Tue, 06/15/2010 - 12:23

You would need to have a wireless sniffer capture to see all of that.

Thanks,

Lee

Mazzola68 Wed, 06/16/2010 - 06:16

Hi Scott

I have installed airmagnet and have configured one SSID for both dot11Radio0 and Radio1 ,but Airmagnet allows a filter option scan only for a channel or BSSID (included mac address).

The BSSID of 2.4 and 5 have different mac address and I cannot scan at same time for verify band selection features because I need see:

Beacon from ap over 5Ghz

Beacon from ap over 2,4 Ghz

Probe request from client over 2,4 Ghz

Ignore probe request from AP over 2,4

Probe request over 5Ghz from client

Ack from AP over 5Ghz.

With Airmagnet(7.5 Build 10222)  I can only scan in sequence all channel or specify one frequency.

Can you hel me ?

Thanks in advance.

Actions

This Discussion