Inconsistent port type PVST

Answered Question
May 31st, 2010
User Badges:

Hi all

we are occuring and problem when connecting an two existing toplogy based on Catalyst Cisco 2960 & 2950 and existing toplogie base on 3Com Switch 8810 Core switch that we need to connect them to gather.


When connect the 3com segment trought an access port on Vlan 10 to  to Cisco catalyst on defaut Port  Vlan 1 on catalyst 2960. The catalyst seen on error message :

%SPANTREE-2-RECV_1Q_NON_TRUNK: Received IEEE 802.1Q BPDU on non trunk
FastEthernet0/1 on vlan 1.
%SPANTREE-2-BLOCK_PORT_TYPE: Blocking FastEthernet0/1 on vlan 1.
Inconsistent port type.


After getting this error catalyst port used for this connexion stay in yellow color with non trafic passing.


Assuming that the catalyst switch port has a default configuration and there is another local Vlan used by another  Catalyst port suching that Catalyst run PVST version.


when we connect to 3com switch to an access port vlan 10. and this switch run MSTP version, this configuration can cause this problem?


Please, what can you propose to resolve this issue?


best regards.

Correct Answer by Calin Chiorean about 7 years 3 weeks ago

You are connecting a switch (3Com)  to an access port on Cisco switch(usually an access port is configured with spanning-tree portfast). This shouldn't be done especially if the BPDUguard is enabled.

You are getting the message because BPDUguard is detecting a BPDU packet on an Access port.


Try looking if you have bpduguard or bpdufilter enabled:


show run | i  spanning-tree portfast bpduguard

or

show run | i spanning-tree portfast bpdufilter


If you have it configured, then there are 2 solutions:

1. configure trunking between 3Com and Cisco switch, and eliminate spanning-tree portfast

2. if you have no solution than connecting the 3Com on access port in switch, then on the Cisco port do:

spanning-tree bpduguard disable

spanning-tree bpdufilter disable


Let me know if this works for you!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Calin Chiorean Tue, 06/01/2010 - 00:19
User Badges:
  • Silver, 250 points or more

You are connecting a switch (3Com)  to an access port on Cisco switch(usually an access port is configured with spanning-tree portfast). This shouldn't be done especially if the BPDUguard is enabled.

You are getting the message because BPDUguard is detecting a BPDU packet on an Access port.


Try looking if you have bpduguard or bpdufilter enabled:


show run | i  spanning-tree portfast bpduguard

or

show run | i spanning-tree portfast bpdufilter


If you have it configured, then there are 2 solutions:

1. configure trunking between 3Com and Cisco switch, and eliminate spanning-tree portfast

2. if you have no solution than connecting the 3Com on access port in switch, then on the Cisco port do:

spanning-tree bpduguard disable

spanning-tree bpdufilter disable


Let me know if this works for you!

Sindibade 78 Tue, 06/01/2010 - 00:31
User Badges:

Hi,


Please; Befor cheking this parameters i need to check with you if this link methode is correct or no?


From 3com switch port configured on Vlan 10 i connect on the catalyst switch using a port with default configuration.


I assume that when a get this link, i will distribute the Vlan 10 from 3com to catalyst throught this link?


PVST on catalyst can by pass this mecanisme or it's will block the port when it's see that the traffic comming from 3com switch has a PVid (10) diffrent to 1 as default on catalyst port.


best regards

Calin Chiorean Tue, 06/01/2010 - 01:00
User Badges:
  • Silver, 250 points or more

PVST will block the port due to the BPDUguard being enabled. This the security part of  PVST


Next, if on the Cisco port, which connects to 3COM, you have VLAN 1 and this is the native vlan, and on the 3COM you have VLAN 10, this will work, BUT somewhere on the Cisco you still need to define VLAN 10 for the communication with the L3 IP address.

In this case, if you really want there on Cisco access port I would suggest the following, even this is not best practice.


-disable bpduguard on the access port connection to 3com

-configure vlan 10, on both ports (cisco and 3com)


Then you have reachability inside VLAN and don't have to worry about STP.

Sindibade 78 Tue, 06/01/2010 - 01:05
User Badges:

what about other ports on Catalyst switch, i assume that are configured on default Vlan 1.


except 2 ports configured on a local Vlan used for a WAN L3 connection.


By default, 2960 has A BPDU guard enabled and there ports are configured as Fastport?

Calin Chiorean Tue, 06/01/2010 - 01:25
User Badges:
  • Silver, 250 points or more

I didn't worked with 2960, but on other platforms it's not enabled by default, but it's hardly recommend to have it on, to avoid STP problems. If you need more help, please provide some configs.

Actions

This Discussion