LACP EtherChannel issue with Switch and HP server

Unanswered Question
Jun 1st, 2010
User Badges:
  • Blue, 1500 points or more

I have two HP G6 servers both running Windows 2008 and each have 4 NIC's. And I also have dual 6509's running VSS. What I am trying to do is Team and EtherChannel NIC1 and NIC3 from server 1 to Port-Channel 52 using ports Gi2/2/30 and Gi1/2/40 but I am having issues with that.


Server 2 I also am Teaming and EtherChanneling NIC1 and NIC3 to Port-Channel 51 using ports Gi2/1/48 and Gi1/2/39, and that is not having any problems.


I am using HP teaming software on both servers and everything is at the same and latest firmware and rev. The Team is setup with the HP Teaming software exactly the same for both servers with 802.3ad (LACP) and Load balanced on Destination IP Address.


Why does Po51 show up like this and Po52 show up differently with a Po52A.....what is the A...I have never come accross this.


Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
51     Po51(SU)        LACP      Gi1/2/39(P)    Gi2/1/48(P)  


Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
52     Po52(SU)        LACP      Gi2/2/30(P)   
52     Po52A(SU)       LACP      Gi1/2/40(P)  


Here are the configs for the interfaces in question. Po51 works fine but Po52 does not.

First is Po51

interface Port-channel51
description FIRM41b07 Exchange EtherChannel
switchport
switchport access vlan 7
switchport mode access
mtu 9216
spanning-tree portfast trunk
end

interface GigabitEthernet1/2/39
description firm41b07 exchange mbx nic3
switchport
switchport access vlan 7
switchport mode access
mtu 9216
channel-group 51 mode active
spanning-tree portfast
end


interface GigabitEthernet2/1/48
description firm41b07 exchange mbx nic1
switchport
switchport access vlan 7
switchport mode access
mtu 9216
channel-group 51 mode active
spanning-tree portfast
end

ROC-6509-VSS#show etherchannel 51
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port

        w - waiting to be aggregated
Number of channel-groups in use: 80
Number of aggregators:           83

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
51     Po51(SU)        LACP      Gi1/2/39(P)    Gi2/1/48(P)  

Last applied Hash Distribution Algorithm: Fixed





Next is Po52

interface Port-channel52
description FIRM42b07 Exchange EtherChannel
switchport
switchport access vlan 7
switchport mode access
mtu 9216
spanning-tree portfast trunk
end

interface GigabitEthernet2/2/30
description firm42b07 exchange mbx log nic1
switchport
switchport access vlan 7
switchport mode access
mtu 9216
channel-group 52 mode active
spanning-tree portfast
end


interface GigabitEthernet1/2/40
description firm42b07 exchange mbx log nic3
switchport
switchport access vlan 7
switchport mode access
mtu 9216
channel-group 52 mode active
spanning-tree portfast
end

ROC-6509-VSS#show etherchannel 52 sum
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port

        w - waiting to be aggregated
Number of channel-groups in use: 80
Number of aggregators:           83

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
52     Po52(SU)        LACP      Gi2/2/30(P)   
52     Po52A(SU)       LACP      Gi1/2/40(P)  

Last applied Hash Distribution Algorithm: Fixed





Thanks for your help,

Mike

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Tue, 06/01/2010 - 07:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mike,

this happened to me too sometimes


an interpretation I've found in the forum is that at the moment of setting up the bundle the two links were considered different in some minor aspect.


in your case do you see load balancing in effect over both links or only one is used? This is to understand if you have a real issue

In my case it was not a real problem.


Have you tried to shut both ports and to use interface range to re-enable them with a single command?



Hope to help

Giuseppe

Calin Chiorean Tue, 06/01/2010 - 07:01
User Badges:
  • Silver, 250 points or more

The issue with the letter A, I have it once. It shows that you have 2 (or more) interface in a channel bundle, but they have different configuration (from channel point of view). If you have there a third interface different from the other 2, it would have letter B as far as I know.


Now, I don't see any issue with the config, but try running the following commands:


sh int po52 switchport

sh int gi2/2/30 switchport

sh int gi1/2/40 switchport


Check if you have any error there.


Then, if this is an access port as stated you don't need spanning-tree portfast trunk on the PO52 interface.

Check on the HP to have similar configuration on both interfaces.


In the worst case, take all the config out, and configure again the PO52. Sometimes it helps more that you believe


Let me know if this helps!

burleyman Tue, 06/01/2010 - 07:19
User Badges:
  • Blue, 1500 points or more

Calin and Giuseppe,

Thanks for your responce. Here is the output of the show int switchport for each. I did check that and the capabilities for all ports as well. I guessed it was a different aggregate but I could not see why. I have totally ripped the config out and reconfigured. I also have another one setup using the same model server and all the same software and same config and that came up fine. I am a little baffeled. I have setup etherchannels all the time and have never run accross this. I may try re-doing this again using different ports and Po setup. I will try this with the Int range in a single command...did not think of that.

ROC-6509-VSS#show int gi2/2/30 switchport
Name: Gi2/2/30
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access (member of bundle Po52)
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 7 (exchange)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled

ROC-6509-VSS#show int gi1/2/40 switchport
Name: Gi1/2/40
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access (member of bundle Po52A)
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 7 (exchange)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled


ROC-6509-VSS#show int po52 switchport   
Name: Po52
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 7 (exchange)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled


ROC-6509-VSS#show int gi2/2/30 capabilities
GigabitEthernet2/2/30
  Model:                 WS-X6748-GE-TX
  Type:                  10/100/1000BaseT
  Speed:                 10,100,1000,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on,desired),tx-(off,on,desired)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q8t), tx-(1p3q8t)
  QOS queueing mode:     rx-(cos), tx-(cos)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          no
  Inline power policing: no
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
  Ports-in-ASIC (Sub-port ASIC) : 25-48 (25-36)
  Remote switch uplink:  no
  Dot1x:                 no
  Port-Security:         yes

ROC-6509-VSS#show int gi1/2/40 capabilities
GigabitEthernet1/2/40
  Model:                 WS-X6748-GE-TX
  Type:                  10/100/1000BaseT
  Speed:                 10,100,1000,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on,desired),tx-(off,on,desired)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q8t), tx-(1p3q8t)
  QOS queueing mode:     rx-(cos), tx-(cos)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          no
  Inline power policing: no
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
  Ports-in-ASIC (Sub-port ASIC) : 25-48 (37-48)
  Remote switch uplink:  no
  Dot1x:                 no
  Port-Security:         yes


Thanks,

Mike


burleyman Wed, 06/02/2010 - 04:32
User Badges:
  • Blue, 1500 points or more

This ended up being server related. I did not figure out exactly what it was but it was either software, firmware, or driver problem. Since this server had all the same software, firmware, and drivers, all at the same rev level as another identical server and that other server worked I seem to think something got damaged or corupted which was causing my problem.



Thanks for your help on this.


Mike

Actions

This Discussion