best way to connect 2 4506's together between buildings

Unanswered Question
Jun 1st, 2010

What is the best practice to connect two 4506's together between two buildings?

There are about 300 users in each building with 100Mb LES cct.

Currently it is configured as a trunk.

On building one core:
interface GigabitEthernet3/4
description 100MB to building2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 902
switchport mode trunk
switchport nonegotiate
bandwidth 100000
speed 100
duplex full
qos trust dscp
tx-queue 3
   priority high
   shape percent 20
spanning-tree portfast trunk
service-policy output DBL

interface Vlan902
description VLAN for intersite routing
ip address 10.254.1.9 255.255.255.248
ip policy route-map BT-10

On building two core:


interface GigabitEthernet2/1
description 100Mb to building one
switchport access vlan 5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 902
switchport mode trunk
switchport nonegotiate
service-policy output DBL
speed 100
duplex full
spanning-tree portfast

interface Vlan902
description VLAN for intersite routing
ip address 10.254.1.10 255.255.255.252
end

It is working fine however I am not sure if you would call this a trunk / a routed link or if I should configure the connecting ports as routed ports?

it is using a 100Mb RJ45 LES cct.

thanks

Roger

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
podhillo Tue, 06/01/2010 - 08:22

Hi Roger,

As per the below excerps i can presume this link is going to be acting as a Routed Port more than a Trunk Port only reason can be IP address is configured for Interface Vlan 902 and on the Switch port its configured on Gig2./1 .

Do share your views ....

Regards

podhillo

simplecisco Tue, 06/01/2010 - 08:30

I am not sure what the best practice is? As far as I can tell it is running as a routed link but I don't fully understand what is going on with the config.

Roger

podhillo Tue, 06/01/2010 - 08:52

As per the best practise is concerned

You have two 4506 Switch in that case both are equally capable of doing Routing as well and one the 4506 has to be connected to a Gateway Router or a Core Router in order to cater all the user traffic over to Internet as normally Core Switch cannot have BGP running on it as its the Role of a Core Router to get connected to a gateway Device and then with ISP.

So i would recommend one Switch of 4506 to act as Collapsed Core where it can do inter vlan Routing and run eigrp and then get that connected over to Gateway Device where it can traverse outside .

And one more thing which i am presuming if both your switch wants to get connected between buildings then both i believe is acting as Core/Dist Switch connected over MM/SM fiber depending upon the distance between the buildings also you can use LRE . And then connect those core switch in a redundant fashion run HSRP in them for every individual vlan interface and have a gateway device connected it can be any model of Layer 3 Device .

Also if you can atleast tell me what those two 4506 switch is acting as then i can give you some additional suggestion on whats the best practise is .

Regards,

podhillo

Leo Laohoo Tue, 06/01/2010 - 15:00

bandwidth 100000
speed 100
duplex full
spanning-tree portfast trunk

On a WAN link, I'd go for a routed link anytime.

"bandwidth 100000"

Unless you have some kind of a metric system, this is not really necessary because you don't have any redundant link.  And speaking of redundant link, do you have one?  How far are both buildings?

"speed 100" and/or "duplex full"

You sure the provider won't allow auto-negotiate?  Check your links to make sure it's there are no input/output errors or collisions.

"spanning-tree portfast trunk"

Not a fan of this.  Not one bit. 

Don't forget to rate uses posts.  Thanks.

Actions

This Discussion