Troubleshooting ADSL connections

Unanswered Question
Jun 1st, 2010
User Badges:

I have an 877 router that will not connect to my ISP. I've tried the troubleshooting docs, when I run a PPP debug, I get Vi2 CHAP: O RESPONSE id 1 len 34 from <my isp username>"

Vi2 CHAP: I FAILURE id 1 len 42 msg is "CHAP authentication failure, unit 2965"


the username and password are for certain correct, and the line is ok, as when I use another (much cheaper) router, it works fine. I've wiped my router and re-done the config from scratch, with same result. I'm running the latest IOS. Any ideas what other troubleshooting can be done?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 06/01/2010 - 11:44
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Alan,

post a filtered version of your current configuration and if you like the output of


debug ppp negotiation

debug ppp authentication


Vi2 means virtual-access 2, you could use a dialer interface instead so looking at your config may help


Hope to help

Giuseppe

alanmsv1234 Wed, 06/02/2010 - 06:22
User Badges:

Hi,


debug ppp neg is as follows:


*Mar  1 03:33:39.090: Vi2 LCP: State is Closed
*Mar  1 03:33:39.090: Vi2 PPP: Phase is DOWN
*Mar  1 03:33:39.090: Vi2 PPP: Phase is ESTABLISHING, Passive Open
*Mar  1 03:33:39.090: Vi2 LCP: State is Listenunde
*Mar  1 03:33:40.402: Vi2 PPP: LCP not open, discarding UNKNOWN(0xAAAA) packet
*Mar  1 03:33:41.107: Vi2 LCP: Timeout: State Listen
*Mar  1 03:33:41.107: Vi2 PPP: No remote authentication for call-out
*Mar  1 03:33:41.107: Vi2 LCP: O CONFREQ [Listen] id 225 len 10
*Mar  1 03:33:41.107: Vi2 LCP:    MagicNumber 0x23C69477 (0x050623C69477)
*Mar  1 03:33:41.579: Vi2 LCP: I CONFREQ [REQsent] id 139 len 19
*Mar  1 03:33:41.579: Vi2 LCP:    MRU 1500 (0x010405DC)
*Mar  1 03:33:41.579: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:33:41.579: Vi2 LCP:    MagicNumber 0x55E3EF63 (0x050655E3EF63)
*Mar  1 03:33:41.583: Vi2 LCP: O CONFACK [REQsent] id 139 len 19
*Mar  1 03:33:41.583: Vi2 LCP:    MRU 1500 (0x010405DC)
*Mar  1 03:33:41.583: Vi2 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 03:33:41.583: Vi2 LCP:    MagicNumber 0x55E3EF63 (0x050655E3EF63)
*Mar  1 03:33:41.583: Vi2 LCP: I CONFACK [ACKsent] id 225 len 10
*Mar  1 03:33:41.583: Vi2 LCP:    MagicNumber 0x23C69477 (0x050623C69477)
*Mar  1 03:33:41.583: Vi2 LCP: State is Open
*Mar  1 03:33:41.583: Vi2 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 03:33:41.595: Vi2 CHAP: I CHALLENGE id 1 len 36 from "bras-red7.l-wat"
*Mar  1 03:33:41.595: Vi2 CHAP: Using hostname from interface CHAP
*Mar  1 03:33:41.595: Vi2 CHAP: Using password from interface CHAP
*Mar  1 03:33:41.595: Vi2 CHAP: O RESPONSE id 1 len 34 from "XXXXXXXXX"
*Mar  1 03:33:41.635: Vi2 CHAP: I FAILURE id 1 len 42 msg is "CHAP authenticatio n failure, unit 1822"
*Mar  1 03:33:41.635: Vi2 LCP: I TERMREQ [Open] id 140 len 4
*Mar  1 03:33:41.635: Vi2 LCP: O TERMACK [Open] id 140 len 4all
*Mar  1 03:33:41.635: Vi2 PPP: Sending Acct Event[Down] id[3B1]
*Mar  1 03:33:41.635: Vi2 PPP: Phase is TERMINATING
*Mar  1 03:33:42.075: Vi2 LCP: I TERMREQ [TERMsent] id 1 len 4
*Mar  1 03:33:42.075: Vi2 LCP: O TERMACK [TERMsent] id 1 len 4
All possible debugging has been turned off
MSV-877#
*Mar  1 03:33:43.631: Vi2 LCP: Timeout: State TERMsent
*Mar  1 03:33:43.631: Vi2 LCP: State is Closed





Running config:


interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.0.10.252 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address xx.xx.xx.3 255.255.255.240
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname ***********
ppp chap password 0 ************
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
ip http secure-server
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.0.10.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!

paolo bevilacqua Wed, 06/09/2010 - 09:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

*Mar  1 03:33:41.635: Vi2 CHAP: I FAILURE id 1 len 42 msg is "CHAP authentication failure, unit 1822"


Are there special characters in the credentials ?

alanmsv1234 Tue, 06/08/2010 - 09:57
User Badges:

I don't understand why it would say virtual interface. I configured it via SDM, I presume it would apply it to the actual interface?

Giuseppe Larosa Tue, 06/08/2010 - 10:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Alan,

the configuration looks like correct I've checked on one of my device a virtual-access interface  is derived from the dialer interface



What IOS image is running on the device?


post sh ver | inc image


Hope to help

Giuseppe

alanmsv1234 Wed, 06/09/2010 - 09:45
User Badges:

System image file is "flash:c870-advsecurityk9-mz.124-24.T3.bin"


Cheers

Actions

This Discussion