Cisco 6500 booting issue.

Unanswered Question
Jun 1st, 2010

Hi All,

I have Cisco 6500 switch with Sup 720-3B on it.


The issue is the switch is bootting in the ROMMON mode.I have sent the conf register to 0x2102 save the config and reload the switch. The switch works fine if I do reboot,.


But when I manually shut the switch off and powered ON  again,  I see that the Config register is lost on the switch. Hence had to again login to rommon and do the stuff.


Is this bug or anything missing? My switch is running 12.2(18)SXD4



Thanks in advance. your help would be highly appriciated.


Regards

Alex.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Reza Sharifi Tue, 06/01/2010 - 09:15

hi Alex,


Do you only have one image on the flash? if you have more then one you want to make sure that your boot variable is pointing to the correct IOS image before booting it.  It may also be a bug. 12.2(18)SXD4 is pretty old.  the latest on CCO is 12.2(33)SXI3


HTH

Reza

podhillo Tue, 06/01/2010 - 10:23

Hi Alex,


Please update the contents of the Flash using the 'dir all' command so that we can recognise you are using Native mode or Hybrid mode.


Following is the procedure for catos to cisco ios and vice versa which i think you are following:


CatOS to IOS:

http://www.cisco.com/en/US/partner/products/hw/switches/ps708/products_tech_note09186a008015bfa6.shtml


IOS to CatOS:

http://www.cisco.com/en/US/partner/products/hw/switches/ps700/products_tech_note09186a00801350b8.shtml


After you reload it manully please check the message on the console if the controls are with SP or RP?

Please do check the boot variable?

Do update the output for 'dir all'.


After checking if there is no human errors we can go for Bug hunting.


Regards,

podhillo.

alexc2010 Tue, 06/01/2010 - 10:58

Hi Podhilo,

I am running Native IOS.  The switch works fine when I do reload, only the problem comes when I switched the box off and switched on.

As soon as I switched on the box goes into rommon mode.



------------------ show version ------------------ Cisco Internetwork Operating System Software IOS (tm) s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD4, RELEASE SOFTWARE (fc1) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2005 by cisco Systems, Inc. Compiled Tue 12-Apr-06 Image text-base: 0x4002100C, data-base: 0x42318000 ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1) BOOTLDR: s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD4, RELEASE SOFTWARE (fc1) Router uptime is 25 minutes Time since Router switched to active is 20 minutes System returned to ROM by error - a Software forced crash, PC 0x402EF39C at 01:22:43 UTC Mon Jun 1 2005 (SP by power-on) System image file is "sup-bootflash:s72033-pk9sv-mz.122-18.SXD4.bin"


2)

Why is this switch going to rommon when the box been switched off and on again?


I think this is due to some bug....any comments from you will be appriciated.



Thanks in advance.

alex.

podhillo Tue, 06/01/2010 - 11:39

Hi Alex,


Please check after you hard reload the switch do we get any crash info file generated for the same in the 'dir all' command.


Do sent me the 'dir all' and 'show log' output.


Regards,

podhillo

Faisal Imdad Fri, 09/30/2011 - 11:00

Hi ,


I am facing the same Issue.. Here are my dir all results.



#dir all

Directory of system:/


    2  dr-x           0                      memory

    1  -rw-        8215                      running-config

   12  dr-x           0                      vfiles


No space information available

Directory of tmpsys:/


    6  drw-           0                      eem_lib_system

    5  drw-           0                      eem_lib_user

    4  drw-           0                      eem_policy

    1  dr-x           0                      lib


No space information available

Directory of flexwan-fpd:/


    0  dr--                      


No space information available

Directory of disk0:/


    1  -rw-   143182180  Sep 30 2011 13:33:22 +00:00  s72033-advipservicesk9_wan-mz.122-33.SXJ1.bin


1024557056 bytes total (881360896 bytes free)

Directory of sup-bootflash:/


    1  -rwx    49141220   Jan 1 2000 00:58:36 +00:00  s72033-ipservicesk9-mz.122-33.SXH2.bin


65536000 bytes total (16394652 bytes free)

Directory of sup-microcode:/


    0  dr--                      

    1  -r--    18691014                      DRACO2_MP

    2  -r--     8043894                      CHEVYS-LC

    3  -r--     9384490                      C2LC

    4  -r--      327162                      LCP_LX10100

    5  -r--      297508                      LCP_LX1000

    6  -r--      319552                      LCP_AX1000

    7  -r--      389998                      LCP_AX10100

    8  -r--      366830                      LCP_CPFAB

    9  -r--      723998                      LCP_CPGBIT

   10  -r--      468286                      LCP_CP10G

   11  -r--      788894                      LCP_CPMBIT2

   12  -r--      888782                      LCP_CPMBIT

   13  -r--     1108014                      LCP_CPXBIT

   14  -r--       65318                      LCP_ABOOT

   15  -r--       60490                      LCP_BOOT


41924230 bytes total (0 bytes free)

Directory of const_nvram:/


    1  -rw-           0                      vlan.dat


129004 bytes total (129004 bytes free)

Directory of nvram:/


1918  -rw-        8201                      startup-config

1919  ----          24                      private-config

1920  -rw-        8201                      underlying-config

    1  -rw-           4                      rf_cold_starts

    2  ----          15                      persistent-data

    3  -rw-           0                      ifIndex-table


1964024 bytes total (1952675 bytes free)

Directory of bootflash:/


    1  -rwx    49141220   Jan 1 2000 00:39:56 +00:00  s72033-ipservicesk9-mz.122-33.SXH2.bin


65536000 bytes total (16394652 bytes free)

Directory of dfc#3-bootflash:/


No files in directory


15990784 bytes total (15990784 bytes free)

Directory of dfc#4-bootflash:/


No files in directory


15990784 bytes total (15990784 bytes free)



thanks

glen.grant Fri, 09/30/2011 - 13:56

  At what point are you setting the config register.?   There is a config register for switch supervisor and one for the msfc . Set the register at the rommon prompt .You are in the switch supervisor at this point.  Reset the switch and when it comes up make sure you have the correct boot statement  in the config . Save and then reload .

Leo Laohoo Fri, 09/30/2011 - 18:24
But when I manually shut the switch off and powered ON  again,  I see that the Config register is lost on the switch. Hence had to again login to rommon and do the stuff.

I don't the meaning of this.  How could you "lost" the config register?


Can you post the output for the command "sh bootv"?

Faisal Imdad Sat, 10/01/2011 - 03:56

Hi,


When I switch off and switch on the Switch 6500 it cones straight to Rommon mode and last line it says.


Autoboot: failed, BOOT string is empty


and I need to enter boot command to boot it up..

amikat Sat, 10/01/2011 - 11:57

Hi,


Will you please post the "remote command switch show bootvar" command output.

Thanks & Regards,


Antonin

Leo Laohoo Sat, 10/01/2011 - 16:58
and I need to enter boot command to boot it up.. 

If that is the case, please post the "sh bootvar" command output please?

Faisal Imdad Mon, 10/03/2011 - 11:43

Hi,


What happening is when I boot my switch and enter "show bootvar" I found no value setted. Than I set the bootldr value and pointed boot image with those commands


config-register 0x2102


boot system flash sup-bootflash:xxxxx.bin



boot bootldr bootflash:
xxxxx.bin


and if I enter reload command it works properly and switch boot with the IOS image I have setted. But If I cut the power off and reconnect it. It lose all configuration and again goes to rommon mod.


I never forget to enter WR command after setting boot images.


thanks

Actions

This Discussion