×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

connection between distribution sw to router

Unanswered Question
Jun 1st, 2010
User Badges:

hi!

I've a pair of 3550 sw runnig hsrp. The 3550 distrution switches are the route processor/gw for intervlan routing. If i would to connect 2x 2811 routers to our hq (1 router connection from each dist sw), what would be the recommended or normal configuration like? can provide sample guideline on this? is it active, standby and how can i determine the priority path etc?


one question is that the ethernet connection from my 3550 switch to the 2811 routers' ethernet connection, shd it be a trunk link or i've to configure that port to be L3 with the no switcport command and then assign it with an ip on the sw end and the router end?


thx.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Jon Marshall Tue, 06/01/2010 - 10:33
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Depends what you want but personally i would use routed point to point links between the 3550s and 2800 routers and run a dynamic routing protocol between them. Then leave it up to the dynamic routing protocol work out which link to use.


Jon

dkblee@hotmail.com Wed, 06/02/2010 - 04:55
User Badges:

hi! routed point to point between the DL sw with the 2811, do you mean assigning an ip to the 2811's fe port and no switchport command  with an ip on the DL sw as mentioned?


thks.

merryllem Tue, 06/01/2010 - 10:46
User Badges:

Hello,


From what I can tell from your post, you need to add 2x RTR's to your network to connect to your HQ. I am assuming 2X WAN (P2P/MPLS/Frame) connections. In most instances when more than one connection is present you would use a routing protocol to provide the load balacing and failover of the connection (Using HSRP is also plausible). I can't really give you examples until you clarify what you are trying to do.(Diagrams would be nice)


For the second question, you have multiple options to connect your router, the most common way is just to create a new VLAN/Subnet (on the switch) and connect the RTR ethernet to the switch using an switch access port. This option gives you the flexibility to use a routing protocol or HRSP on the switch end to achive LB or Failover.


Using trunks on RTR ports is used mostly for a VLAN on a stick topology. In your case, I think  you not would gain anything by using trunks.


Hope that helps

dkblee@hotmail.com Wed, 06/02/2010 - 06:04
User Badges:

hi! I'm trying this out in the test environment first. The WAN link i'm using in the test environment is a p2p link whereas the actual env is running mpls. This is to simplify the test setup. I would just want to get the concept right first. A bit of guideline and sample will be great. i;ve attached the draft of the setup. i hope to have at least a active/standby(branch router) of setup for the traffic to the hq. thx

Attachment: 
tj.mitchell Tue, 06/01/2010 - 11:05
User Badges:
  • Bronze, 100 points or more

PTP links with a protocol between them. criss/cross the links if possible R1 to Sw1 and R1 to Sw2, then R2 to Sw2 and R2 to Sw1. Then connect the switches together. Use a protocol between the router/switch links and what ever you want between the switches. Give you load-balance and redundancy.

merryllem Wed, 06/02/2010 - 11:15
User Badges:

You need to find out how you and your ISP will handle routing (Thru Routing Protocls or Static Routes).


With that said, here are a few things to get you started


Lets assume the following information


HQ Subnet: 7.7.7.0 255.255.255.0
Branch Subnet:8.8.8.0 255.255.255.0


HQ1


interface s0/0
ip address 1.1.1.1 255.255.255.252


ip route 8.8.8.0 255.255.255.0 1.1.1.2


HQ2


interface s0/0
ip address 2.2.2.1 255.255.255.252


ip route 8.8.8.0 255.255.255.0 2.2.2.2.2



Branch1


interface s0/0
ip address 1.1.1.2 255.255.255.252


interface F0/0
ip address 3.3.3.1 255.255.255.248


ip route 7.7.7.0 255.255.255.0 1.1.1.1


router ospf 10
network 3.3.3.0 0.0.0.7 area 0
redistribute static subnets


Branch2


interface s0/0
ip address 2.2.2.2 255.255.255.252


interface F0/0
ip address 3.3.3.2 255.255.255.248


ip route 7.7.7.0 255.255.255.0 2.2.2.1


router ospf 10
network 3.3.3.0 0.0.0.7 area 0
redistribute static subnets


DL-SW1


Interface VLAN333
ip address 3.3.3.3 255.255.255.248


Interface fa0/20
Switchport mode access
switchport acces vlan 333


router ospf 10
passive-interface default
no pass-interface VLAN333
network 3.3.3.0 0.0.0.7 area 0
network 8.8.8.0 0.0.0.7 area 0


DL-SW2


Interface VLAN333
ip address 3.3.3.4 255.255.255.248


Interface fa0/20
Switchport mode access
switchport acces vlan 333


router ospf 10
passive-interface default
no pass-interface VLAN333
network 3.3.3.0 0.0.0.7 area 0
network 8.8.8.0 0.0.0.7 area 0


Hope that helps

dkblee@hotmail.com Thu, 06/03/2010 - 10:20
User Badges:

hi! Thanks for the reply.


I setup the lab environment using the IPs that you gave me as an example, except that i added in the 172.16.x.x range in the DL-switch1 and a loopback interface at the HQ1 (I tried in HQ1 and Branch1 first). In addition to that, my test env DL-switch1 can only run eigrp. Based on the config that i've done below, what need to be done so that from my DL-switch1 i can reach the loopback interface at HQ1 and vice versa? With the config below from my DL-switch1 i can only reach Branch1's fa0/0 interface. and from my HQ1 i can only reach the vlan333 interface but not the rest of the interfaces. pls advise. thanks!


HQ1
-------------------
interface Loopback10

ip address 8.8.8.1 255.0.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 1.1.1.1 255.255.255.252
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
ip route 3.3.3.0 255.255.255.248 1.1.1.2
ip route 172.16.10.0 255.255.255.0 1.1.1.2
ip route 172.16.11.0 255.255.255.0 1.1.1.2
ip route 172.16.12.0 255.255.255.0 1.1.1.2
ip route 172.16.13.0 255.255.255.0 1.1.1.2
ip route 172.16.14.0 255.255.255.0 1.1.1.2
ip route 172.16.15.0 255.255.255.0 1.1.1.2


----------------------------------------------

branch1
----------
interface FastEthernet0/0
ip address 3.3.3.1 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 1.1.1.2 255.255.255.252
clock rate 64000
!
router ospf 10
log-adjacency-changes
redistribute static subnets
redistribute eigrp 10 metric 1 subnets
network 3.3.3.0 0.0.0.7 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route 3.3.3.0 255.255.255.248 FastEthernet0/0
ip route 172.16.15.0 255.255.255.0 FastEthernet0/0
!
no ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
---------------------------------------------------
DL-Switch1
----------
!
interface Vlan333
ip address 3.3.3.3 255.255.255.248
!
router eigrp 10
network 3.3.3.0 0.0.0.7
network 172.16.10.0 0.0.0.255
network 172.16.11.0 0.0.0.255
network 172.16.12.0 0.0.0.255
network 172.16.13.0 0.0.0.255
network 172.16.14.0 0.0.0.255
network 172.16.15.0 0.0.0.255
no auto-summary

merryllem Thu, 06/03/2010 - 11:20
User Badges:

Looks like EIGRP needs to be configured on the branch router. Here are the lines



branch1


!*remove the following lines since there is no need for it
no ip route  3.3.3.0 255.255.255.248 FastEthernet0/0
no ip route 172.16.15.0  255.255.255.0 FastEthernet0/0


router eigrp 10
network 3.3.3.0 0.0.0.7

redistribute static

default-metric 1500 1 255 1 1500
  no auto-summary


Hope that helps

dkblee@hotmail.com Fri, 06/04/2010 - 06:07
User Badges:

hi! thanks for the reply. What shd the changes be if branch1 is configured with ospf? the one you suggested is in eigrp? the current setup i'm trying to do in branch1 is in ospf. The DL-switch1 is the one configured with eigrp. pls advise. thx

merryllem Mon, 06/07/2010 - 12:58
User Badges:

So what you are asking is to run EIGRP on the switch and OSPF in the router?


In order for the DL-Swtich and the Branch1 Router to exchange routes they need to use the same routing protocol. With that said, what you are asking is not possible.

dkblee@hotmail.com Sat, 06/12/2010 - 09:11
User Badges:

hi! so you r saying a router connected to a L3 sw, both must be running the same routing protocol or static route, otherwise redistribution of route is not possible? Is that a rule or a limitation?


but i can use 2 different routing protocols between 2 connected routers right?


thx

Actions

This Discussion