C4K_EBM-4-HOSTFLAPPING when q-in-q is used.

Unanswered Question
Jun 1st, 2010

Good day.

We use q-in-q tunnel via catalyst4506->catalyst4900M->catalyst4900M switches. Scheme is attached.There is no any notifications on the 4900m switches but on the catalyst45060

Jun  2 06:51:39.401: %C4K_EBM-4-HOSTFLAPPING: Host 00:13:80:84:F4:31 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:51:49.253: %C4K_EBM-4-HOSTFLAPPING: Host 00:09:12:48:37:42 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:51:53.198: %C4K_EBM-4-HOSTFLAPPING: Host 00:00:0C:9F:F0:01 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:51:54.402: %C4K_EBM-4-HOSTFLAPPING: Host 00:13:80:84:F4:31 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:52:04.566: %C4K_EBM-4-HOSTFLAPPING: Host 00:09:12:48:37:42 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:52:08.898: %C4K_EBM-4-HOSTFLAPPING: Host 00:00:0C:9F:F0:01 in vlan 300 is flapping between port Gi3/1 and port Te1/1
Jun  2 06:52:09.398: %C4K_EBM-4-HOSTFLAPPING: Host 00:13:80:84:F4:31 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:52:20.243: %C4K_EBM-4-HOSTFLAPPING: Host 00:09:12:48:37:42 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:52:22.999: %C4K_EBM-4-HOSTFLAPPING: Host 00:00:0C:9F:F0:01 in vlan 300 is flapping between port Te1/1 and port Gi3/1
Jun  2 06:52:24.407: %C4K_EBM-4-HOSTFLAPPING: Host 00:13:80:84:F4:31 in vlan 300 is flapping between port Te1/1 and port Gi3/1

The problem is that we have the same several macs in different vlans. These vlans are encapsulated into the vlan 300. So it seems like catalyst4506 check only first dot1q vlan-id and think that our mac-addresses are in the vlan 300 and there is a flapping. In fact network is stable, there is no any loops.

IOS - cat4500-entservices-mz.122-37.SG1.bin

Port configuration on the

interface GigabitEthernet3/1
description "QinQ ->s2-fe-1-1-mow-mar8 #171015"
switchport access vlan 300
switchport mode dot1q-tunnel
switchport nonegotiate
mtu 9192
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable

So could you help to find any workaround? Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion

Related Content