QoS for Video

Unanswered Question
Jun 2nd, 2010

Hi,


I need to configure QoS on 2960 SW and also on trunk ports.


I have these values:

Vlan 802.1q CoS 5 and 4

DSCP CoS Trust (CoS will be marked by codec, 5 and 4) :

TCP 1720 DSCP AF31 (26)

TCP 3230:3243 AF31 (26)

UDP 3280:3285 DSCP AF41 (34)

What must be configured on Video port and trunks???

Thanks

v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} p\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} v\:textbox {display:none;} Slayt 3


v\:* {behavior:url(#default#VML);} o\:* {behavior:url(#default#VML);} p\:* {behavior:url(#default#VML);} .shape {behavior:url(#default#VML);} v\:textbox {display:none;} Slayt 3

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Mark Bowyer Wed, 06/02/2010 - 07:19

I also need to know. What QoS needs to be put on the port which the video conferencing unit is connected to? Does QoS then need to be put on every interface in-line with that one e.g. the trunk port and if so, what QoS commands need to be used for those interfaces?

Calin Chiorean Wed, 06/02/2010 - 07:20

If you are sure that you have the marking correct, then on the ports and trunk you have to trust this value:

mls qos

and on the interfaces

mls qos trust cos

or

mls qos trust dscp

Good luck!

muratg7777 Wed, 06/02/2010 - 07:27

I configured nothing. What must the full config including marking commands?

Calin Chiorean Wed, 06/02/2010 - 07:45

Well, you are not giving us much details, but as general rule.

As closer as it can be to the edge of the network (e.g. access port where video device is connected) you have to mark the packets accordingly.

For this one method is to use and ACL like:

access-list 101 permit tcp any any range 3230 3243
access-list 101 permit tcp any range 3230 3243 any

Then you use this ACL in a class-map like:

class-map match-all AF26
match access-group 101

The class-map is matched in a policy-map like:

policy-map MARK-MY-VIDEO
class AF26
  set dscp af26

Then you add this direction input to the access port where your video server is connected:

interface GigabitEthernetx/x
service-policy input MARK-MY-VIDEO

This is just for one class of traffic, you need to to the same for other classes of traffic that you want to mark and group all this under a common policy-map (like MARK-MY-VIDEO)

The you need to prioritize the queue where you match the video traffic to be expedited before other. This has to be done on the L3 devices.

Nevertheless, this is not a point-and-click task. You need to have good understanding of what QoS is and how to configure it. What I pointed here is just some basic rules.

Please rate if you find it useful!

muratg7777 Thu, 06/03/2010 - 01:07

Here is the full info:

Vlan 50 for video

IP Block 10.0.0.0/26

Next Hop: 10.0.0.01

Video IP : 10.0.0.10

For Lan QoS:

CoS Marked with 5 for video and audio 4 for signalling

DSCP CoS Tags :

TCP 1720 DSCP AF31 (26)

TCP 3230:3243 AF31 (26)

UDP  3280:3285 DSCP AF41 (34)

I tried to configure :

policy-map MARK-MY-VIDEO
class AF26

and recieved

class map AF26 not configured  error.

I have also found a sample config:

class-map Video-Conf 
  match access-group 102
class-map Streaming-Video
  match access-group 103
!
policy-map QoS-Policy
  class Video-Conf
    priority 450 30000
  class Streaming-Video
    bandwidth 150
class class-default
    fair-queue
!
! -- Video-Conf Traffic
access-list 102 permit ip any any dscp cs4
access-list 102 permit ip any any dscp af41
!
! -- Streaming Traffic
access-list 103 permit ip any any dscp cs1
access-list 103 permit ip any any dscp af13


and for CoS level 5 and 4btagging what must be configured?

Hitesh Vinzoda Thu, 06/03/2010 - 01:49

Hi

You have to configure in this order

ACL's than Class-map than policy map and than apply to the interface...

Try it and comment back..

HTH

Hitesh Vinzoda

Please rate useful posts

Mark Bowyer Thu, 06/03/2010 - 06:28

We have got a video conferencing unit connected to a 2960. The 2960 is then trunked to a layer 3 3750. We do not currently use access lists. What would we need to configure on both the 2960 and 3750?

Actions

This Discussion