LMS RME 4.3.1 Netconfig job Deploy failed

Unanswered Question
Jun 2nd, 2010

NetConfig job failed:

*** Device Details for xxxxxxxxx ***
Protocol ==> null
Message: Deploy failed.:null

Job Policies
----------------------------------------------------------------------------------------------
Failure Policy: Ignore failure and continue
E-mail Notification: Disabled
Execution Policy: Parallel
Fail on Mismatch of Config Versions: Disabled
Copy Running Config to Startup: Disabled
Sync Archive before Job Execution: Disabled
Job Password: Disabled


Job Approval Details
----------------------------------------------------------------------------------------------
Job Approval: Disabled
Approval List: null
Maker E-mail ID: null

Flow Type:
Device Based Flow.


Task Details
----------------------------------------------------------------------------------------------
Task: ReloadSwitchIn

Commands

----------------

reload in 1:00

I have attached the netconfig job log. Can someone interpret the log and tell me why is this job failing?

Thanks!

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 06/02/2010 - 08:53

You're missing the interactive tags required to perform a reload.  Change your template to:

reload in 1:00
helexis@okstate.edu Wed, 06/02/2010 - 09:23

Attempted the above suggestion with the below results:

ERROR:RME_CDL1022:Failed while locking the device

Job ID: 2691
Owner: crbarke
Description: test reload command on c3650crystal
Schedule Type: Immediate

Job Policies
----------------------------------------------------------------------------------------------
Failure Policy: Stop on failure
E-mail Notification: Disabled
Execution Policy: Parallel
Fail on Mismatch of Config Versions: Disabled
Copy Running Config to Startup: Disabled
Sync Archive before Job Execution: Disabled
Job Password: Disabled

Job Approval Details
----------------------------------------------------------------------------------------------
Job Approval: Disabled
Approval List: null
Maker E-mail ID: null

Flow Type:
Device Based Flow.

Task Details
----------------------------------------------------------------------------------------------

Task: ReloadSwitchIn

Commands
-------------
reload in 1:00

Log is attached for interpretation.

Thanks!

Attachment: 
helexis@okstate.edu Wed, 06/02/2010 - 09:52

Ok now we changed the commands to:

reoad in 1:00 y

...and it is successful but we get an immediate reload. It ignores the 'in 1:00' parameter.

Job log attached.

Attachment: 
Joe Clarke Wed, 06/02/2010 - 10:11

I think it would have worked without the 'y' but the device was locked previously.

In any event, how exactly are you scheduling this job?  Are you using the Adhoc template?

Joe Clarke Wed, 06/02/2010 - 10:36

What appears to be happening is RME is interpreting your user-defined template as a Reload template (which doesn't support any additional options).

I cannot reproduce, though.  I created a new user-defined task called "SwitchMaintenance".  To that task, I added a templated "ReloadSwitchIn".  I made it Enable mode, and added the CLI command:

reload in 1:00y

Then I ran a job, and it worked.  I got a pop-up saying the device would reload in one hour.

Actions

This Discussion