Add ability for any phone to pickup an incoming call to the operator

Answered Question
Jun 2nd, 2010

Hi all,

I am new to managing the phone system and my boss would like the ability to pickup a call that comes into the main line from his phone. Currently his phone does not ring when an icoming call comes in and he does not want it to. I am using cucmbe to manage the system and 7940 and 7960 phones. Any help would be extremely appreciated.

Thanks

I have this problem too.
0 votes
Correct Answer by William Bell about 6 years 6 months ago

Terry,

You can accomplish what you need to do with the Call Pickup feature.  Check the following links:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucmbe/admin/7_1_2/ccmcfg/b03cpkup.html#wpmkr1044902

http://www.cisco.com/en/US/docs/voice_ip_comm/cucmbe/admin/7_1_2/ccmfeat/fscpickg.html#wpxref30558

HTH.

Regards,
Bill

Please remember to rate helpful posts uses the stars below.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Correct Answer
William Bell Wed, 06/02/2010 - 13:50

Terry,

You can accomplish what you need to do with the Call Pickup feature.  Check the following links:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucmbe/admin/7_1_2/ccmcfg/b03cpkup.html#wpmkr1044902

http://www.cisco.com/en/US/docs/voice_ip_comm/cucmbe/admin/7_1_2/ccmfeat/fscpickg.html#wpxref30558

HTH.

Regards,
Bill

Please remember to rate helpful posts uses the stars below.

TGettle0001 Tue, 06/08/2010 - 08:36

Thanks for the links, I went through and seemed to get everything done, except even after I assign the template to a phone it does not change the phone display. I have reset and restarted in cucmbe, restarted the physical phone, all a no go.

William Bell Tue, 06/08/2010 - 09:10

Terry,

I don't follow.  What isn't reset on the display?  Are you looking for the softkey perhaps?  Did you place Call Pickup in the On Hook line state?  Did you put it at the bottom of the list?  On the phone, do you have a "more" soft key displayed?  If you do, when you press "more" what do you see?

Regards,
Bill

TGettle0001 Tue, 06/08/2010 - 09:20

Sorry for not being more clear. There are 3 softkeys being shown currently on the Onhook state, Redial New Call CFwdAll, nothing on the 4th button. I went into the custom template and added the Pickup to the onhook 4th button spot, and there is no more button displayed after doing a reset, etc. Thanks again for your time and help

William Bell Tue, 06/08/2010 - 10:26

Interesting.  I just dug out one of my 7960 phones and tested this out.  I did not have a problem with adding the softkey to the 7960.  I figured it was worth a check given that for many features the 7940/60 phones don't support the feature in the same way as other phones do.  Anyway, not the case here.

What version of CUCM are you running?

Have you been able to add/remove other buttons on the softkey layout?

I am running CUCM 7.1(3b)SU2 here

7960 load P00308000400

Regards,
Bill

TGettle0001 Tue, 06/08/2010 - 11:21

I am using version 6.1.1.2000-3 of CUCMBE, and I have never tried adding or removing buttons prior to this.

One thing I did notice is that when I try to restart the phone from CUCMBE it does not restart, maybe there is some kind of communication issue. I tried creating a different template with fewer options and it still did not work. The phone is registered and makes and receives calls without issue and I have made changes to the display name and other items with no problems.

William Bell Wed, 06/09/2010 - 05:33

Curious.  You may have something else going on.  Some things I would look at:

1. Execute a reset on the phone from CUCM.  (i.e. tell the phone the shut down and reboot).  Do this while you are next to the phone so that you can watch.  If you do not see the phone reset then there is definitely something going on.  I have seen this in clustered environments but not single server environments.

2. Can you TFTP files from the CUCM?  Check basic things like downloading ring tones, etc.

3. Check the bug toolkit for defects related to resets (assuming #1 proves to be a problem)

4. I would also consider downloading the phone config file from the CUCM system to take a look at what's in there.  Maybe overkill.  If you find that the phone does indeed reset (#1) then looking at the TFTP config file is the next logical step.  Assuming security allows for this, you can TFTP a phone's config file from the CUCM using any desktop tftp client.

5. Change the "label" on a phone line (for a phone sitting next to you) and save.  Wait to see if the phone does a restart (and shows the label).  If not, then that process is broken for sure (changes to phone lines should initiate a restart immediately).  Execute a restart manually.  See if the label shows up.

6. Finally, on a phone that has your new softkey template, reset the phone from the phone.  Just pull the power and bring it back on line.  You may want to do this on your on phone or test phone.

That's all I can think of at this point.  Let us know what comes of it.

HTH.


Regards,
Bill

Please remember to rate helpful posts.

TGettle0001 Thu, 07/01/2010 - 14:51

Hi Bill,

Sorry for the long wait, I was on vacation for a couple weeks and then was hammered all last week. I did finally get the buttons to appear on the phone after a restart of the entire system. My problem now is that the buttons are there but they are not working.

When I started there was only one call group for everyone. I thought well if we are all in one group anyway it should just work without creating additional goups, but it didn't. I created another group and added myself and the operator to the group. Still will not work with Pickup or group pickup. Pickup says there is no call, and group pickup just gives me a busy signal if I dial the operator extension or the group #.

I am sure that there is something that I do not have configured properly, but no idea what it is. I attached a screen shot of the group I created to see if that may help.

Thanks again for you time and help.

Terry

Attachment: 

Actions

This Discussion