Cisco 1760 my default GW. Optimizing external interface.

Unanswered Question
Jun 2nd, 2010

Hello, my current setup is....

[comcast 10 Mbps]<----->[Cisco 1760]<------->[Dell PowerConnect 3024]--------[LAN]

I have a WIC-1ENET on my 1760 connected to the the motorola cable modem.  I was wondering if there are any specific commands I should apply to an external interface to improve performance, or keep unwanted traffic from being sent out.

interface Ethernet0/0
ip address dhcp
no ip redirects
no ip proxy-arp
ip nat outside
no ip route-cache cef
no ip route-cache
no ip mroute-cache
priority-group 1
no cdp enable

That is my current setup for my external interface.  I have the priority set for my xbox 360.  So that netflix gets highest priority.  This allows for me to get HD streams 90% of the time, with little to no slow downs from others using the network.  I would like to set full-duplex, but doing so brings the connections to the internet down to a crawl.  I don't know if this is because the cable modem needs to be reset after full-duplex has been set, or what.

I have seen some configurations with a hold-queue value.  Would this help me any?  Speed tests using dlsreports i see about 8Mbps/1.5Mbps down/up.  I have modified the nat tcp timeout to 10 minutes.

Thanks for any information guys.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Hitesh Vinzoda Fri, 06/04/2010 - 00:06

I see little problem here... seems that process switching is on.. Does your CPU peaks up.. check out..

no ip route-cache cef
no ip route-cache
no ip mroute-cache

enable the cef switching which eases the packet forwarding in and out.

add the following commands under the interface.


ip cef

under interface

ip route-cache cef (CEF forwarding)

ip route-cache ( Fast switching)


Hitesh Vinzoda

Pls rate useful posts.

Nathan Cole Sat, 06/05/2010 - 12:24

Thank you!  I wasn't sure if those looked right or not.  You confirmed it for me.

I am going to read up on these some more so that I have a better understanding of exactly what they do.  I have read about CEF briefly before, and knew it helped with switching performance, but wasn't sure what the route-cache did.

Thank you again.

Nathan Cole Mon, 06/07/2010 - 13:36

Issuing the ip route-cache and ip route-cache cef commands caused problems for many clients while playing games.

They could connect to a game at first, but if the game switched maps, or they connect to another game, the client would be unable to connect.

Issuing no ip route-cache and no ip route-cache cef  fixed this problem.  Is there a way to allow route-cache and fix this problem?

Thank you again!

abersven Sun, 06/13/2010 - 08:45

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Regarding the duplex settings on Ethernet 0/0 there are some rules in the standards. If you set the duplex manually on the interface auto negotiation is turned off and requested duplex will not be ‘announced’ to your cable modem. The default behavior according to the standard is for the cable modem to use half duplex. This will also happen if you set Ethernet 0/0 to full duplex since auto negotiation is turned off.

So in order to get full duplex you have two options:

1) Use the command ‘duplex auto’ on Ethernet 0/0

2) Configure both Ethernet 0/0 and your cable modem to full duplex.



This Discussion