Rate-Limit on 3400me

Answered Question
Jun 2nd, 2010
User Badges:

I am having a heck of a time trying to configure rate-limiting on the 3400me switch for outgoing traffic.  I basically have two ports that are facing the switch from a subscriber network and one on the service provider network.


port 1 -> subscriber

port 2 -> subscriber

port 4-> provider


There port 1,2 will be configured with a /30 ip address and a vlan will be passed in through port 4 from the provider network which is also a /30.


policer aggregate NWMNSA_DOWN cir 5120000 bc 960000 conform-action transmit  exceed-action drop



class-map match-all WELLY
match qos-group 5


policy-map NWMNSPA_DN
class class-default
     police aggregate NWMNSA_DOWN


policy-map TEMP
class WELLY
    shape average 5000000


policy-map MARKIT
class class-default
  set qos-group 5



interface GigabitEthernet0/1
description Video
no switchport
ip address 10.10.10.245 255.255.255.252
load-interval 30
service-policy input MARKIT



interface GigabitEthernet0/2
description Video
no switchport
ip address 10.10.10.249 255.255.255.252
load-interval 30
service-policy input MARKIT


interface GigabitEthernet0/4
port-type nni
switchport trunk allowed vlan 555
switchport mode trunk
service-policy input NWMNSPA_DN
service-policy output TEMP


interface Vlan555
ip address 10.10.10.242 255.255.255.252



My Download or input policy takes action like I would expect.  I have tried a ton of configuration choices to try and resolve this.  The problems is I want to share 5Mb between g0/1 and g0/2 and not put input policies on them or rate limit at that point.  On other vendors switches this is so simple.  I can get this to work when i just use the interface as a uni in a similar manner, but the qos-groups must strip when they get routed through the switch.  Basically I am trying to get 5Mb input and 5mb output when i use the switch.  I do not want the total of 5Mb for upstream to be passed up my network and prefer to use the g0/4 to rate-limit the outgoing connection as a group if i can.  I had it working earlier, but the qos-group function didn't apparently matter so I think I hit a bug.

Correct Answer by Giuseppe Larosa about 7 years 2 weeks ago

Hello Jwilde,


thanks for your feedback it makes this a complete story


Best Regards

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
jwilde Fri, 06/04/2010 - 20:50
User Badges:

I think i found a bug i backgraded and it works as i would expect.

Giuseppe Larosa Sun, 06/06/2010 - 11:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jwilde,

for making this case complete may you add what was the initial IOS image running on the device and with what image you have fixed your problem?


Have you done a bug search if so you are allowed to mention the Cisco bug id affecting your system


Hope to help

Giuseppe

jwilde Sun, 06/06/2010 - 11:52
User Badges:

The version I got it working as expected on is:  Version 12.2(44)EY.  The version that I had issues with was me340x-metroipaccessk9-tar.122-54.SE and -53.  I have not looked through the bug reports  on the issue but I may do that later.  I thought I was doing something wrong all along.

jwilde Sun, 06/06/2010 - 16:41
User Badges:

I did not find anything under the bugs.

Correct Answer
Giuseppe Larosa Mon, 06/07/2010 - 09:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jwilde,


thanks for your feedback it makes this a complete story


Best Regards

Giuseppe

Actions

This Discussion