Multicasting across VLANs

Answered Question
Jun 2nd, 2010

Hi All,

I am trying to test multicast streaming across the VLANs and am running into issues. Within VLAN, of course all works fine.

I have configured following on a 3550 Catalyst switch running EMI code. And since I intend to test with couple of other switches and routers, I am setting up this switch as RP ( static).

ip routing

ip multicast-routing

int vlan 2

ip add

ip pim sparse-mode

int vlan 3

ip add

ip pim sparse-mode

ip pim rp-address

int fa0/1

description "Multicast Source"

sw mode access

sw access vlan 2

int fa0/5

desciption "Multicast Receiver"

sw mode access

sw access vlan 3

I am using VLC player set up as muticast source (UDP with group address of at default port of 1234) on a Vista machine on vlan 2 and on XP machine, a VLC player as streaming client to subscribe to this mulicast on vlan 3. I cannot get this stream on client.

Please advise if I am missing anything in configuration.

Appreciate any help.


Devinder Sharma

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 6 years 4 months ago

Check that the TTL for the multicast stream is greater than 1. To be routed across one vlan the TTL needs to 2 at least. You set the TTL for the stream within VLC.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (4 ratings)
Hitesh Vinzoda Thu, 06/03/2010 - 02:16


Check this command on switch

sh ip igmp snooping groups

see whether Fa0/5 is there in the list ?

check sh ip mroute on switch to find the for the group it has vlan 3 as outgoing port.

try statically join the group on vlan 3

int vlan3

ip igmp join-group


Hitesh Vinzoda

Please rate useful posts.

dpsharma Thu, 06/03/2010 - 04:27

Thanks Hitesh. I did verify that under sh ip mroute, I do have group of with vlan 3 as exit port. and sh ip igmp snoop groups has fa0/5. I have not added the group itself to the switch as then switch will subscrive itself to the group as that will cause traffic to be routed to CPU also.

Please advise anything further. I believe my configuration is correct, but I cannot proceed any further if I cannot ever do simple inter vlan multicast forwarding.

Thanks again for your help and I look forward to further advice.

Hitesh Vinzoda Thu, 06/03/2010 - 04:36

I think it could be problem with VLC, try the multicast using "unreal media player server and client". It works good for me and easy to configure and install.


Hitesh Vinzoda

Please rate useful posts.

dpsharma Thu, 06/03/2010 - 06:48

Thanks Hitesh. I will try unreal player and post as to my findings soon.

dpsharma Thu, 06/03/2010 - 09:16

Hi Hitesh,

I downloaded unreal media server and client and I have the same issues. I can subscribe to stream when I am within same vlan as server, but cannot when I put my client in Vlan 3 with server in vlan 2.

I have made sure to keep TTL value to 4.

I have searched around for some examples on Cisco, but most of these use routers, whereas I am looking for some specific one that uses few switches in the LAN and then routed WAN link. I need to simulate multicasting extension over a 100Mbps MPLS WAN circuit between two offices, by creating a GRE tunnel over the MPLS. But I cannot even get thru inter-vlan in a single LAN switch. Any configuration document detailing this kind of set up will be highly appreciated.


Devinder Sharma

Correct Answer
Jon Marshall Thu, 06/03/2010 - 03:03

Check that the TTL for the multicast stream is greater than 1. To be routed across one vlan the TTL needs to 2 at least. You set the TTL for the stream within VLC.


dpsharma Thu, 06/03/2010 - 04:22

Thanks Jon, but I already had set TTL under VLC server to be 4, as I wanted to add other multicast hops on teh way in additon to just inter VLAN. So that does not seem to be the problem. Anything else that I should be looking at?

Appreciate your advice.

dpsharma Thu, 06/03/2010 - 13:12

I have also tried upgrading the image on the switch but with no success. Everything seems to be correctly set up as per Cisco docs.

I find that the multicast group ( set up on the server is being joined by client (on vlan 3) as per the output of "show ip mroute" but I do not see any counters under "show ip mroute count". Visually also, there is brisk activity on the port connecting to server that is streaming but very little activity on the port that connects the client.

Access3550#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*,, 00:08:04/00:02:27, RP, flags: SJC
  Incoming interface: Null, RPF nbr
  Outgoing interface list:
    Vlan3, Forward/Sparse-Dense, 00:05:08/00:02:27

(*,, 00:33:29/00:02:29, RP, flags: SJC
  Incoming interface: Null, RPF nbr
  Outgoing interface list:
    Vlan2, Forward/Sparse-Dense, 00:33:29/00:02:29

(*,, 00:33:35/stopped, RP, flags: SP
  Incoming interface: Null, RPF nbr
  Outgoing interface list: Null

(,, 00:33:17/00:02:59, flags: PT
  Incoming interface: Vlan2, RPF nbr
  Outgoing interface list: Null

(*,, 00:33:37/00:02:28, RP, flags: SJCL
  Incoming interface: Null, RPF nbr
  Outgoing interface list:
    Vlan2, Forward/Sparse-Dense, 00:33:37/00:02:28

Access3550#sh ip mroute count
IP Multicast Statistics
5 routes using 2824 bytes of memory
4 groups, 0.25 average sources per group
Forwarding Counts: Pkt Count/Pkts(neg(-) = Drops) per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group:, Source count: 0, Packets forwarded: 0, Packets received: 0

Group:, Source count: 0, Packets forwarded: 0, Packets received: 0

Group:, Source count: 1, Packets forwarded: 0, Packets received: 45665
  RP-tree: Forwarding: 0/0/0/0, Other: 0/0/0
  Source:, Forwarding: 0/-23/0/0, Other: 45665/0/45665

Group:, Source count: 0, Packets forwarded: 0, Packets received: 0

Mohamed Sobair Thu, 06/03/2010 - 13:22


from the output you have posted, its vital that you dont have hosts joining the group, may be some setup is incorrect in the VLC, or some setup on the source of the multicast stream.

If you could further check is this multicast server has this group configured also.

As a quick testing method, you could just join vlan 3 interface to this group and try to perform testing from the source vlan 2 and check out the output.

If its working, then its propably setting on the source or the reciever.



dpsharma Thu, 06/03/2010 - 13:39

Hi Mohammed,

Appreciate your support on this.

1. I have VLC server set up for this multicast group and it uses UDP 1234 and client is set up for the same.

2. As recommended by you, I have added vlan 3 interface to join this group. Restarted application and client and still the same issue.

3. I have verified several times settings on VLC and they all are okay. I have also tried unreal media server and player and no improvement in thee situation.

4. Any other free multicast test tool that I can use. Not sure if iPerf support multicast streaming but I will look into it.


Here is the relevant config of the test 3550 (EMI IP services image):

hostname Access3550
ip routing
ip multicast-routing
ip igmp snooping querier

interface FastEthernet0/1
description Multicast Source
switchport access vlan 2
switchport mode access
spanning-tree portfast

interface FastEthernet0/6
description Multicast Client
switchport access vlan 3
switchport mode access
spanning-tree portfast

interface Vlan2
description Multicast Source
ip address
ip pim sparse-dense-mode
interface Vlan3
description Multicast Clients
ip address
ip pim sparse-dense-mode

ip pim rp-address

dpsharma Thu, 06/03/2010 - 14:50

Hello Folks,

Looks like I have some progress to report. I had not reloaded the switch, so I did that and I saw traffic start flowing, with no change in configuration.

And for multicast testing, I used a rather simpler way, iPerf. I explored and found that I can use iPerf for multicast also.

Here is what I used for iPerf:

On Multicast source,

iperf -c -u -T 3 -t 100 -i 1   (note it is set up as client uploading to group address, T switch is for TTL)

On Multicast client,

iperf  -s -u -B -i 1 (set up as server to listen to traffic coming in from the multicast group).

And I was able to see lossless traffic being received by this client as reported by iPerf screen.

Please note that iPerf in UDP server mode, the switch B is used to JOIN group, as well as then later listen to traffic coming in from this group address. In regular TCP server mode, switch B is used to bind to the interface (listen thru) in a multihomed machine.

I am documentating this useful iPerf syntax for benefit of others.

I will keep this thread open as I wish to extend my testing to another switch and then to couple of routers to simulate multicast over WAN link.

Meanwhile thanks to all who have advised me on this issue.

Devinder Sharma

dpsharma Fri, 06/04/2010 - 13:32

Hi All,

Further to my posts of yesterday, I extended my testing from one switch (L3) over to second switch (L3) and added two routers to simulate WAN and was able to successfully subscribe to test multicast stream from anywhere, if I use iPerf as detailed earlier. I did use wireshark on both multicast source and client and I could see IGMP exchange and PIM messages as they need to flow.

So today I went back to VLC server and VLC player, but no luck in streaming media thru my test network. I can clearly see that when I fire VLC client, it correctly sends in a IGMP join message ( and leave message on exiting it) and under the WAN router attached to this client ( I have client directly conneect to router port), show ip igmp group now shows the group to be subscribed ( *., but under show ip mroute, I need to see an entry like (, but it is not there. With iPerf, I see all these routes installed.

The router is constantly sending PIM hellos out its interfces, so it should discover the stream group from the upstream routers and switches to which the source is connected. On starting the stream, wireshark shows traffic being sent from source to, and client has sent in join request but still there is no multicast group route being installed in the switches and routers. I have TTL set in application to be 6.

I will doubt that VLC server has some issues, but when I connect these two machines in same VLAN, same muticast UDP stream works fine. But I have also not been able to find any issues with network configuration.

Please advise.

Thanks a lot,

Devinder Sharma

dpsharma Fri, 06/04/2010 - 14:34

Just found the solution and the reason. The VLC version that I am using has issues in setting TTL value thru the GUI interface I used. I found via wireshark that even if I set my TTL to 6, actually TTL was 1. And I used global settings under preferences to set TTL to 6 (stream output, access output, hop limit) and that fixed the issue.

Thanks everyone and have a great weekend.

IM-Design Mon, 08/16/2010 - 09:35


I have a 3560G set up in a lab with 3 vlans and I want to test multicasting across these vlans in order to understand it better before trying to make adjustments to a production network.

I am following this thread and encountering a problem with iPerf settings that you describe above:

On 2 windows 7 machines int he same subnet, I am executing the following:

Client: iperf -c -u -T 3 -t 100 -i 1

Server:  iperf  -s -u -B -i 1

On the server I encounter the following error:

C:\Program Files\iperf-2.0.2\bin>iperf -s -u -B -i 1
bind failed: Cannot assign requested address
recvfrom failed: Invalid argument
Server listening on UDP port 5001
Binding to local address ă‼aă‼aA
Joining multicast group  ă‼aă‼aA
Receiving 1470 byte datagrams
UDP buffer size: 8.00 KByte (default)

C:\Program Files\iperf-2.0.2\bin>

This is iPerf v 2.0.2 precompiled for windows.

Any ideas?


dpsharma Mon, 08/16/2010 - 19:41

I had my machines running Vista, logged in as administrator and never tested with Windows 7.

Did you make sure that, as such the two machines are talking to each other? One reason it will complain that it cannot bind to the multicast address, will be if the interface is not enabled / or associated in case of wireless.

You should also try using the windows XP/Vista machines if available. Also try changing the multicast address, just to make sure that windows 7 is not accepting this address as valid multicast and hence may not be sending out igmp join message. Try using something like, althought the whole 239/8 block is recommneded local administred multicast range, but you never know and the address I had used in my example may be conflicting with some multimedia address used by Windows 7.

Remember, client is acting as server (listening for multicast streams to be received) and server is acting as client.

Devinder Sharma

IM-Design Tue, 08/17/2010 - 10:46

Seems that the problem with iPerf is related to version 2.0.2. I found version 1.7 and your configuration worked for me.

So, next step for me was to test multicating between these 2 vlans using vlc

In doing so I followed the thread, but was not able to see (or hear) the streaming content and the client end

On the server on vlan1 at , this was my vlc command

vlc -vvv Gravity.flac --sout udp: 12

On the client on vlan25 at, this is what I tried:

vlc rtp:[email protected]

Im not getting anything on the client, but I can use vlc to play the file locally on the server.


dpsharma Tue, 08/17/2010 - 11:28

I have iPerf 2.02 for long time. An I had used VLC GUI, so not sure if there is any command syntax isssue with your situation.

For multicasting on a single switch, even without any multicasting config, it shoudl work, as it simply become brodcast. And you just need igmp snooping on the single L2 switch.

Switch config is really simple and I am sure you have followed my example. Then it has to be something with VLC set up. Try using wireshark to see what is the actual TTL.


This Discussion