How to configure Ether-channel between 6513 switches

Unanswered Question

Hello ,


I am trying to configure layer 2 ether channel between two of my core switches which were connected using fiber.


CS1 ( 10.1.1.1)     -----------------------------  CS2 ( 10.1.1.3) CS2 is the standby hsrp switch. we are using eigrp and pvst method.


Gi 13/14                                      Gi 3/1

Gi 13/15                                      Gi 3/2

Gi 13/16                                      Gi 3/3

Gi 13/17                                      Gi 3/4

Cs1: on all ports


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address

channel-group 1 mode on
end


and created  port-channel 1


interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
end


Cs2: on all ports


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address

channel-group 1 mode on

end


nd created  port-channel 1


interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
end


After i did this i lost remote connectivity to both the switches and had to remove the configuration.


Error logs on CS1 core switch:-


Jun  3 14:30:36.293 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/14, putting Gi13/14 in err-disable state
Jun  3 14:30:36.345 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/15, putting Gi13/15 in err-disable state
Jun  3 14:30:36.517 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/16, putting Gi13/16 in err-disable state
Jun  3 14:30:36.733 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/14 in err-disable state
Jun  3 14:30:36.733 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/15 in err-disable state
Jun  3 14:30:36.208 UAE: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/14 in err-disable state
Jun  3 14:30:36.292 UAE: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/15 in err-disable state
Jun  3 14:30:36.348 UAE: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/16 in err-disable state
Jun  3 14:30:36.733 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/16 in err-disable state
Jun  3 14:30:36.913 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/15, putting Gi13/15 in err-disable state
Jun  3 14:30:37.029 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/16, putting Gi13/16 in err-disable state


I am confused in the following things -


1) Is it the right way for creating Layer 2 ether channel  ( Does layer2 eth channel requires manual port-channel to be created?)

2) Since i am not assgning ip to these gig interface can i used pagp/lacp  method and which is the best in this scenario?

3) Wouold like to know the full configuration for the above scenario  using auto /lacp /pagp method?


Highly appreciate all your efforts.


Regards,

KA.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Use the below - fill in the blanks.....


interface Port-channelxx
description <>
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

!

interface <>
description <>
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group xx mode desirable

There are a few little tweaks - but to get what you want, the above will do the trick.

HTH>

Ganesh Hariharan Thu, 06/03/2010 - 18:32

Hello ,


I am trying to configure layer 2 ether channel between two of my core switches which were connected using fiber.


CS1 ( 10.1.1.1)     -----------------------------  CS2 ( 10.1.1.3) CS2 is the standby hsrp switch. we are using eigrp and pvst method.


Gi 13/14                                      Gi 3/1

Gi 13/15                                      Gi 3/2

Gi 13/16                                      Gi 3/3

Gi 13/17                                      Gi 3/4

Cs1: on all ports


switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address

channel-group 1 mode on
end


and created  port-channel 1


interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
end


Cs2: on all ports

Hi,

Few guidelines are there all physical ports should have same duplex and speed settings and assign all LAN ports in the EtherChannel to the same VLAN or configure them as trunks.If you configure an EtherChannel from trunking LAN ports, verify that the trunking mode is the same on all the trunks. LAN ports in an EtherChannel with different trunk modes can operate unpredictably.

Check out the below link for step by step configuration of etherchannel on 6500 series switches

http://www.planetcisco.info/en/US/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/channel.html

Hope to Help !!

Ganesh.H

Remember to rate the helpful post

Hitesh Vinzoda Thu, 06/03/2010 - 23:32

Hi,

I would like to suggest that Shutdown all the ports manually before applying Port channel config. Follow this steps

1. Remove "channel-group 1 mode on" from the switchports which are member of etherchannel on both switches

2. Shutdown the etherchannel ports.

3. Apply the command on Sw-1 under the ports : "channel-group 1 mode on"

4. Apply the command on Sw-2 under the ports : "channel-group 1 mode on"

5. No shut the port one by one on Sw-1

6.  No shut the port one by one on Sw-2

You etherchannel should be up and working.... Coz i have seen this myself when you configure the channel group config when ports are in UP, UP state, it creates a hell lot of problem. Follow the steps mentioned above and you will good to go

HTH

Hitesh Vinzoda

Pls rate useful posts

glen.grant Fri, 06/04/2010 - 04:52

  Yes you can use  pagp or lacp for the channel between them .  We use this all the time and it works well .  As another poster said  have the port channel shutdown while configuring then bring everything  up at the same time . If you try to bring up ports one at a time the results can be unpredictable . We use "channel-group X mode desirable non-silent "  between cisco devices , have never had an issue .

Actions

This Discussion