BGP issues

Unanswered Question
Jun 3rd, 2010

I have two issues. i am running two router using bgp on hotstandby. One router is the primary on one is the backup. the issue are,

1) BGP is not passing the default route

2)  Getting BGP identifier wrong

I would I appreciate any help.

Here is the configuration of the router,

Main router

interface GigabitEthernet0/0
description Internal Network
ip address x.x.41.2 255.255.255.0
duplex auto
speed auto
media-type rj45
standby 1 ip x.x.41.1
standby 1 preempt delay minimum 60
standby 1 track Serial1/0
no mop enabled

router bgp 65000
no synchronization
bgp log-neighbor-changes
network x.x.41.0
redistribute connected
redistribute static
neighbor x.x.41.3 remote-as 65000
neighbor x.x.41.3 next-hop-self
neighbor x.x.188.77 remote-as 209
neighbor x.x.188.77 send-community
neighbor x.x.188.77 default-originate
neighbor x.x.188.77 route-map setpath out
neighbor x.x.22.229 remote-as 209
neighbor x.x.22.229 send-community
neighbor x.x.22.229 default-originate
neighbor x.x.22.229 route-map Swales out
no auto-summary

ip route 0.0.0.0 0.0.0.0  x.x.41.5

ip route x.x.222.0 255.255.255.0 x.x.41.5

Backup router

interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address x.x.41.3 255.255.255.0
duplex full
speed auto
media-type rj45
standby 1 ip x.x.41.1
standby 1 preempt delay minimum 60
standby 1 track Serial1/0
no mop enabled

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

router bgp 65000

no synchronization

bgp log-neighbor-changes

network x.x.41.0

redistribute connected

redistribute static

neighbor x.x.41.2 remote-as 65000

neighbor x.x.41.2 next-hop-self

neighbor x.x.188.77 default-originate

neighbor x.x.188.77 remote-as 209

neighbor x.x.188.77 send-community

neighbor x.x.188.77 route-map setpath out

neighbor  x.x.22.229 remote-as 209

neighbor  x.x.22.229 default-originate

neighbor  x.x.22.229 send-community

neighbor  x.x.22.229 route-map Swales out

no auto-summary

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

ip route 0.0.0.0 0.0.0.0  x.x.41.5

ip route x.x.222.0 255.255.255.0 x.x.41.5

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Thanks,

Jose' Luis Granda

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 06/03/2010 - 11:40

Hello Josè,

bgp router-id can be configured with

router bgp 65000

bgp router-id x.x.x.x

post the route-map configurations they may influence the capability to advertise a prefix including a default route

>>>>neighbor x.x.188.77 route-map setpath out

Hope to help

Giuseppe

jgranda12 Thu, 06/03/2010 - 12:15

Hello Giuseppe, Thanks for the quik response. Here is the router map

Main site for box units

route-map Swales permit 10
set community 13697114 13698023
!
route-map setpath permit 10
set community 13697094 13697114 13698023

Let me know if you need anything else.


Thanks,

Jose' luis Granda

Actions

This Discussion