Viewmail 8.0(3) with Outlook 2010

Unanswered Question
Jun 3rd, 2010

Does Viewmail 8.0(3) work with Office 2010 32-bit on Windows 7 64-bit?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Jaime Valencia Thu, 06/03/2010 - 11:56

Release Notes for Cisco Unity ViewMail for  Microsoft Outlook Release 8.0(3)

Microsoft Windows 7

The following versions of Microsoft Windows 7 are qualified for use with  ViewMail for Outlook 8.0(3) on subscriber workstations:

Windows 7 Professional (32- and  64-bit)

Windows 7 Enterprise (32- and  64-bit)

Windows 7 Ultimate (32- and  64-bit)

Microsoft Windows 7 is not supported with any earlier versions of  ViewMail for Outlook.

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/unity/vmo/release/notes/803cuvmorn.html

Table 1     Supported Version Combinations for  Cisco Unity 8.0(3) with Exchange and the Software on Subscriber  Workstations 

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/unity/compatibility/matrix/cuclientmtx.html#wp395244

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

joe.conger Thu, 06/03/2010 - 12:01

I kind of knew about the Windows 7 support with 8.0(3).  How about the Outlook 2010 Support.

drosenfield Mon, 06/14/2010 - 01:22

Hi

was able to have this work on Windows 7 32-bit & Office 2007, Upgraded to Office 2010 and was still working fine. One day it just stopped working for no apparent reason and we are now unable to make it work again. Either the form doesn't install or if it does install it doesn't run. Anyone worked round this yet?

Darren

drosenfield Mon, 06/14/2010 - 04:34

Hi

I have now spent a bit of time on this. It seems that you have to manually add the form. If you open the viewmail.oft from the viewmail folder you can then publish this to your personal form store. It needs to have a name of ipm.note.voice.unity. The description by default is Viewmail for Outlook. You may get an issue when you try to run the form. This can be corrected by adding a key to the registry for activeX. If you google one off forms for outlook you'll find the right key.

hope this helps

Darren

drosenfield Tue, 06/15/2010 - 23:44

Hi Nash

I'll try and break this down into steps

firstly you will need to add the reg key needed to allow you to open the forms, it is more than likely this that has stopped the whole thing from working.

I used this this link for this info http://www.outlookcode.com/article.aspx?id=67

you will see at the bottom the key

To use a registry entry, add a DWORD value named AllowActiveXOneOffForms to the HKCU\Software\Microsoft\Office\11.0\Outlook\Security I set mine to 2 but you can try a lower setting if you like

1. Inside outlook 2010 turn on the developer tab

2. Select choose form from the developer tab ribbon

3. select user templates in filesystem then browse

4. find the location of your viewmail install, c:\program files\viewmail by default, select ok

5. you should now see the voicemessage.oft, select this and press open

6. you should now be looking at a blank viewmail form.

7. select the developer tab again and the publish button

8. set the display name as viewmail for outlook and the form name as voice.unity and publish you will see the message class at the bottom automatically becomes ipm.note.voice.unity

I think thats all I did to make it work but may have changed other things while testing. I have tested this procedure on another machine since and seemed to do the trick.

hope it helps and good luck

Darren

snicklas Thu, 07/22/2010 - 11:27

This is worked for me thanks a bunch......only outstanding issue I have is that it does not seem possible to get VMO shortcut icon to appear in the Outlook tool bar.  Instead you just need to manually open the newly created form.

tmking001 Mon, 08/16/2010 - 16:19

I tried the registry key and the manual publishing of the *.oft file, but I've got some computers that work and others that still receive the "To prevent malicious code" error.  I've thus far been unable to find how these systems might differ.  It's definitely not linked to the user's Exchange mailbox itself as I can log in on two different PCs with the same user account and have one work and the other throw the error and refuse to open the form.

If anybody finds the magic bullet I'd be really interested to know.  Also, is Cisco working on an updated version of the client to properly add it's menus to Outlook 2010?

MikeM-2468 Wed, 12/15/2010 - 07:37

I wasn't able to make the registry change through regedit.  The Security key was hidden and I couldn't get to it.  I ran the following and it worked:  

Reg add HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Security /v AllowActiveXOneOffForms /t REG_DWORD  /d 1

I have one outstanding issue with getting this to work.  On Outlook 2007, I'd select Tools, Viewmail Options to set the server and extension information.  Where is that in 2010?

MikeM-2468 Wed, 12/15/2010 - 09:47

I found that the first time I tried to open a message, it would prompt for the extension and the server.  It only does that once.  In order to change, if necessary, I found that the information is stored in the registry at:

HKEY_CURRENT_USER\Software\Cisco Systems\Cisco Unity\Media Master\Profiles\default

There are two keys, one for the extension and one for the server.

"Telephone Record and Playback extension"="1234"
"Telephone Record and Playback server"="IP or hostname"

So far, so good on Outlook 2010.

luda_ryt2010 Thu, 12/16/2010 - 08:07

The information provided work for me for the most part.  I'm trying to get the message to play by clicking on the arrow,

like I did before Office 2010 and I get nothing.  If I click on the .wav file below that, it will open MS media player and play.

Any insight on getting it to play this way?

Thanks.

MikeM-2468 Thu, 12/16/2010 - 08:32

When you first opened the email containing the voicemail, were you prompted to add the extension and the server?

luda_ryt2010 Thu, 12/16/2010 - 11:29

Yes, I changed the settings for both ext. and server. I also changed the output to play on the PC speakers and record on the phone..

As I stated, it plays fine if I click on the .wav file. Any ideas?

Thanks.

MikeM-2468 Thu, 12/16/2010 - 12:24

Seems to me that Viewmail isn't working at all for you.  You should be able to play the wav file by clicking on it without ever installing Viewmail - seems like that's the functionality you're seeing.

I have mine playing back to the phone, so there might be some other limitations that I'm not seeing.  Where do you change the output?  I don't have the menu item.

Sorry I can't offer any more.

luda_ryt2010 Thu, 12/16/2010 - 12:32

Here is partial screen shot of how we've always changed the playback devices, and under “Options” for the server/ext. options.

Thanks anyway.

Attachment: 
gregwilkinson Fri, 12/17/2010 - 11:56

I have this same problem and it's been plaguing me for months.

I've applied the registry/developer form workaround, but it only seems to work sporadically in our office.

With my playback device set to my soundcard, I click on the arrow and nothing happens. I can get it to play through my phone, but that is of no use to me. I got upgraded recently to a new laptop. Office 2010 and Viewmail were the first things I installed to prove this wasn't a conflict caused by another program. Same problem.

We don't have time to try this workaround at every user's machine: We need a compatible version from Cisco or management will begin asking why don't we switch to a competitor.

tmking001 Mon, 12/20/2010 - 07:35

Greg,

Which version of the ViewMail client are you using?  If you're using the 8.x client you may be experiencing the same issues I ran into.  I could not get PC playback to work at all with that version.

We're currently using the 7.0(4) version of the client without issue.  Both playback to PC and phone appear to work fine.  Of course there are still no menus available outside the ViewMail form itself, but it does work.

You may run into a problem after removing the 8.0(3) client and installing 7.0(4).  In our situation we found that Outlook would throw an error stating it was blocking macros in the form due to security restrictions, although that's not verbatim.  I found that there was a single registry key left behind by the 8.0(3) client that caused this problem.

If you run into that issue let me know and I'll post the registry key you need to remove.

Regards,

Ty

gregwilkinson Mon, 12/20/2010 - 08:47

Ty,

Thanks for the help.

I've rolled back to version 7.0.2 (Cisco doesn't list a 7.0.4)

I'm getting these errors in order:

1. Could not load an object because it is not available on this machine.

2. Viewmail for Outlook has either never been installed on this machine or has been uninstalled. The form will now be unpublished from your inbox.

If I try to re-publish the form, I get the "to prevent malicious code" error.

This may not be exactly what you saw, but would you mind posting the registry key that needs to be deleted to see if it resolves this issue?

tmking001 Mon, 12/20/2010 - 09:01

Greg,

Sorry, I did mean 7.0(4).  Their versioning gets confusing.

Here's the registry information.  If you paste the following into a .reg file and run it I've formated it to simply remove the key automatically.  This does only apply to Windows XP from what I've seen so far.  It's probably a different key in Windows Vista or 7.  I didn't attach the file simply because I'm not sure if this forum would block an reg file.

__________________________________________________________________________________________

Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{4CD89391-F289-11d2-8E6B-00C04FF0D76F}]

"Compatibility Flags"=-

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{4CD89391-F289-11d2-8E6B-00C04FF0D76F}]

__________________________________________________________________________________________

Let me know if that doesn't work.  I have a Windows 7 computer that I can probably run the installer for 8.0(3) on, uninstall it, then run a before/after snapshot on the registry.  That's how I figured out what the key was on WinXP.


Regards,

Ty

richardbergen Mon, 01/17/2011 - 12:00

Just curious which unity 7.0(4) client you are using? I can't seem to find the one you guys are talking about.

Got to the point where I had same problem with 8.0(3) where when I hit the play button in the email message in outlook 2010 / windows 7 64 bit, it would play through the phone but not through speakers.

Wouldn't mind trying th 7.0(4) client, but there are so many unity client options that I have no idea which one to choose!

thanks for your help!

gregdeese Tue, 02/22/2011 - 11:32

First off thanks to all who have replied to this thread.  All the  information was very helpful and allowed me to resolve the issue of only  playing the v-mail via the phone after installing 8.0(3).  Upgrading to  8.0(4) and going through the registry update/custom form publishing  process worked perfect.  However, I'm looking for any info on an  automated process for publishing the voicemail.oft form with Outlook  2010.  The registry update we can do via the login process but we're  trying to work around having the Help Desk manually publish the form for  all our users as they're upgraded to Win7/Office 2010.  Has anyone  worked out a trick for that process? Any additional info that can be  shared is greatly appreciated.  Thanks.

Actions

This Discussion