Cisco Presence 6.0.3 Upgrade Issue

Unanswered Question
Jun 3rd, 2010
User Badges:

Hi Guys,

      I have some issues upgrading Presence server. The existing presence server is I am trying to pgrade to 7.0.6.x.x.x

When i insert the DVD and upgrade from DVD. the system doesnt show me any error MSGS..after i get upgrade complete .I tried to switch to newly created inactive partition 7.0.6x.x.x.

I tried from GUI and cli.. but nothing happens..

admin:utils system switch-version ?
utils system switch-version
no parameters are required

admin:utils system switch-version

Active Master Version:

Inactive Master Version:

Do you really want to switch between versions ?

Enter (yes/no)? yes

Switching Version and Restarting the Appliance ...

Please do not close this window until you see a Broadcast
message from root.

Version switch has has been submitted.  This can take a long
time depending on the platform and database size.  Please continue
to monitor the switchover process from here.  Please verify the
system restarts and the correct version is active.


My questions are

1) which command can i use to see whats happening.

2) Where can i read the logs ?

Because nothing happens i am very curious to know.. Can anyone guide that whats going on and how can i fix this situation..This has wasted my 1 day..

Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
htluo Fri, 06/04/2010 - 05:42
User Badges:
  • Red, 2250 points or more

You may use the Disaster Recovery CD to boot into another version.

Or you may open a TAC case.  I think it's a bug.


amitpalsinghbatra Mon, 06/07/2010 - 14:31
User Badges:

Hi Htulo,

         Thanks for your reply.

I think i couldnt explain it properly. Let me try one more time. This is how i try to upgrade.

1) I insert the DVD

2) Go to the OS administration page and click on upgrade from local DVD /

3) It starts upgrdaing the system.

4) After this option..

Status: Ready
Installed Versions
Active Version6.0.3.1000-12
Inactive Version7.0.6.10000-17

5) Now i click on switch version button and this message appears..


Warning MessageA switch version request has been submitted. This can take a long time depending on the platform and database size. Please continue to monitor the switchover process from the Cisco Unified Communications OS Platform CLI. Please verify the system restarts and the correct version is active.

I wait for 2 days and system never restarted...Nothing happened.. System is still running on 6.0.3..

When i do the same thing from the command line the result is same...

Is there is any command and anyway i can read some logs to understand on whats happening.....

I just wanna have some visibility on whats going on in the system...


htluo Mon, 06/07/2010 - 14:33
User Badges:
  • Red, 2250 points or more

You may review the installation logs (either with RTMT or CLI).

But at the end of the day, you still want to switch to the new version.  My suggestion is to boot from a recovery CD and switch version from there.


amitpalsinghbatra Tue, 06/08/2010 - 01:28
User Badges:


This is what and tried.

1) upgrade the CUPS 6.0.3 to version 7.0.3..

restart server.

2) After upgrade successfuly i used 7.0.6 recovery disk.(I donot have 7.0.3 recovery disk)

3) recovery disk boots properly.

4) I get an option to change active partition.

5) change active to 7.0.3..and restart system

6) System comes up with 7.0.3 as expected..

After this i did some tesing..things worked fine as expected... i was able to achieve 90% success out of my presence testing..

Clients can see the status, dial using the dial pad things like that...

Now i restart the system again just for the sake of my satisfaction...

I came up fine.. No probs.. Tested all features again.. No probs...

Since my objective is to upgrade the server to 7.0.6..An idea came in my mind...wy switch to 6.0.3 back..upgrade to 7.0.6 this time and use the system recovery disk once and test...

Now what happened is ..

1) I login into the system using command line.while it is running 7.0.3.. because i wanted to switch to 6.0.3 back..

2) i issue this command utlis system switch-version

3) the system start giving me trouble staright away..

I restart the system and system comes up with ETH0 down and has no IP...

I dont know what went wrong and why i lost the static IP ???

During restart it came up with this message ..

("" Checking network connectivity..

System doesnt have static IP configured "..)

system comes up and i cannot access the server remotly..

login into command to check the eth0 status and found that

no ip

eth0 down...disabled.

I tried to bring it up via command line and set IP command command line .. But no luck...

Any advice ???

Thanks in advance



This Discussion