Outlook IMAP client authen to CUCMBE-UC with LDAP/AD integration

Unanswered Question

I have a CUCME 7.1(3). instlallation which is integrated into AD's LDAP for user population and authentication.  Users can log into the UC PCA (/ciscopca)

and authenticate their username/password against AD successfully.

I'm trying to setup Outlook clients but I cannot authenticate my client when testing the connection to UC. My username's SMTP address is [email protected]

and when I set-up my IMAP outlook client I am using an email address of [email protected], server information for IMAP has incoming and outgoing server address 10.1.1.1 (10.1.1.1 is my CUCMBE-UC address). I am using my username and password which works for ciscopca access (via AD authen). But when I test my connection it just kicks back the test that the log in failed.

Is there a problem with authentication IMAP clients to UC-IMAP when AD auth/integration is used in Business Edition or am I missing something.

THANKS!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (5 ratings)
Loading.
David Hailey Wed, 06/09/2010 - 19:45

Based on what you have written, I believe the best bet for you would be to review the IMAP configuration steps and examples in the CUC System Administration guide here:  http://www.cisco.com/en/US/docs/voice_ip_comm/connection/7x/administration/guide/7xcucsag175.html

Unity Connection has it's own SMTP domain so the user's SMTP address would be user@.  One tip for using the user's corporate email address as opposed to Connection-specific info is:

Configure the corporate email address of each user  as an SMTP proxy address for the user. When setting up the Connection  IMAP account on user workstations, use the corporate email address of  the user, rather than the Connection-specific email address, in the IMAP  settings. In this way, users do not need to know an extra set of email  addresses for addressing voice messages in the email client, and are  insulated from changes to the Connection-specific addresses if the  Connection SMTP domain is changed.

Read thru the guide and see if you can get it straightened out.  If you still have problems, just ask.

Hailey

Please rate helpful posts!

zane.england Wed, 06/09/2010 - 23:32

are you using LDAP over SSL if so there is a bug that prevents IMAP from working for accounts that are sync'd with  LDAP but if you are using local passwords will work

Zane,

  Thanks for the reply. No, LDAP is not using SSL. Although it does seem like it is something to that affect. All I'm trying to do is get my voicemail in email. I've got my exchange account built- email [email protected]. (cucm1.acme.com resolves to the Connection/CUCMBE server. Server information: IMAP and incoming/outgoing mail server is the ip address of the connection server. Userid=jdoe and password is what I use and am able to log into Cisco PCA using. In Connection, my user's SMTP address=[email protected].

  It seems I'm missing something stupid. I can log into Cisco PCA using my AD authentication information.

zane.england Thu, 06/10/2010 - 16:05

The bug i was refering to is CSCsy48064  and you can still log into ciscopca just imap doesnt work

Create an account that isnt associated with AD in unity and try to use that for IMAP

David Hailey Thu, 06/10/2010 - 18:21

Out of curiousity, in the Class of Service assigned to the user - did you enable IMAP?  You would need to check the box for Allow Users to Access Voice Mail Using an IMAP  Client.

You would then need to select one of the following:

Allow  Users to Access Message Bodies

Allow Users to Access  Message Bodies Except on Private Messages

Allow Users to Access  Message Headers Only

Hailey

Please rate helpful posts!

David Hailey Sat, 06/12/2010 - 11:46

So, there is one portion of the document that I sent you I'd like to focus in on and ask if you've tried this and, if not,

please do:

Configure the corporate email address of each user  as an SMTP proxy address for the user. When setting up the Connection  IMAP account on user workstations, use the corporate email address of  the user, rather than the Connection-specific email address, in the IMAP  settings. In this way, users do not need to know an extra set of email  addresses for addressing voice messages in the email client, and are  insulated from changes to the Connection-specific addresses if the  Connection SMTP domain is changed.

In other words, you would have the following:

AD User = jdoe

CUC User = jdoe (synced from AD)

Corporate SMTP/Email Address = [email protected]

CUC SMTP/Email Address = [email protected]

For jdoe's CUC user account, configure the SMTP proxy address to be the corporate email address ([email protected]).

When you set the IMAP connection in Outlook, specify the SMTP Proxy Address as the connection name NOT the CUC SMTP address.  You would also provide your AD password just like you do with PCA.

Have you tried to see if that yields different results?

Hailey

Trent Hewitt Tue, 05/17/2011 - 21:24

Hello,

Did an answer for this ever come up? I am experiencing the same exact problem and its driving me insane!

Trent

Actions

This Discussion