Multicast across different vlans

Unanswered Question
Jun 4th, 2010
User Badges:

Hi all,


We have devices in different vlans that needs to talk on multicast. We have 2 devices per vlan . We can see only the 2 device, when we see in the same vlan and do not see other devices.


6509crs1#sh ip mroute 239.195.1.2 co
IP Multicast Statistics
22 routes using 8620 bytes of memory
16 groups, 0.37 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.195.1.2, Source count: 4, Group pkt count: 0
  RP-tree: Forwarding: 0/0/0/0, Other: 0/0/0
  Source: 172.16.208.203/32, Forwarding: 0/-1/0/0, Other: 161950/0/161950
  Source: 172.16.208.204/32, Forwarding: 0/-1/0/0, Other: 16230/0/16230
  Source: 172.16.211.52/32, Forwarding: 0/-1/0/0, Other: 58298/0/58298
  Source: 172.16.216.225/32, Forwarding: 0/-1/0/0, Other: 16227/0/16227


Any help on how we can send multicast over different vlans.


Thanks in Advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Fri, 06/04/2010 - 12:10
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Dhanasekaran.r


you need to enable ipv4 multicast routing and PIM dense-mode on layer 3 interfaces as a minimum


on each network device


ip multicast-routing


int vlan x

ip pim dense-mode


int vlan y

ip pim dense-mode


int vlan z

ip pim dense-mode


use of PIM sparse mode is more efficient but as a start you need to configure the above lines including the L3 interfaces between different network devices not only client vlans


Hope to help

Giuseppe

dhanasekaran.r Fri, 06/04/2010 - 12:21
User Badges:

Hi Giuseppe,


Thanks, I have enabled IP PIM Sparse-dense mode on all Vlans across network, I have ip mulitcast routing enabled. If you see the output the OIF Counter is increasing . Looks like Multicast is not finding route,, wild guess ..

Giuseppe Larosa Fri, 06/04/2010 - 12:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

you may need to set an RP in order to make it to work


There have been some discussions about this even if PIM sparse-dense mode can treat some groups as dense an RP address for some groups have to be configured


Hope to help

Giuseppe

Giuseppe Larosa Fri, 06/04/2010 - 13:58
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,

sorry I missed to give an example


config  t


ip pim rp-address x.x.x.x acl#


the acl# will tell for what groups the RP will be working ( group to RP mapping it  can be checked with sh ip pim rp mapping)


and x.x.x.x is typically a loopback interface of one router that will act as RP and it needs to be advertised in the unicast routing protocol in use in your network.


this has to  be done on all routers including the one that has the RP address


see this chapter in 12.4T multicast config guide


http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_basic_cfg_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1054581


to be noted groups not matching the ACL will be treated in dense mode


Hope to help

Giuseppe

dhanasekaran.r Fri, 06/04/2010 - 14:55
User Badges:

Hi,


Thanks, The RP is configured earlier. I did not understand the RP group. By the way below is the output.


The setup is like there are 15 vlans configured with intervlan routing enabled on EIGRP. RP is configured on router. IP Pim Sparse mode or IP Pim sparse-dense mode is configured on all Vlan interface. I have also configured ip CGMP also. Ip multicast routing is enabled in all routers.


6509crs1#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s) 224.0.1.39/32
  RP 172.16.0.200 (?), v1
    Info source: local, via Auto-RP
         Uptime: 7w0d, expires: never
Group(s) 224.0.1.40/32
  RP 172.16.0.200 (?), v1
    Info source: local, via Auto-RP
         Uptime: 7w0d, expires: never
Group(s): 224.0.0.0/4, Static
    RP: 172.16.0.200 (?)



Still i am not able to reach through multicast to the devices in other VLAN.

Giuseppe Larosa Sat, 06/05/2010 - 14:06
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Dhanasekaran,


post the relevant configuration of multicast commands in your devices, it looks like you have already set a manual RP for all the multicast address space.


Have you configured the ip pim rp-address 172.16.0.200 also on the device that owns this address?




with this configuration you should work in PIM sparse mode for all groups (224.0.0.0/4) except the special groups used by autoRP and listed in sh ip pim rp mapping output


Hope to help

Giuseppe

Actions

This Discussion