SFP ports on 7200 NPE-G2

Unanswered Question
Jun 4th, 2010
User Badges:

I'm trying to use the gig0/2 SFP port on an NPE-G2.  I've set the media-type to SFP, used a know good SFP-GE-L (single or multimode) and a known good SM patch and for whatever reason the interfaces keeps going line up protocol down immeadiately after I turn up the interface.



I get a message saying %ENTITY_ALARM-6-INFO: CLEAR INFO GI0/2 physical port administrative state down, but the port does not show admin down when I do a show interface.



I'm running disk2:c7200p-adviperserviesk9-mz.124-22.T5.bin


Any help would be apprciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
francisco_1 Fri, 06/04/2010 - 11:10
User Badges:
  • Gold, 750 points or more

I think your problem might be related to auto negotiation. When the interface is configured for negotiation auto, the interface advertises all modes of which it is capable. The link only comes up if the negotiation process succeeds in finding a common mode between the Cisco 7200 SFP media type and its link partner


To turn this negotiation auto feature off (it is on by default), issue the interface command no negotiation auto


Francisco

w951duu Fri, 06/04/2010 - 11:23
User Badges:

Unfortunately that didn't work, now both line and protocol are down.  a sho

w controllers shows that media is not connected, but this is a known good SFP and the fiber is good as well (I tested it on a cat6500 first).

francisco_1 Fri, 06/04/2010 - 11:36
User Badges:
  • Gold, 750 points or more

have you tried  issued

media-type gbic


in interface configuration mode?


Francisco

francisco_1 Fri, 06/04/2010 - 11:47
User Badges:
  • Gold, 750 points or more

strange!!!. I dont think it's related but below is the compactability matrix for IOS supported.



NPE-G2

GLC-SX-MM

SFP-GE-S
SFP-GE-L
SFP-GE-Z
CWDM SFP


12.2(33)SRC2
12.4(15)T7
12.4(20)T1

12.2(31)SB2
12.2(33)SRC2
12.4(15)T7


Do you have another SFP to try? Unapproved SFP modules will not be enabled.



Francisco.

w951duu Fri, 06/04/2010 - 11:58
User Badges:

The SFP-GL-E is the one we are using and it's in the supportability matrix. I've tried another model that's MM only and it's working just fine.


The SFP that fails in the NPE-G2 is working just fine in a catalyst. So, I'm kind of at a loss.

francisco_1 Fri, 06/04/2010 - 12:15
User Badges:
  • Gold, 750 points or more

Accroding to CISCO the following SFP modules are supported on the NPE-G2:  SFP-GE-S, SFP-GE-L, and SFP-GE-Z



Francisco.

huangedmc Fri, 06/04/2010 - 20:16
User Badges:

How far away is the neighbor device?

Perhaps you exceeded the max. supported distance?


We recently had a problem turning up a link, which we thought was within the supported range of LH.

Turns out we're just a bit out of the range, and had to use ZX SFP instead.


Did you already have your fiber provider test end to end?

tprendergast Fri, 06/04/2010 - 12:09
User Badges:
  • Silver, 250 points or more

Gregory,


Please post up your interface configs from both sides (show run interface gi0/2). What is the other side of the connection? (module type, device/blade type, etc).


Are you doing direct-to-device connection, or running through a patch panel? If you put a loop connector in, does your interface stay up?


Post those up so we can better assist.


Thanks!

Tim

jwilde Fri, 06/04/2010 - 20:58
User Badges:

try a loopback (one fiber) on send/receive and see if it comes up then you will know if one of the above comments are your problem.

Actions

This Discussion