me3400 +QOS marking

Unanswered Question
Jun 4th, 2010

I was wondering if the DSCP identifier is supposed to be stripped when going through a routed port.  I am using a qos-group of 5 for marking on two different ports.  One stays on the same vlan when I network trace it and the other is routed before I see it.  These are on the same switch btw so there is no other switch stripping anything.  I see the DSCP identifier of 5 when sniffing the LAN port, however, when I look at a packet that has been routed i see a dscp identfier of .0 vs the 5 I mark it as.  I found that kind of strange but maybe that is expected behavior on a metro ethernet switch.  I have weird problems beyond that however.  When I remove the packet identifier altogether my service policy is acted on even though it shouldn't.  It works like i would expect when going through a vlan but not like what I would expect when routing it before my policy-map.  Part of my config may make it more clear:

*** This one works as expected ****

interface GigabitEthernet0/1
description School LAN
switchport access vlan 556
load-interval 30
service-policy input SETPRIORITY

class-map match-any video
match access-group 10

policy-map SETPRIORITY
class video
  set dscp af41
  set qos-group 5

access-list 10 permit any

******** Gets shaped from the output access-list on 4 ***********

interface GigabitEthernet0/2
description Video
no switchport
ip address 69.165.20.249 255.255.255.252
load-interval 30

******* QOS service-policy ***********

interface GigabitEthernet0/4
port-type nni
switchport trunk allowed vlan 555,556
switchport mode trunk
service-policy output IUP

class-map match-all WILDE
match qos-group 5

policy-map IUP
class WILD
    shape average 5000000

Now why would it shape the routed port?  Is this because it is a bug or?

This is on the version me340x-metroipaccessk9-tar.122-53.SE

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jwilde Fri, 06/04/2010 - 20:55

i am guessing this is a bug because i backgraded and did multiple tests and it seemed to work.  It was on a earlier series of code which sux because i like some of the new features in the new code, or the old code had bugs.  code version i'm using now that worked is  Version 12.2(44)EY

Actions

This Discussion