UC-540 Wireless signal issues

Unanswered Question
Jun 5th, 2010

We replaced our Cisco 877W with a brand new UC-540 from Cisco in January 2010.

We setup the UC-540 via wizard. Upon use,  we immediately noticed a decrease in wireless signal strength and dropped connections every three minutes or so - even when within feet of the device when compared to the Cisco 877W.

We first attributed the issue to the slightly more enclosed mounting location, or the additional metal shelving. . We were just about to pay for a professional site survey to rule out radio interference when we discovered a a reference from http://uc500.com/en/uc520w-built-wifi-fluctuating-rf-levels.

We decided with Cisco's STAC to test the following solution before RMA'ing the unit as faulty;

antenna receive right
antenna transmit right

It worked! Our signal strength is much better and we have yet to drop a connection after two weeks of regular use.

Did Cisco fail to consider that there is only one antenna in this device?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
David Hornstein Sat, 06/05/2010 - 22:41

Excellent stuff  Brook,

Thank you very much for this input and bringing this to the attention of the wider public, your comments are indeed accurate and relevant.

I looked up this issue and found this issue mentioned in an release note regarding CCA version 2.

see reference:

http://www.ciscosystems.cd/en/US/docs/net_mgmt/cisco_configuration_assistant/version2_0/release/notes/OL159332.html

It mentions an issue discovered and CSCtg07290 workaround;

CSCtg07290


CCA should set antenna TX/RX to right (primary) under dot11 radio interface on UC 520 and UC 540 platforms with integrated wireless


Symptom Poor audio and dropped calls for wireless phones connected via the integrated wireless access point on the UC 520.

Workaround The only workaround for this issue is to access the device CLI and configure the "right" setting under the dot11 radio interface for both transmit and receive.


UC520(config-if)#antenna ?
   gain        Configure Resultant Antenna Gain
   receive    receive antenna setting
   transmit  transmit antenna setting


UC520(config-if)#antenna receive ?
   diversity  antenna diversity
   left          antenna left/secondary
   right        antenna right/primary

regards Dave

David Trad Sun, 06/06/2010 - 20:38

Hi Brooke,

Found this one out the hard way, good o'l Dave Harper pointed this out to me after a week and a half of torment with one client... I am so glad you posted this as I totally forgot to


I am not sure why a dipole chipset was put in one of these boxes although they only carry one antenna, pity there is no way to add the secondary antenna and use the chipset to their full advantage.

Cheers,

David.

Brook Powers Sun, 06/06/2010 - 22:52

Ugh. I had to reset my UC-540 and now I cant find my way to Dot11Radio Interface again.

The following is useless to me as far as assisting in the configuration of the device;

UC520(config-if)#antenna ?
   gain        Configure Resultant Antenna Gain
   receive    receive antenna setting
   transmit  transmit antenna setting


UC520(config-if)#antenna receive ?
   diversity  antenna diversity
   left          antenna left/secondary
   right        antenna right/primary

Would someone mind providing the correct commands starting after logging into the device via telnet.

Thanks,

David Trad Sun, 06/06/2010 - 23:29

Hi Brooke,

You need to go to the interface to do it, please see below:

ROUTER#(config)#interface Dot11Radio0/5/0

ROUTER#(config-if)#antenna receive ?

  diversity  antenna diversity
  left       antenna left/secondary
  right      antenna right/primary

ROUTER#(config-if)#antenna receive left..errrr or is it right MEH! i forgot LOL

Have a go at that.

Cheers,

David.

Brook Powers Mon, 06/07/2010 - 14:22

Everything is tied to the right amtenna on my UC540. I was doing;

ROUTER#(config)#interface Dot11Radio0

and

ROUTER#(config)#interface Dot11Radio1

but getting no where.

For other resons I reset the device to defaults and its working fine. It must have been an upgrade along the way that set the antenna's back to diversity.

That just goes to show you that upgrades sometimes have no respect for your existing configuration and if you dont have a need for the fixes upgrades provide, the upgrade may make things worse.

Thanks David!

David Trad Mon, 06/07/2010 - 15:18

Hi Brooke,

That just goes to show you that upgrades sometimes have no respect for your existing configuration and if you dont have a need for the fixes upgrades provide, the upgrade may make things worse.

I'm a sucker for new upgrades, it gets me into a lot of trouble, I call it the Homer Simpson syndrome, I keep going back for more even after I have burnt myself.

Cheers,

David.

Brook Powers Wed, 06/09/2010 - 18:16

Well, resetting it to factory defaults did not, in fact resolve the random drops and waves of poor signal strength.

The problems reared their head after just a few days.

Here is what I just tried, based on David Trad's advice;

ROUTER#config

ROUTER#(config)#interface Dot11Radio0/5/0

ROUTER#(config-if)#antenna receive ?

This returns the current (and factory default) settings, below

  diversity  antenna diversity
  left       antenna left/secondary
  right      antenna right/primary

If I type;

ROUTER#(config-if)#antenna receive right

Sets receive to the right antenna - the only one physically present

ROUTER#(config-if)#antenna transmit right

Sets transmit to the right antenna - the only one physically present

And run

ROUTER#(config-if)#antenna receive ?

or

ROUTER#(config-if)#antenna transmit ?

I get;

  diversity  antenna diversity
  left       antenna left/secondary
  right      antenna right/primary

NOTHING has changed.

What am I missing?

Is there something to do with the diversity command?

David Trad Thu, 06/10/2010 - 03:46

Hi Brooke,

What am I missing?

These may be stupid questions but I think we need to start somewhere

  • Is the appliance housed inside a cabinet?
  • Is the appliance surrounded by a lot of electrical devices/cables? (Within close proximity)
  • Is there a lot of other Wireless access points in the vicinity (Within a 50-100 Meter radius?)
  • Is the Appliance set as WPA?
  • Have you changed the channel it is using? I.E tried another channel other then the auto scan? (Look at forcing it onto channels 6 or 11 for testing)

I have one UC-500 deployed right now where we have had to force it onto one particular channel, it would not work on any other due to congestion in the area, even still it is not stable as much as what an 877W would be or an 1141, but it is doing the job just (and for now).

You can also consider the following:

  • Purchasing a Cisco approved wireless antenna that has a higher DB rating (So long as it is not illegal in your area)
  • Disbanding the inbuilt wireless and purchasing a 11XX AP which in any event would be much more powerful/stable over a UC-500

Might not be the best of options, and also the most simplisic questions, but it would be a good place to start in my mind.

Cheers,

David.

Brook Powers Thu, 06/10/2010 - 06:35

David,

Thanks as always for your reply.

  • Is the appliance housed inside a cabinet?
  • Is the appliance surrounded by a lot of electrical devices/cables? (Within close proximity)
  • Is there a lot of other Wireless access points in the vicinity (Within a 50-100 Meter radius?)
  • Is the Appliance set as WPA?
  • Have you changed the channel it is using? I.E tried another channel other then the auto scan? (Look at forcing it onto channels 6 or 11 for testing)
  • The unit is in the same location it was when STAC made the changes to the antenna that caused the unit to work much better.

    The unit is still surrounded by the same CAT5e and power cables, but not too many.

    Yes, there are a lot of WAPS in the building, but still the unit worked well after the changes made by Cisco's STAC to use the right antenna.

    The appliance is stll set to WPA2.

    The channel was 8 before, and it is 8 now. I may try setting it to "least congested at startup", but I remain convinced the issue is due to the factory default settings configuration, which assumes a right and left antenna. There is no left antenna.

    I wish I could remember what else the Cisco STAC did, because it made the wireless work very well. This time I will record/document the session and when/if it works, post it back here.

    Maybe Cisco STAC has a record of the session?

    Brook Powers Thu, 06/10/2010 - 06:52

    Thanks Steve!

    It was one of these three. Most likely Case# 613652985 or 614554143.

    CASE HISTORY

    CASE                               ISSUE                                                                 CISCO STAC REP

    ===============          ====================                                 ================

    Case # 613652985         7975G Firmware upgrade woes                        Derrick

    Case# 614554143          7975G VPN Client "This key not active here"   ?

    Case#  614554255         Multiple Gateway IP’s how to in CLI?               Jason

    "                                     Single Number Reach being wonky                  "

    Case# 614605353          Wireless sucks again after reset to defaults   Jason

    Steven DiStefano Thu, 06/10/2010 - 07:15

    There is no relevant data in any of these opened from your site.....

    But Case=614605353 has **no** data, looks like they are waiting to hear back from you????

    Maybe it was discussed and not documented.

    Sorry ;-)

    Message was edited by: Steve DiStefano

    Steven DiStefano Thu, 06/10/2010 - 07:32

    I found something...

    A different case from a different site....

    "try manually setting the antenna tx and rx to right instead of diversity"

    F340.02.18-UC520W-2(config-if)#antenna ?
      gain      Configure Resultant Antenna Gain
      receive   receive antenna setting
      transmit  transmit antenna setting

    F340.02.18-UC520W-2(config-if)#antenna receive ?
      diversity  antenna diversity
      left       antenna left/secondary
      right      antenna right/primary

    ...

    ...

    "We have made the changes to both the TX and RX.  Great news... this has 
    fixed our issue..  Thanks for your help
    Seems like antenna is set by default to diversity.
    provided instructions to set the antenna tx/rx to right (primary)"

    Brook Powers Thu, 06/10/2010 - 07:58

    If I type;

    ROUTER#(config-if)#antenna receive right

    Sets receive to the right antenna - the only one physically present

    ROUTER#(config-if)#antenna transmit right

    Sets transmit to the right antenna - the only one physically present

    And run

    ROUTER#(config-if)#antenna receive ?

    or

    ROUTER#(config-if)#antenna transmit ?

    I get;

      diversity  antenna diversity
      left       antenna left/secondary
      right      antenna right/primary

    NOTHING has changed.

    What am I missing?

    Is there something to do with the diversity command?

    So what command do I enter to set the tx and rx to right if not the above?

    If thats not it, what is the command to turn diversity off?

    Steven DiStefano Thu, 06/10/2010 - 08:12

    I think they are meaning to do this:

    UC540(config)#interface dot11Radio 0/5/0
    UC540(config-if)#antenna ?
      gain      Configure Resultant Antenna Gain
      receive   receive antenna setting
      transmit  transmit antenna setting

    UC540(config-if)#antenna receive ?
      diversity  antenna diversity
      left       antenna left/secondary
      right      antenna right/primary

    UC540(config-if)#antenna receive right
    UC540(config-if)#antenna transmit right
    UC540(config-if)#end
    UC540#sh run | b interface Dot11
    interface Dot11Radio0/5/0
    no ip address
    !
    encryption vlan 1 mode ciphers aes-ccm
    !
    encryption vlan 100 mode ciphers aes-ccm
    !
    ssid cisco-voice
    !
    ssid datalan
    !
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    antenna receive right
    antenna transmit right
    !

    DONT forget to 'wr mem'

    David Trad Thu, 06/10/2010 - 13:30

    Hi Brooke,

    Maybe Cisco STAC has a record of the session?

    I always ask them to send me the results of the TAC session, and also a recording if it was recorded in WebEx, I then store all correspondence in their respective folders and date them, on top of that I also create a knowldge base entry for it as well.

    However though you do on occasions get a TAC rep who might be new or something and doesn't even put much information on your TAC case notes, it frustrates me but I have learnt to deal with it.

    Cheers,

    David.

    Brook Powers Fri, 06/11/2010 - 06:50

    It would be really helpful if Cisco realized that the device only has one antenna and wrote the code for one antenna, instead of two. Or, the could have perhaps utilized a second antenna - if the chip actually supports it.

    If Cisco made a mistake in writing code for two antenna's, then they should update the code to support what is actually in the device.

    If that's the case, Cisco should state plainly and affirmatively, "If you have X version, or earlier, or x-y serial number, type the following commands into the CLI to resolve the issue."

    I'm not sure how well what we have done is working to resolve the issue yet. It definitely not as good as it was when someone at the STAC (who's name and commands I failed to record) made some changes previously.

    Lessons Learned;

    1. Cisco should perform quality control on their code

    2. I should docuement or even record everything

    3. Cisco should step up and publish some clear guidance for other UC-540 owners

    Anyway, I appreciate the help of the STAC, David and Steve.

    Steven DiStefano Fri, 06/11/2010 - 07:06

    /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} What was found in late March is being taken seriously.

    All of us at Cisco want to make this right for our Partners, and I am tracking it as well inside.

    I am glad you were able to communicate with us on this community, which was a BIG way Cisco 'stepped up' to support our Partners, and in cases like this, it will work.

    I appreciate where you are coming from, nonetheless and will keep this thread updated.    I also apologize for the trouble.

    Steve

    Message was edited by: Steve DiStefano:  The name I thought was the TAC person was wrong. 

    Steven DiStefano Mon, 06/14/2010 - 11:25

    Brief Update:

    Our Technical Marketing Engineer took care of updating the default config which will be in the 8.0.3 SW pack for both uc520 and uc540 platforms last week to address new deployments.

    Brook Powers Mon, 06/14/2010 - 11:32

    Steve,

    Thank you for your diligent work and follow up.

    I'm not absolutely certain our wireless signal strength is what it was after a unidentified Cisco support person made undocumented changes (my fault for not documenting it).

    It may be that we are on a different channel, or it's phsycological, or maybe we still are not optimized.

    We are still testing and will advise.

    Steven DiStefano Tue, 06/15/2010 - 05:04

    Brook,

    If you determine anything else, let me know.

    I am pleased also that my dear friends in the CCA Engineering team are also lending a hand

    by adding ability to control the antenna in 2.2(5).

    Look for this in August timeframe

    CSCtg07290: CCA should set antenna tx/rx to right (primary) under dot11 radio int

    Brook Powers Tue, 10/19/2010 - 17:37

    Steve,

    The help file included with 8.0.2 states (released just recently);

    Antenna Settings (UC 520 and UC 540 Wireless SKUs only)

    You should only these modify antenna settings if instructed to by Cisco Support. The UC 520 and UC 540 wireless SKUs only have one antenna.

    Receive Antenna

    For UC 520 and UC 540 wireless SKUs, the Receive Antenna must be set to Default.

    Transmit Antenna

    For UC 520 and UC 540 wireless SKUs, the Transmit Antenna must be set to Secondary only.

    Is that really true, or is Cisco still having trouble understanding their single antenna?

    Steven DiStefano Wed, 10/20/2010 - 06:17

    Hi Brook,

    The default configuration now has this all correct.  I think we understand and addressed it.

    Brook Powers Wed, 10/20/2010 - 06:48

    Steve,

    Please clarify.

    When you say the default configuration now has this correct, do you mean as of your post, or as of the latest release.

    Because I assure you (see my post- above) that the latest release documentation is still wrong and I'm not convinced the default WAN settings are optimal either.

    There was a time when someone at Cisco STAC assisted me in configuring my 802.11 settings and then I had to reset. We have not been able to duplicate that level of performance again to date.

    Steven DiStefano Wed, 10/20/2010 - 06:51

    Latest SWP:

    !        
    interface Dot11Radio0/5/0
    no ip address
    !       
    ssid office-data
    !       
    ssid office-voice
    !       
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    antenna receive right
    antenna transmit right
    !       
    service-policy output Voice
    !