C2960 energywise - some experiments

Answered Question
Jun 5th, 2010

Hi Ken,

Had a little play with energywise on a Cisco 2960 LANlite switch.

.

I have pasted  far below, the demo script I used  as an example of a number of technologies available for you to use.

I make use of the ;

  • alias and
  • kron commands in my simulation to automate the startup and shutdown of an office at certain times of the day.

It's interesting how you can use alias to simplify long CLI commands.

It's interesting to use the kron command to automate the energywise functionality, so that the switch turns on and off functions. Note Ken, that I used NTP client on my switch to synchronize the switch clock, so it would automate things on time.

Energywise has a double benefit to shutting down devices such as AP's after hours, for added building perimeter security....cool stuff

If I had a couple of badge readers it would be cool to set up energywise on a per user or port basis, it's easy but I have no readers. Badge readers can send down HTTP command to the energywise domain to control a whole bunch of switches or chassis.  I have included the http commands at the bottom of this email.

Anyway,  the kron script turns off my phones and AP's at 21:00 hrs daily and turn them on again at 08:00hrs daily.

I created some alias commands to simplify the turning on and off different POE ports.

energywise domain office security shared-secret 0 cisco

energywise importance 60

energywise name workers

energywise keywords phone,ap

energywise management security shared-secret 0 cisco



interface FastEthernet0/38

description Phone

switchport trunk allowed vlan 100

switchport mode access

switchport voice vlan 100

energywise keywords phone

energywise name workers


!

interface FastEthernet0/39

description AP

switchport trunk allowed vlan 100

switchport mode access

switchport voice vlan 100

energywise keywords ap

energywise name workers


alias exec apoff energywise query importance 60 keywords ap set level 0

alias exec apon energywise query importance 60 keywords ap set level 1

alias exec phoneoff energywise query importance 60 keywords phone set level 0

alias exec phoneon energywise query importance 60 keywords phone set level 1

I created the alias, as i suggested to simplify my CLI commands for demo's that i run.

So for example,  if I type phoneoff,  when in switch  CLI,  the FastEthernet interfaces with the energywise keyword "phone" will power off.  I also make use the alias' in the kron policy-list below.

kron occurrence office_close at 21:00 recurring

policy-list office_close

!

kron occurrence Office_open at 8:00 recurring

policy-list office_open

!

kron policy-list office_close

cli apoff

cli phoneoff

!

kron policy-list office_open

cli apon

cli phoneon

If your  2960 switch has a HTTP interface,  the following commands will work from IE and Chrome.  (My 2960 Lanlite switch is at 192.168.10.29.)

to turn phone on Fastethernet0/38 on, or interfaces with energywise keyword phone

http://192.168.10.29/level/15/exec/energywise/query/importance/60/keywords/phone/set/level/1/CR                                                                      |

turn phone on Fastethernet0/38 off, or interfaces with energywise keyword phone

http://192.168.10.29/level/15/exec/energywise/query/importance/60/keywords/phone/set/level/0/CR

turn AP on Fastethernet0/39 on, or interfaces with energywise keyword ap

http://192.168.10.29/level/15/exec/energywise/query/importance/60/keywords/ap/set/level/1/CR

turn AP on Fastethernet0/39 off, or interfaces with energywise keyword ap

http://192.168.10.29/level/15/exec/energywise/query/importance/60/keywords/ap/set/level/0/CR

Ken, have fun with this application, it's really neat, with huge potential for energy and  dollar savings by your end users.

regards Dave

I have this problem too.
0 votes
Correct Answer by Leo Laohoo about 3 years 10 months ago

Nice post.  I have two questions, though:

1.  Why is your alias to turn phone and AP on are set to energywise level 1 instead of full power or 10?

2.  I read about energywise when Cisco unveiled it last year (even though the SE in Canberra, Australia) never knew about it.  The most controversial scenarios is this:  EnergyWise level is set to 0 (off) but how does this work if you have a, say, a staff on overtime work?  Does the phone turn on or stay off?

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Correct Answer
Leo Laohoo Sat, 06/05/2010 - 16:26

Nice post.  I have two questions, though:

1.  Why is your alias to turn phone and AP on are set to energywise level 1 instead of full power or 10?

2.  I read about energywise when Cisco unveiled it last year (even though the SE in Canberra, Australia) never knew about it.  The most controversial scenarios is this:  EnergyWise level is set to 0 (off) but how does this work if you have a, say, a staff on overtime work?  Does the phone turn on or stay off?

David Hornstein Sat, 06/05/2010 - 23:35

Hi

I'll be in melbourne next week. Canberra is a lovely city to visit, wish i could pay a visit.

I mentioned in my note to Ken (in Australia) that i wished i had a badge or card reader. I saw a demo whereby one of the ISR G2 product managers tied two  badge readers into the solution using a 2921 ISR and two 2960's.

The badge reader would send a HTTP command to the energywise domain that could allow for individual settings to be sent to the energywise domain.

My problem was that I couldn't beg, or borrow  two badge readers for my demo.

After hours, as you enter the building, the badge reader can turn on specific keywords that represent your desk or proximity to a AP.  On the way out of the office you do the reverse on another badge reader leading out of the office and it sends a http command to the energywise domain to turn off ports that supply you with services.  The kron would turn off and on ports at specific times, but a door access card reader could issue commands to turn on or off  ethernet ports.

The beauty of this solution is not just energy saving, but a secondary security benefit of disabling access to the LAN from specific ethernet ports.

Concerning your valid comments concerning the use of "energywise level 1 instead of full power or 10,"  yep i was just playing, but it did turn on and off my 7965/7970 phones  and 1142 AP's with no issue.

I guess the manual says "A PoE port supports level 0 to level 10. If the power level is 0, the port is powered off."  but my twisted thinking is that if the value isn't '0' then the port isn't powered off on my single unit energywise domain.

If you can beg or borrow a 2960 POE switch, have a play with my configuration, it actually works very very well.

regards Dave

Leo Laohoo Sun, 06/06/2010 - 14:50

Thanks Dave.  Hope you have time to visit Canberra (1 hr plane ride from MEL).  The Cisco office is just <5 minutes from the airport.

jorgeluis_alva Wed, 06/29/2011 - 22:48

Hi David,

Thanks for a very useful information. I tell you that now I am trying to do a Energywise Lab too and I am looking for a way how I can send HTTP comands from badge reader to a switch but I dont have ideas. Please could you give some recommendations about it?

Thanks in advance for your help,

Best Regards,

Jorge

epasqualotto Mon, 07/08/2013 - 05:04

Hi, I also do some test with energywise switches but after setup a domain I can't send a set query to all domain but only on the current switch.

There's a way to change the scope of a query?

I wrote also a Windows software to configure Catalyst and I it energywise module on it, if someone want to try it or give me a feedback can send me a private message.

The software is available at www.ios4all.net

Actions

Login or Register to take actions

This Discussion

Posted June 5, 2010 at 9:53 AM
Stats:
Replies:5 Avg. Rating:5
Views:3174 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55