Routing call to PSTN via CUCM7

Unanswered Question
Jun 6th, 2010
User Badges:

Hello all,


Can someone please help me get outbound calls routed out to my PSTN.  I've tried using MGCP and now H.323 and it still doesn't work.  I've been able to route an inbound call to one of my IP phones but I had to use "connecton plar 7001" to even get that far. When that's not in my running config, then an inbound call won't even route to call manager?    All of my internal IP phones work fine. I can dial internally with no problems. The gateway (currently H.323) is communicating with cucm7.  The route pattern is configured for 9.! with pre-dot selected and then the route list and group tunnels down to my H.323 gateway device.  I don't what I'm missing? My Call manager is 172.30.100.14, and my gateway is 172.30.100.51.  I have 4fxo ports 1/1/0 to 1/1/3.  here's my gateway running-config:


3725#show run
Building configuration...

Current configuration : 4732 bytes
!
! Last configuration change at 10:40:15 UTC Sun Jun 6 2010
! NVRAM config last updated at 10:15:45 UTC Sun Jun 6 2010
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3725
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
no network-clock-participate wic 1
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.30.100.1 172.30.100.125
ip dhcp excluded-address 172.30.100.175 172.30.100.255
!
ip dhcp pool 172.30.100.0/24
   network 172.30.100.0 255.255.255.0
   option 150 ip 172.30.100.14
!
!
ip name-server 4.2.2.2
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
voice-card 1
no dspfarm
!
!
!
!
!
!
!
voice class h323 1
h225 timeout tcp establish 3
!
!
!
!
!
!
voice translation-rule 2
!
!
!
crypto pki trustpoint TP-self-signed-1918761977
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1918761977
revocation-check none
rsakeypair TP-self-signed-1918761977
!
!
crypto pki certificate chain TP-self-signed-1918761977
certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 ..................

  quit
!
!
controller E1 0/0

!
!
!
interface FastEthernet0/0
ip address 192.168.0.178 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.30.100.51 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet2/0
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
!
router rip
version 2
passive-interface FastEthernet0/0
passive-interface FastEthernet0/1
passive-interface Vlan1
network 172.30.0.0
network 192.168.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 172.30.100.0 0.0.0.255
!
!
!
control-plane
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
shutdown
!
voice-port 1/1/0
connection plar 7001
!
voice-port 1/1/1
shutdown
!
voice-port 1/1/2
!
voice-port 1/1/3
!
no ccm-manager fax protocol cisco
!
no mgcp timer receive-rtcp
!
!
!
dial-peer voice 3301 pots
destination-pattern 3301
port 1/0/0
!
dial-peer voice 100 voip
preference 1
destination-pattern ....
voice-class h323 1
session target ipv4:172.30.100.14
dtmf-relay h245-alphanumeric
ip qos dscp cs5 media
!
dial-peer voice 1 pots
destination-pattern 9T
direct-inward-dial
port 1/1/0
!
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
shutdown
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
ntp clock-period 17180821
ntp peer 172.30.100.14
ntp server 131.188.3.220
!
end

3725#



Any help is much appreciated. I just want to get outbound calls working.


Thanks,

Eric

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Sun, 06/06/2010 - 13:52
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

If your CUCM config is correct then do a debug ISDN Q931 and debug voip ccapi inout to further troubleshoot this in the GW.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

Joel Hatfield Sun, 06/06/2010 - 14:17
User Badges:

Couple of things:


1.  CUCM may be waiting for you to enter more digits before sending the call to the gateway since the last criteria you are matching in your route pattern is "!".  I think your route pattern would match all numbers in the range 90 through 9999999999999999999999.  If you want to test this theory then put a pound sign (#) at the end of your route pattern.  Then on your route pattern discard pre-dot and trailing #.  Then dial your PSTN number followed by the pound key.


2.  If you are stripping your external access code 9 (pre-dot) then you are not sending the "9" to the gateway (unless you are prefixing a 9 on your route pattern).  Your POTS dial-peer is matching 9T.  If you are not sending the 9 it won't match your POTS dial-peer. 


Also, since you have more than one active IP Interface you may want to force h323 to be bound to the address you have configured for the gateway in CUCM:
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.30.100.51


The debug voip ccapi inou should be helpful once the call gets to the gateway.

Eric.Biggie Fri, 06/11/2010 - 00:45
User Badges:

Joel,


Thanks for your reply, and sorry I'm replying so late. My day job keeps me really busy.


I eventually got it to work to where I can make outbound calls and receive inbound calls. I had to config the ports for PLAR on the gateway to get the inbound routed, and strangely I have to dial a "99" to make an outbound call. So far I only have one route pattern identified and its "9.!", so I don't know why I have to dial "99" to get an outside line.... but at least it works!  


However, my directives have recently changed.  Now I need an outside line direct to each IP phone and I need to use a prefix to only dial dn's inside the network. Each IP phone needs to act like it's just a normal phone with it's own PSTN line.  I've done a little research so far when I've had time, and this looks possible.....



Thank you for your helpful reply!


Best,

Eric



PS: and Thank you, java, for your reply as well! 

Joel Hatfield Fri, 06/11/2010 - 04:29
User Badges:

If you are willing to do a test, I think if you change your route pattern so that you are not stripping the pre-dot you should be able to just dial one 9 for outbound calls.

Actions

This Discussion