disable 2800 series' USB port?

Unanswered Question
Jun 7th, 2010

is there a command to disable the USB port on a 2800 router?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
podhillo Mon, 06/07/2010 - 12:19

Hi ,

please try to get into the interface using the "interface usd" command and try a "shut" and check if it works.


interface usb

To enter the interface configuration mode for the Universal Serial Bus (USB) interface, use the interface usb command in global configuration mode.

Cisco uBR925 cable access router, Cisco CVA122 Cable Voice Adapter

interface usb number

Syntax Description

Identifies the USB interface (always 0).

Command Default


Command Modes

Global configuration


show usb port

To sisplay USB root hub port information, use the show usb port command in privileged EXEC mode.

show usb port [port-number]

Syntax Description
(Optional) Displays information only for a specified. If the port-number is not issued, information for all root ports will be displayed.

Command Modes

Privileged EXEC

Command History
Release  Modification 
This command was introduced.


The following example shows how to enter interface configuration mode for the USB interface and then to display the available commands:

Router(config)# interface usb 0


Interface configuration commands:

access-expression Build a bridge boolean access expression

arp Set arp type (arpa, probe, snap) or timeout

bandwidth Set bandwidth informational parameter

bridge-group Transparent bridging interface parameters

carrier-delay Specify delay for interface transitions

cdp CDP interface subcommands

crypto Encryption/Decryption commands

custom-queue-list Assign a custom queue list to an interface

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

exit Exit from interface configuration mode

fair-queue Enable Fair Queuing on an Interface

h323-gateway Configure H323 Gateway

help Description of the interactive help system

hold-queue Set hold queue depth

ip Interface Internet Protocol config commands

keepalive Enable keepalive

load-interval Specify interval for load calculation for an


logging Configure logging for interface

mac-address Manually set interface MAC address

max-reserved-bandwidth Maximum Reservable Bandwidth on an Interface

mtu Set the interface Maximum Transmission Unit (MTU)

no Negate a command or set its defaults

ntp Configure NTP

priority-group Assign a priority group to an interface

random-detect Enable Weighted Random Early Detection (WRED) on an


service-policy Configure QoS Service Policy

shutdown Shutdown the selected interface

snmp Modify SNMP interface parameters

standby Interface HSRP configuration commands

timeout Define timeout values for this interface

traffic-shape Enable Traffic Shaping on an Interface or


transmit-interface Assign a transmit interface to a receive-only


tx-ring-limit Configure PA level transmit ring limit

Please let me know if this was helpful.


randomjoe1 Mon, 06/07/2010 - 12:51

could not 'int usb x', got the error ^ under the u.  the show command worked and that helps as well.  thanks!

Leo Laohoo Mon, 06/07/2010 - 15:18

Just because the status says it's "Disabled" doesn't really mean it's disabled.  It means that if you stick a USB flash in there the hardware will detect it and enable.

I have no idea why you want to disable this but I've been, in two occassions, use the USB to boot the router because of corrupt IOS.

randomjoe1 Tue, 06/08/2010 - 07:41

why would I want to disable the usb port?  security.  I have a router in a physically insecure area and don't want someone plugging in their iphone to charge it.  There are other ways to recover a router, my laptop has a CF reader and I have a spare card.  and if you change the baudrate to 115200 you could transfer an IOS image in 6 minutes

Leo Laohoo Tue, 06/08/2010 - 14:44

I have a router in a physically insecure area and don't want someone plugging in their iphone to charge it.

Errr ... The USB port won't or doesn't work like that.  I hope I get the term right, but the USB port(s) of the appliance works as an Input/Output (I/O) device and not as a multi-function dock.
randomjoe1 Tue, 06/08/2010 - 18:32

OK background on why I started the thread...  we got a log msg recv'd

saying a usb device was plugged in (we NEVER use usb)

.  so we logged in and decided to find out what was plugged in.  upon performing the

dir command, the router proceeded to crash and reboot.  ya.  The router is off site, so while the field eng. drove on site, we were betting on what happenned.  Iphone does not get recognized, BUT I COULD charge my blackberry 8820 off a router, and it mounted the microSD card and I was able to browse it from the router.  Could not reproduce the crash though on a lab 2800 running the same code.

so there, the usb port does have power and could indeed charge a blackberry 8800 series phone

randomjoe1 Tue, 06/08/2010 - 18:38

there is no reason why anyone should know that info...  cause really, who would think about chargin

g a phone on a router?  We tried to just

to try and reproduce the crash (what else would someone working in a warehouse plug into a router


Senthil Rajendra Tue, 06/08/2010 - 05:46

Dear Podhillo,

        Simillarly can you tell me the command to check the USB port of 7604 Core router.

Thanks in Advance


Leo Laohoo Tue, 06/08/2010 - 14:45

Simillarly can you tell me the command to check the USB port of 7604 Core router.

If you are using Sup32 or Sup720, there's no need to check.  These cards do not support USB.  As a matter of fact, the USB is software disabled by the IOS all the time.


This Discussion