Catalyst 4500E Supervisor VI QoS changes

Unanswered Question
Jun 7th, 2010
User Badges:

I have upgraded a Cisco 4506 with a Supervisor 4 to a Supervisor 6-E and low & behold, my CoS/QoS settings no longer work.  I see from a white paper that Cisco upgraded the supervisor capabilities to MQC, which is more inline with the IOS routers.  There are a couple differences though.  Does anyone have any links or other tips that is not covered in white  paper?


I'm having a hard time converting my previous 4500 QoS settings for voice (Avaya phones) to the new syntax on the Supervisor 6-E.  I used a Cisco Press book called End-to-End QoS Network Design, but being a few years old it doesn't include the latest Sup 6 from the 4500's.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Mon, 06/07/2010 - 13:58
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

As you stated, it uses the same methodology as the routers and it's much easier to deploy. By default all switchports are trusted and markings will be preserved unlike your typical QoS on Cisco switches.


The documentation has good information on this matter:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/52sg/configuration/guide/qos.html#wp1474085


Regards


Edison

valnar Tue, 06/08/2010 - 07:49
User Badges:

I'm reading it now, but I still don't understand a couple things.


1) Table maps are not explained.  How do I know if I am changing CoS or DSCP?

2) If I apply a policy to a VLAN, does it affect every L2 switchport on that VLAN?  Or only when it flows through the L3 vlan interface? (behavior similar to a router)

valnar Wed, 06/09/2010 - 10:05
User Badges:

I also don't understand what qos-groups are and why they are needed.


After initiating auto-qos on a port, the exerpt below was configured on the switch.  I don't use auto-qos personally, but it does give insight into the functionality.


Notice the redundancy between dscp24/26 and qos-group24/26.  Why??




class-map match-all AutoQos-VoIP-Control-Dscp26
match  dscp af31
class-map match-all AutoQos-VoIP-Control-Dscp24
match  dscp cs3
class-map match-all AutoQos-VoIP-Control-QosGroup24
match qos-group 24
class-map match-all AutoQos-VoIP-Control-QosGroup26
match qos-group 26
class-map match-all AutoQos-VoIP-Control-Cos
match cos  3
class-map match-all AutoQos-VoIP-Bearer-Cos
match cos  5
class-map match-all AutoQos-VoIP-Bearer-QosGroup
match qos-group 46
class-map match-all AutoQos-VoIP-Bearer-Dscp
match  dscp ef


!
policy-map AutoQos-VoIP-Input-Dscp-Policy
class AutoQos-VoIP-Bearer-Dscp
  set qos-group 46
class AutoQos-VoIP-Control-Dscp26
  set qos-group 26
class AutoQos-VoIP-Control-Dscp24
  set qos-group 24
policy-map AutoQos-VoIP-Input-Cos-Policy
class AutoQos-VoIP-Bearer-Cos
  set qos-group 46
class AutoQos-VoIP-Control-Cos
  set qos-group 24
policy-map AutoQos-VoIP-Output-Policy
class AutoQos-VoIP-Bearer-QosGroup
  set dscp ef
  set cos 5
    priority
    police cir percent 33
class AutoQos-VoIP-Control-QosGroup26
  set dscp af31
  set cos 3
    bandwidth remaining percent 5
class AutoQos-VoIP-Control-QosGroup24
  set dscp cs3
  set cos 3
    bandwidth remaining percent 5
class class-default
    dbl
!


interface GigabitEthernet2/1
auto qos voip trust
service-policy input AutoQos-VoIP-Input-Cos-Policy
service-policy output AutoQos-VoIP-Output-Policy


darrenriley5 Mon, 03/19/2012 - 09:05
User Badges:

Hi,


Just wondered if someone would be able to explain the qos groups are as I don't understand it myself. I've tried reading the documentation but it doesn't seem to explain it very well.


Thanks

Darren

Surya ARBY Mon, 09/09/2013 - 01:57
User Badges:
  • Silver, 250 points or more

A Qos-group is an internal marker, just like the old "internal DSCP" was; but qos-group may be used if all the traffic embedded into a class is not IP-based.

Actions

This Discussion

Related Content