cisco 3550 Qos DSCP marking

Unanswered Question
Jun 8th, 2010

I have the following setup :

device marking dscp  >------>trunk port [3550 switch] ----- access port---------> management computer

The device is marking with dscp 6 in upstream. I need to be able to recognise the dscp 6 marking on the switch and also performing the dscp marking 6 on downstream on the switch for allowing traffic to pass.

Also, I need the management computer to be able to access the device marking dscp, meaning that I need to replace the dscp marking with no marking.

I have the following config :

interface FastEthernet0/1

description TRUNK_4MOTION_ODU

switchport trunk encapsulation dot1q                

switchport mode dynamic desirable

service-policy input ACS

mls qos trust dscp

interface FastEthernet0/5

description MANAGEMENT_CPE

switchport access vlan 1101

switchport mode access

service-policy input ACS

spanning-tree portfast

access-list 120 permit ip 10.101.0.0 0.0.0.255 any dscp 6

ip dhcp pool MANAGEMENT_CPE

   network 10.101.0.0 255.255.255.0

   domain-name test.com

   default-router 10.101.0.254

   option 60 ascii "dslforum.org"

   option 43 ascii "InternetGatewayDevice.ManagementServer.URL=http://10.101.0.252:8080/dps/TR069"

   lease 0 0 5

class-map match-all ACS

  match access-group 120

policy-map ACS

  class ACS

   set dscp 6

!

For some reasons I cannot pass any traffic between the device marking with dscp 6 and my switch.

What am i missing ?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
liviu.sisu Tue, 06/08/2010 - 04:37

Hi Andrew,


Thanks for your prompt response.

I think I already "instruct" the trunk port to accept qos-marked packets.

I am not quite sure if I got your point. Inter-vlan routing is being done at the moment on the 3550 switch.

My concern is not on that side, but I assume i am doing something wrong on the policer side.


Liviu

liviu.sisu Tue, 06/08/2010 - 05:04

The device marking the traffic should get an IP from this pool :


ip dhcp pool MANAGEMENT_CPE

   network 10.101.0.0 255.255.255.0

   domain-name test.com

   default-router 10.101.0.254

   option 60 ascii "dslforum.org"

   option 43 ascii "InternetGatewayDevice.ManagementServer.URL=http://10.101.0.252:8080/dps/TR069"

   lease 0 0 5

.

And it gets it.



The management computer's IP address is on 10.101.0.252 and it is on VLAN 1101.




Behind the CPE I am using multiple VLANs, that's why I am using trunking.



On the switch side, I want to be able to recognise dscp 6 marked on the CPE, assign an IP from DHCP pool residing on VLAN 1101 and be able to pass traffic.




At the moment I cannot ping the device performing marking.




Actions

This Discussion