From 100Mb to 10Mb.... Why?

Unanswered Question
Jun 8th, 2010

Hi Everybody,
I bought a wic-4ews for a my cisco 1760, but I have a problem...


I configure my cisco 1760 in this way:


-On FastEthernet0/0  (on motherboar) connect the router cisco 2800 (of my ISP) . the speed of connection on internet is 100Mb (Test with speedtest.net)
-On wic-4ews I connected the pc / switch of my office


But I surf on internet to 10Mb .

I believe  that there is some limitation because the test always the same,  about 9.80Mb in download and 8.90Mb in upload

Why is it possible?
Where I have wrong?

I'am trust that I haven't set any limitations....

my running-config , interface and version of my cisco

Current configuration : 1293 bytes
!
version 12.4
.....
ip subnet-zero
....
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat outside
ip virtual-reassembly
speed 100
full-duplex
!
interface FastEthernet1/1
duplex full
speed 100
!
interface FastEthernet1/2
duplex full
speed 100
!
interface FastEthernet1/3
duplex full
speed 100
!
interface FastEthernet1/4
duplex full
speed 100
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.254
!
...
ip nat inside source list 120 interface FastEthernet0/0 overload
!
access-list 120 permit ip 192.168.1.0 0.0.0.255 any
!







Router#show ver
Cisco IOS Software, C1700 Software (C1700-ADVSECURITYK9-M), Version 12.4(3), RE)
Technical Support:
http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Fri 22-Jul-05 12:04 by hqluong

...

Cisco 1760 (MPC860P) processor (revision 0x500) with 86982K/11322K bytes of mem.
Processor board ID FOC08190CC9 (3260477220), with hardware revision 0000
MPC860P processor: part number 5, mask 2
1 Ethernet interface
5 FastEthernet interfaces
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102








FastEthernet0/0 is up, line protocol is up
  Hardware is PQUICC_FEC, address is 000f.24af.4579 (bia 000f.24af.4579)
  Internet address is 192.168.0.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 235000 bits/sec, 24 packets/sec
  5 minute output rate 13000 bits/sec, 20 packets/sec
     1634687 packets input, 2220511936 bytes
     Received 2 broadcasts, 0 runts, 0 giants, 0 throttles
     1300 input errors, 0 CRC, 0 frame, 1300 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     881594 packets output, 83612847 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet1/1 is up, line protocol is down
  Hardware is Fast Ethernet, address is 0013.606a.5ee8 (bia 0013.606a.5ee8)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet1/2 is up, line protocol is down
  Hardware is Fast Ethernet, address is 0013.606a.5ee9 (bia 0013.606a.5ee9)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet1/3 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0013.606a.5eea (bia 0013.606a.5eea)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/130/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     24815 packets input, 19519349 bytes, 0 no buffer
     Received 37 broadcasts, 0 runts, 0 giants, 0 throttles
     31 input errors, 31 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     33854 packets output, 28158277 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet1/4 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0013.606a.5eeb (bia 0013.606a.5eeb)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/9/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 11000 bits/sec, 16 packets/sec
  5 minute output rate 226000 bits/sec, 20 packets/sec
     877666 packets input, 69544596 bytes, 0 no buffer
     Received 619 broadcasts, 0 runts, 0 giants, 0 throttles
     37 input errors, 21 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     1612808 packets output, 2197718332 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Vlan1 is up, line protocol is up
  Hardware is EtherSVI, address is 000f.24af.4579 (bia 000f.24af.4579)
  Internet address is 192.168.1.254/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:03, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 11000 bits/sec, 17 packets/sec
  5 minute output rate 220000 bits/sec, 19 packets/sec
     881532 packets input, 83739602 bytes, 0 no buffer
     Received 805 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     1635410 packets output, 2220889385 bytes, 0 underruns
     0 output errors, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
NVI0 is up, line protocol is up
  Hardware is NVI
  MTU 1514 bytes, BW 10000000 Kbit, DLY 0 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation UNKNOWN, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out



Thank you a lot

Bye

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 06/08/2010 - 04:32

The Cisco 1760 only supports 8-9Mb throughput so that is why you are only getting that figure. Just because a router has a 100Mb interface this does not mean it will support 100Mb.

If you want 100Mb then you either need to connect your switch into the ISP router or purchase a router that can do 100Mb throughput.

Jon

Carachi83 Tue, 06/08/2010 - 04:48

ah ok

understand!

So i need to buy a router cisco 2800 like the router of my ISP, right?

where I can found a list of router that  support 100Mb?

Thank you

Bye

Jon Marshall Tue, 06/08/2010 - 04:52

To get a 100Mb you need a 2851. However Cisco have recently released the 2900 series routers so it would be a good idea to talk to a Cisco var who could point you in the right direction.

You could also consider a L3 switch which may well be cheaper but has limitations eg. most L3 switches don't do NAT for example.

Jon

abersven Sun, 06/13/2010 - 04:31

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;}

The performance/throughput is decreased when NAT is enabled since there is a lot of CPU load involved with NAT translation tear downs. So remember to look specifically for performance with NAT enabled.

/André

Actions

This Discussion