Wireless controller module can't see WAPs on seperate POE switch

Unanswered Question
Jun 8th, 2010

Our 2811 has the NME-AIR-WLC12-K9 WLAN controller installed. All of the WAPs are connected to an HP POE switch. The controller is configured but it doesn't see any of the WAPs.

My LAN is 172.18.129.0 and as I've configured on other 2811s with a WLCM, the WLCM is on 172.19.129.0. The router's Integrated-Service-Engine1/0 interface is 172.19.129.1 so I have no issues getting to the WLCM.

Will the WLCM being on a seperate subnet only work if the WAPs are connected to a POE card in the router? If so, how do I conigure the router's Integrated-Service-Engine1/0 interface and the WLCM?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dancampb Tue, 06/08/2010 - 08:19

What method are you using to tell the AP where the controller is, DHCP option 43 or DNS resolution?

jasonww04 Tue, 06/08/2010 - 08:46

Neither. I've never configured a 2811 with a WLCM that didn't have POE ports for the WAPs.

If I use option 43, should it be in the DHCP pool for wired clients or the pool for wireless clients? Also, if I use option 60, how do I enter it if I'm using 1131 APs? The table I found lists the VCI as Cisco AP c1130 but when I put in option 60 ascii "Cisco AP c1130" it tells me invalid input at the A in AP.

dancampb Tue, 06/08/2010 - 09:41

If the AP isn't on the same subnet as the management interface you'll have to use either option 43, DNS, or IP forward protocol so that the AP can find the controller to join.

Your format for option 60 looks correct. Here's an example of what the option 43 configs would look like if your DHCP server is on an IOS device:

ip dhcp pool wireless
   import all
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1
   dns-server 10.0.0.2
   option 43 hex f104.0a00.000a
   option 60 ascii "Cisco AP c1130"

If you don't specify option 60 option 43 will be sent to every device getting an IP from this range.  This may not be an issue.  Just depends on your environment.

jasonww04 Tue, 06/08/2010 - 09:53

Apparently I can't use option 60 since it refuses to take option 60 "Cisco AP c1130". Hopefully there is no issue with all devices getting option 43.

Actions

This Discussion