Citrix Xen Server on UCS-B with Palo Adapter

Unanswered Question
Jun 8th, 2010
User Badges:

All


I am attempting to install Citrix Xen server (tried 5.6 and 5.5) on a UCS-B series blade running the Palo Adapter.

During the install we are asked to install drivers.

I used "kmod-enic-xen-1.1.1j-0.x86_64.rpm" from virtual media and it stated no drivers were found.

I tried extrating this to .gz and further to .cpio with the same results.



Any input or direction would be appreciated.



Thanks in advance

DaveO

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jeremy Waldrop Tue, 06/08/2010 - 18:19
User Badges:
  • Silver, 250 points or more

Citrix XenServer isn't listed on the supported UCS Hardware and Software Interoperability Matrix. I believe XenServer is based on Red Hat like ESX but I am not sure if XenServer is using x86 or x64 kernel. I know that only x64 Red Hat is supported with the VIC.


The matrix can be downloaded from here

http://www.cisco.com/en/US/products/ps10477/prod_technical_reference_list.html



This link states that XenServer 5.5 is supported but doesn't mention which adapter.

http://www.cisco.com/en/US/prod/ps10265/at_work_promo.html#~sw

daveo Tue, 06/08/2010 - 19:28
User Badges:

Jeremy

Thanks for the response. I have been searching around and found both those documents (as well as your blog - great info). The info is not clear as you pointed out. I was not sure if it was support in the recent 5.6 release or if there was a way to add in the driver for it, but we are not having any luck.


My next step if I cant find a way to get it working, will be to determine which mez card is supported and get one for the client.


Any other idea or thoughts welcome.


thanks


DaveO

Jeremy Waldrop Tue, 06/08/2010 - 20:08
User Badges:
  • Silver, 250 points or more

The Menlo adapters should work because those use standard drivers for either Qlogic or Emulex. I can't find anything definitive though. Those are the M71KR-Q and M71KR-E adapters.

Actions

This Discussion