can hear but unable to talk

Unanswered Question
amitkumarp Wed, 06/09/2010 - 02:13

Well you're facing the One way voice issue. Have youu tried pinging from your end to the end where you're calling??

To talk and hear, both ends must be pinging each other. Here I am attaching the document to troubleshoot the one way voice issue.

Hope this helps you.

Regards,

Amit.

I just looked into my system and saw that "show clock" is showing incorrect date. The document you gave me did mention incorrect "clock" could be the cause for one way voice issue.

What I wanted to understand is the difference between the controller clock and the clock displayed by "show clock". Are they the same or totally different?

amitkumarp Wed, 06/09/2010 - 10:05

Hi,

I searched for the difference between the clocking and got the following document. And as per this document, I guess both are different clocks.

The one they've mentioned in troubleshooting document is Controller Clock and not the one which can be seen by Show Clock command.

http://www.cisco.com/en/US/docs/routers/access/1700/1751/software/feature/guide/TDMdesc.html#wp111428

Refer to the document to understand the clocking configuration for controller.

In your case, I guess you need to check your routing i.e. if phones are in different subnets then there should be routing between them or if they're in different VLANs then inter VLAN routing need to be done, and if your router is MGCP or H.323 gateway then you need to run commands bind media source interface and bind control source interface. These are the main causes of the One voice issue.

Let me know your exact topology so that I can understand what exact problem you're facing.

Regards,

Amit.

call will come in via tdm pri  -> gateway transfer call to a h323 server - > h323 server receives call and sends call back out to PSTN

my gateway and the h323 server are in different network. I dont have any control over the h323 server.

Building configuration...

Current configuration : 3982 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname mygateway

!

boot-start-marker

no boot startup-test

boot-end-marker

!

enable secret 5 asdfasfasf

enable password sdfsdfs

!

!

!

resource-pool disable

aaa new-model

!

!

aaa group server radius test

server abcd auth-port 1812 acct-port 1813

!

aaa authentication login test group test

aaa authorization exec test group test

aaa accounting connection test start-stop group test

!

!

aaa session-id common

spe country usa

!

spe default-firmware spe-firmware-1

no ip routing

!

!

no ip cef

!

!

multilink bundle-name authenticated

isdn switch-type primary-5ess

!

!

!

!

!

!

!

!

!

!

!

!

application

service test tftp://xxxx/test.tcl

!

service test1 tftp://xxxx/test1.tcl

paramspace english index 1

paramspace english language en

paramspace english location tftp://xxxx/

!

session

start test test

!

!

!

!

archive

log config

hidekeys

!

!

controller T3 7/0

framing m23

t1 1-28 controller

!

controller T1 7/0:1

framing esf

pri-group timeslots 1-24

!

controller T1 7/0:2

framing sf

!

controller T1 7/0:3

framing sf

!

controller T1 7/0:4

framing sf

!

controller T1 7/0:5

framing sf

!

controller T1 7/0:6

framing sf

!

controller T1 7/0:7

framing sf

!

controller T1 7/0:8

framing sf

!

controller T1 7/0:9

framing sf

!

controller T1 7/0:10

framing sf

!

controller T1 7/0:11

framing sf

!

controller T1 7/0:12

framing sf

!

controller T1 7/0:13

framing sf

!

controller T1 7/0:14

framing sf

!

controller T1 7/0:15

framing sf

!

controller T1 7/0:16

framing sf

!

controller T1 7/0:17

framing sf

!

controller T1 7/0:18

framing sf

!

controller T1 7/0:19

framing sf

!

controller T1 7/0:20

framing sf

!

controller T1 7/0:21

framing sf

!

controller T1 7/0:22

framing sf

!

controller T1 7/0:23

framing sf

!

controller T1 7/0:24

framing sf

!

controller T1 7/0:25

framing sf

!

controller T1 7/0:26

framing sf

!

controller T1 7/0:27

framing sf

!

controller T1 7/0:28

framing sf

!

gw-accounting aaa

acct-template callhistory-detail

!

!

!

!

interface GigabitEthernet0/0

ip address 123.123.123.123 255.255.255.240

no ip route-cache

duplex auto

speed auto

negotiation auto

no cdp enable

h323-gateway voip interface

h323-gateway voip bind srcaddr 123.123.123.123

!

interface GigabitEthernet0/1

no ip address

no ip route-cache

shutdown

duplex auto

speed auto

negotiation auto

no cdp enable

!

interface Serial0/0

no ip address

no ip route-cache

shutdown

clock rate 2000000

!

interface Serial7/0

no ip address

no ip route-cache

shutdown

!

interface Serial0/1

no ip address

no ip route-cache

shutdown

clock rate 2000000

no cdp enable

!

interface Serial7/0:1:23

no ip address

encapsulation hdlc

isdn switch-type primary-5ess

isdn incoming-voice modem

no cdp enable

!

interface Group-Async0

no ip address

encapsulation slip

no ip route-cache

no group-range

!

interface Group-Async1

no ip address

encapsulation slip

group-range 1/00 6/107

!

!

ip forward-protocol nd

no ip http server

!

!

!

!

!

radius-server host srv auth-port 1812 acct-port 1812

radius-server host srv.53 auth-port 1812 acct-port 1813

radius-server key testing123

radius-server vsa send accounting

radius-server vsa send authentication

!

control-plane

!

!

!

voice-port 7/0:1:D

bearer-cap Speech

!

mgcp

!

!

dial-peer voice 1 pots

service test1

incoming called-number 832

direct-inward-dial

port 7/0:1:D

!

dial-peer voice 2 voip

destination-pattern 84.........$

session target ipv4:h323srv

tech-prefix 17116

!

!

dial-peer search type voice data

ss7 mtp2-variant Bellcore 0

ss7 mtp2-variant Bellcore 1

ss7 mtp2-variant Bellcore 2

ss7 mtp2-variant Bellcore 3

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password fdgdfgdf

line 1/00 6/107

modem InOut

!

scheduler allocate 10000 400

no process cpu extended

no process cpu autoprofile hog

end

 

amitkumarp Wed, 06/09/2010 - 23:18

Hi Vinh,

you haven't told me if you are able to ping to the other end where you're calling.

Regards,

Amit.

amitkumarp Thu, 06/10/2010 - 03:15

If you're not able to ping then you need to check the routing. And get a confirmation from them if they have really disabled the ping.

As far as I know, you at least should be able to ping.

Regards,

Amit.

Actions

This Discussion