NBMA and using the EIGRP and OSPF, why not to use RIP, IS-IS and IGRP

Answered Question
Jun 9th, 2010

Hi All;

Anyone can advise why can not use RIP, IS-IS and IGRP in case I was uing NBMA like FrameRelay or X.25? While I can use EIGRP and OSPF with NBMA?

Regards

Bilal

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 3 years 10 months ago

Hello Bilal,

good note

>> What those other methods (other than broadcast)that can let the router knows to whom to send (specially in the beginning as the router does not know whom beside him)?

it is manually configured as for BGP

example

frame-relay multipoint interface NBMA

in ser0/0

enc frame-relay

no ip addr

no shut

int sere0/0.100 multipoint

ip address 172.16.80.1 255.255.255.240

frame-relay map ip 172.16.80.2 102 broadcast

frame-relay map ip 172.16.80.3 103 broadcast

! the broadcast keyword would allow to map RIP hellos without using the neighbor command

router rip

passive-interface ser0/0.100

neighbor 172.16.80.2

neighbor 172.16.80.3

network 172.16.0.0

version 2

see

http://www.cisco.com/en/US/docs/ios/iproute_rip/configuration/guide/irr_cfg_rip_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1061185

similar setups are possible for EIGRP and OSPF (OSPF requires also configuration of appropriate network-type)

Hope to help

Giuseppe

Correct Answer by Giuseppe Larosa about 3 years 10 months ago

Hello Bilal,

>> From the other side, why I can not use IS-IS with NBMA if I disabled the split horizon (same as RIP)?

IS-IS is link state like OSPF there is no split horizon concept in both of them: they flood data structures (OSPF LSA for example) in all links that are in the same area.

Split horizon is a distance vector concept that says do not advertise an IP subnet out the interface it has been learned.

OSPF has many network types that allows to deal with NBMA, IS-IS has only two network types: broadcast (LAN) and point-to-point (serial) so as correctly noted by Laurent it can be used only in an NBMA with a full mesh (where each router can reach every other router without going via a third one)

You can use the neighbor statement in RIP even together with passive-interface (that will stop broadcast advertisements)

As I noted IGRP is not current anymore.

Hope to help

Giuseppe

Correct Answer by Giuseppe Larosa about 3 years 10 months ago

Hello Laurent,

>> ISIS worked over NBMA but only in a fully-mesh topology

Thanks for your correction my memory betrayed me

Best Regards

Giuseppe

Correct Answer by Laurent Aubert about 3 years 10 months ago

Hi,

ISIS worked over NBMA but only in a fully-mesh topology as it supports only pt-2-pt or broadcast network type. Please see the following link for more information:

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a008009445a.shtml

RIP/IGRP works as well over NBMA as split-horizon is disabled by default with FR encapsulation (not for X25). If you can't send multicast update, you can switch to unicast update (neighbor + passive interface commands). Also if you have a lot of neighbor and are sending multicast updates, you may have to tune the broadcast queue.

HTH

Laurent.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (9 ratings)
Giuseppe Larosa Wed, 06/09/2010 - 05:15

Hello Bilal,

OSPF and EIGRP are recommended for NBMA but you can use for example RIP if you disable split horizon on hub router as you need to do with EIGRP.

IGRP is legacy and not supported in modern IOS images

ISIS hasn't an NBMA network mode that is present in OSPF. This makes OSPF to be preferred.

However, in ISIS is possible to configure a feature called mesh group  that may be useful in dealing with NBMA

Hope to help

Giuseppe

Correct Answer
Laurent Aubert Wed, 06/09/2010 - 05:55

Hi,

ISIS worked over NBMA but only in a fully-mesh topology as it supports only pt-2-pt or broadcast network type. Please see the following link for more information:

http://www.cisco.com/en/US/partner/tech/tk365/technologies_tech_note09186a008009445a.shtml

RIP/IGRP works as well over NBMA as split-horizon is disabled by default with FR encapsulation (not for X25). If you can't send multicast update, you can switch to unicast update (neighbor + passive interface commands). Also if you have a lot of neighbor and are sending multicast updates, you may have to tune the broadcast queue.

HTH

Laurent.

Correct Answer
Giuseppe Larosa Wed, 06/09/2010 - 06:00

Hello Laurent,

>> ISIS worked over NBMA but only in a fully-mesh topology

Thanks for your correction my memory betrayed me

Best Regards

Giuseppe

bilalghayad Sat, 06/12/2010 - 14:31

Can I understand that OSPF and EIGRP does not use broadcast while RIP and IGRP are using broadcast? And this is the reason why NBMA is good for OSPF and EIGRP.

From the other side, why I can not use IS-IS with NBMA if I disabled the split horizon (same as RIP)?

As I understood that the problem is related to using the Broadcasting while NBMA does not allow, am correct?

Regards

Bilal

Correct Answer
Giuseppe Larosa Sat, 06/12/2010 - 21:28

Hello Bilal,

>> From the other side, why I can not use IS-IS with NBMA if I disabled the split horizon (same as RIP)?

IS-IS is link state like OSPF there is no split horizon concept in both of them: they flood data structures (OSPF LSA for example) in all links that are in the same area.

Split horizon is a distance vector concept that says do not advertise an IP subnet out the interface it has been learned.

OSPF has many network types that allows to deal with NBMA, IS-IS has only two network types: broadcast (LAN) and point-to-point (serial) so as correctly noted by Laurent it can be used only in an NBMA with a full mesh (where each router can reach every other router without going via a third one)

You can use the neighbor statement in RIP even together with passive-interface (that will stop broadcast advertisements)

As I noted IGRP is not current anymore.

Hope to help

Giuseppe

bilalghayad Sun, 06/13/2010 - 04:28

>> You can use the neighbor statement in RIP even together with passive-interface (that will stop broadcast advertisements).

If we did this, then how the RIP will send for the routers the routing table that he has to do update? As I know that router will start send Hello for his friends to tell them what routes he has, so if we stop the broadcast, then how this will happen?

Actually the question is: those routes which does not use broadcast, or those which use point to point, how they advertise their routing table if the router does not know its neighbour and friends to send for them? What those other methods (other than broadcast)that can let the router knows to whom to send (specially in the beginning as the router does not know whom beside him)?

Your kindly help is high appreciated.

Regards

Bilal

Correct Answer
Giuseppe Larosa Sun, 06/13/2010 - 05:00

Hello Bilal,

good note

>> What those other methods (other than broadcast)that can let the router knows to whom to send (specially in the beginning as the router does not know whom beside him)?

it is manually configured as for BGP

example

frame-relay multipoint interface NBMA

in ser0/0

enc frame-relay

no ip addr

no shut

int sere0/0.100 multipoint

ip address 172.16.80.1 255.255.255.240

frame-relay map ip 172.16.80.2 102 broadcast

frame-relay map ip 172.16.80.3 103 broadcast

! the broadcast keyword would allow to map RIP hellos without using the neighbor command

router rip

passive-interface ser0/0.100

neighbor 172.16.80.2

neighbor 172.16.80.3

network 172.16.0.0

version 2

see

http://www.cisco.com/en/US/docs/ios/iproute_rip/configuration/guide/irr_cfg_rip_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1061185

similar setups are possible for EIGRP and OSPF (OSPF requires also configuration of appropriate network-type)

Hope to help

Giuseppe

bilalghayad Mon, 06/14/2010 - 03:25

Thanks for all.

1) And for IS-IS, using the broadcast keyword does not enable us to use IS-IS in NBMA?

2) Also manual configuration for IS-IS is not possible (like using passive in RIP)?

Regards

Bilal

Giuseppe Larosa Mon, 06/14/2010 - 06:11

Hello Bilal,

the answers is positive for 1) question , because IS-IS is not based on IP protocol but it is part of OSI stack similar to CLNS.

It is enough to look at the link provided by Laurent, but you may be not able to see it

use this public link

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009445a.shtml

frame-relay map clns 123 broadcast

this is for IS-IS hellos

clns routing
!
interface Serial1
 ip address 10.10.10.1 255.255.255.0
 ip router isis
 encapsulation frame-relay
 clns router isis
 frame-relay map clns 123 broadcast
 frame-relay map clns 121 broadcast
 frame-relay map ip 10.10.10.3 121 broadcast
 frame-relay map ip 10.10.10.4 123 broadcast
 frame-relay lmi-type ansi
!

2) neighbor command is not available because it is not an IP address that identify the peer but a net + system-id that is a CLNS address

Hope to help

Giuseppe

bilalghayad Wed, 06/23/2010 - 14:36

Thanks for the gr8 help and kindly answers.

As there is a method to assign clns with broadcast, so why we can not use IS-IS with this broadcast configuration?

From the other side, in case of using multicast of unicast (by using the neighbour command), so why we need to use the passive command? Neighbour is not enough?

From the other side, what is the bad effect of enabling the broadcast on the Frame Relay to use it with RIP or IS-IS? What is the worst thing could happen?

Regards

Bilal

Laurent Aubert Wed, 06/23/2010 - 14:45

Hi

As there is a method to assign clns with broadcast, so why we can not use IS-IS with this broadcast configuration?

ISIS hello are send using special MAC addresses which are handled like broadcast so you don't have any choice but activating broadcast support with CLNS frame-relay mapping.

From the other side, in case of using multicast of unicast (by using the neighbour command), so why we need to use the passive command? Neighbour is not enough?

With the neighbor command only, RIP will send both the update in multicast and unicast. The passive command suppress the multicast update.

From the other side, what is the bad effect of enabling the broadcast on the Frame Relay to use it with RIP or IS-IS? What is the worst thing could happen?

If you have a lot of neighbor, you may have to tune the broadcast queue under the FR interface.

HTH

Laurent.

bilalghayad Wed, 06/23/2010 - 18:15

So the clns broadcast only for the IS-IS hello?

The remaining thing is why can not use the CLNS with neighbour (while it can be used with IP address)? What is the relation between net + system id and not being able to use the neighbour? Is it something related to the destination?!

In other words, why with IP address I can use the neighbour and it is not possible with CLNS?

Giuseppe Larosa Thu, 06/24/2010 - 01:31

Hello Bilal,

I can confirm that the neighor command is not available under router isis context.

the net is the CLNS address of the  node (only one per node not one per interface)

It is a question of implementation of the protocol

in the attachment file there is a chapter that Cisco Press had given as update in 2004

Hope to help

Giuseppe

Actions

Login or Register to take actions

This Discussion

Posted June 9, 2010 at 4:59 AM
Stats:
Replies:13 Avg. Rating:5
Views:1251 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard