DCR Add Device shows Duplicate Device Name

Unanswered Question
Jun 9th, 2010
User Badges:

When manually adding some devices via DCR Device Management I get the "Duplicate Device Name" error.

The names do not show in the DCR Device Management Selector. I have also done an Export of All Devices and the names are not in there either.

I have confirmed that the forward and reverse names and IP addresses resolve corerctly in DNS.


How/why would it complain of a duplicate name that doesn't seem to be in there?


This is LMS v3.2  CS v3.3.0


Thanks for any help,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 06/09/2010 - 22:06
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If the LMS server is integrated with ACS, check the Common Services > Device and Credentials > Reports > Devices not configured in ACS report.  If the device is listed there, then you will need to add it as a client of the ACS server before it will show up in LMS.

GRAEME DANIELSON Wed, 06/09/2010 - 22:45
User Badges:

The devices are as you suspect in the "Devices not configured in ACS report"

I think I see what's happenned. Looks like the devices were orginally added to LMS but at the time they were not correctly configured in ACS.


What has happened since is that the ACS configuration is now correct, but the devices have also been deleted from the LMS DCR.

So they are not showing in the DCR but they are showing in the "Devices not configured in ACS report".


I presume this is what is preventing them from being re-added, will they naturally age out of the ACS report somehow?



Joe Clarke Thu, 06/10/2010 - 18:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What this means is that the devices are all still in DCR, but not in ACS.  That is, the address by which the devices where added to LMS are not found in ACS network element configuration sets.  You need to add these devices to ACS, then restart ACS, then logout and lg back in to LMS.  The devices should show up in the device selectors.

Actions

This Discussion