ASA 5505 WAN interface issue

Unanswered Question
Jun 9th, 2010

I have an ASA 5505 firewall configured as an IPSec VPN gateway which a direct public IP is assigned to the outside WAN interface. After a while I can't access any outside IPs from the firewall even the gateway of the public IP. When I remove the IP and re assign it to the outside interface it starts to work again. Your kind explanations and solutions are highly appreciated to solve this issue. Configuration of my firewall is as below. Thanks in advance.


ciscoasa# show running-config
: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
no nameif
no security-level
no ip address
!
interface Vlan100
nameif inside
security-level 100
ip address 192.168.200.50 255.255.255.0
!
interface Vlan200
nameif outside
security-level 0
ip address 213.142.16.44 255.255.255.240
!
interface Ethernet0/0
switchport access vlan 100
speed 100
duplex full
!
interface Ethernet0/1
switchport access vlan 200
speed 100
duplex full
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list outside_1_cryptomap extended permit ip 192.168.200.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.0.20.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.0.21.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
static (outside,inside) 192.168.200.102 192.168.1.79 netmask 255.255.255.255
route inside 10.0.21.0 255.255.255.0 192.168.200.1 1
route inside 10.0.20.0 255.255.255.0 192.168.200.1 1
route outside 0.0.0.0 0.0.0.0 213.142.16..33 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 192.168.200.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 210.237.253.56
crypto map outside_map 1 set transform-set ESP-DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.200.0 255.255.255.0 inside
ssh timeout 60
console timeout 0


!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
username test password 43ZM61OmXZkVr7B7 encrypted
tunnel-group 210.237.253.56 type ipsec-l2l
tunnel-group 210.237.253.56 ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:92919efb2e3caa5fc9c1e7bb2e467896
: end
ciscoasa#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Federico Coto F... Thu, 06/10/2010 - 06:53

Hi,


The problem is with inbound or outbound traffic?

I don't see any NAT on the ASA for Internet access.

What exactly is the issue that you're facing?


Federico.

Ravindu Jayalath Thu, 06/10/2010 - 10:04

Hi Fedrico,


Thanks for your reply. Say that i configure my firewall for the first time. I assign a public IP to the outside interface. After I complete the testing I keep the test setup plug in but there may not be any haevy traffic going through the firewall. After a while I login to the system and try to go out to the internet or try to comein from the internet to the firewall,but it is not working which it was working earllier. I have the issue to the both inbound and out bound directions. Is there any IDLE timeout or something related to a WAN interface.

Thanks.
Federico Coto F... Thu, 06/10/2010 - 12:10

Look at the output of the ''sh run timeout'' on the ASA


You will see this two:

timeout xlate 3:00:00
timeout conn 1:00:00


Try changing the timeouts so that the connection timeout is longer than the translation timeout.

i.e

timeout xlate 1:30:00
timeout conn 3:00:00


See if it helps.


Federico.

Ravindu Jayalath Mon, 06/14/2010 - 00:30

Hi Fedrico,


I did the change but issue still exists. Any other opinion would be much gratefull.


Thanks.

Hitesh Vinzoda Mon, 06/14/2010 - 06:29

Hi,


Check the arp table on ASA during the timeouts or normal operation for the Gateway to the public ip address... i.e. next-hop ip address in the default route.


HTH


Hitesh Vinzoda


Pls rate useful posts.

Ravindu Jayalath Mon, 06/14/2010 - 23:45

Hi Hitesh Vinzoda,


When I clear the arp table issue will be sorted out thanks to you. So how to overcome this,any opinion? Definitely i will rate.


Thanks

Hitesh Vinzoda Tue, 06/15/2010 - 00:22

Hi,


Do you have any other devices connected on a switch where ASA's outside interface is connected or is it connected directly to the ISP internet gateway ?


If any other devices are connected than check for ARP spoofing done by other devices for ISP gateway, if not than you would like to add a static arp entry for ISP internet gateway...


HTH


Hitesh Vinzoda


Pls rate useful posts.

Ravindu Jayalath Tue, 06/15/2010 - 03:39

Hi,


There are many other devices connected to the same switch where ASA outside interface connected.


Thanks.

Hitesh Vinzoda Tue, 06/15/2010 - 22:49

Check the arp table when your internet stops working on ASA and copy the mac address and check whether that belongs to the interface of ISP's gateway router, or at that time no arp is present on ASA for gateway's ip address..


HTH


Hitesh Vinzoda


Pls rate useful posts

Mohamed Sobair Wed, 06/16/2010 - 01:04

Guys,


before checking the ARP, how would the user access the internet?


You have multiple configuration need to be done, your Natting has to be configured , and here:


static (outside,inside) 192.168.200.102 192.168.1.79 netmask 255.255.255.255 ?? you are creating Static destination nat for what? this destination address is part of your Internal source while it shouldnt be?



HTH

Mohamed

Ravindu Jayalath Wed, 06/16/2010 - 01:57

Hi,


This firewall works as a IPSec VPN gateway and that NAT you mentioned related to one my remote sites. My internel users dont need to go to internet but only the site to site VPN should be establised that is why i didnt include a globa NAT for the outside.


Thnaks


Ravindu

jasoncobham Thu, 06/17/2010 - 15:01

I have, what looks like the identical problem with my ASA. Intermittently, all outbound packets are dropped on the outside interface. Clearing the ARP seems to correct the issue for a while...


It's very strange. This config was running for over 9 months and just recently started this issue. I'm really interested in a resolution. I'll post more info as I get it.


-J

Actions

This Discussion