How to enable routing between HWIC-4ESW and Onboard FE on cisco 1841 router..?

Unanswered Question

Hello All,


I have a cisco 1841 router, recently i have purchased HWIC-4ESW slot for my router. The module is working fine i could able to see additional FE ports(fe0/0/0,fe0/0/1...).Now problem comes in routing i.e. these HWIC-4ESW ports and Onboard FEs are not communicating.If any bode knows the solution kindly let me know the configuration details..


Thanks,Sazz

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Hitesh Vinzoda Thu, 06/10/2010 - 01:07
User Badges:
  • Silver, 250 points or more

Have you configured IP address on ESW port using no switchport command under port or on interface Vlan 1 where the ports is an access port for vlan1. Can you post the configuration the both the interfaces.


HTH


Hitesh Vinzoda


Pls rate useful posts.

glen.grant Thu, 06/10/2010 - 04:32
User Badges:
  • Purple, 4500 points or more

   Create your layer 2 vlans in the vlan database .   Then configure the corresponding layer 3 SVI  on the router itself .  On the 4 port hwics you cannot make them a routed port like some of the other hwics , SVI's must be used for the layer 3 definition.


router#  vlan database

              vlan 2

conf t

int vlan 2

ip address

no shut

bonnyface Fri, 07/16/2010 - 03:25
User Badges:

Dear all,


Please examine the following configuration file on a cisco 1841 with a HWIC-4ESW card added.

How can I there enable routing between the different subnets?


Router>en
Router#sh run
Building configuration...

Current configuration : 1256 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description ****INTERNET****
ip address xxx.xxx.xxx.xxx 255.255.255.252
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1.10
description ****RESIDENCES & STTA****
encapsulation dot1Q 10
ip address 172.16.1.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.20
description ****WAN TO SUB-OFFICES****
encapsulation dot1Q 20
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/1.30
description ****MAIN LAN****
encapsulation dot1Q 30
ip address 10.0.1.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0/0
switchport access vlan 10
switchport mode access
shutdown
!
interface FastEthernet0/0/1
switchport access vlan 20
switchport mode access
shutdown
!
interface FastEthernet0/0/2
switchport access vlan 30
switchport mode access
shutdown
!
interface FastEthernet0/0/3
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end


Regards,

glen.grant Fri, 07/16/2010 - 04:21
User Badges:
  • Purple, 4500 points or more

  As previous post said , create your layer 2 vlans in the vlan database .   Then create your layer 3 interfaces to match those layer 2 vlans .   Assign the hwic ports into the vlan you want assigned to that port and it will route.  Get rid of the subinterfaces that you have  and create a layer3 SVI (interface vlan XX)   and put your addresses on the SVI .

bonnyface Fri, 07/16/2010 - 04:44
User Badges:

Hi,


Look at the configs below.

How can I use IP Routing so communication is possible across all subnets?


Router>en
Router#config t


Router(config)#int fa0/0
Router(config-if)#description ***INTERNET***
Router(config-if)#ip address xxx.xxx.xxx.xxx 255.255.255.252
Router(config-if)#no shut
Router(config-if)#ip nat outside
Router(config-if)#exit


!On-board interface
Router(config)#int fa0/1
Router(config-if)#description ***LAN***
Router(config-if)#ip address 10.0.xxx.xxx 255.255.255.0
Router(config-if)#no shut
Router(config-if)#ip nat inside
Router(config-if)#exit


Router#vlan database
% Warning: It is recommended to configure VLAN from config mode,
  as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

Router(vlan)#vlan 10
VLAN 10 modified:

Router(vlan)#vlan 20
VLAN 20 added:
    Name: VLAN0020

Router(vlan)#exit
APPLY completed.
Exiting....


Router#config t
Router(config)#int vlan 10
Router(config-if)#ip address 172.16.xxx.xxx 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shut
Router(config-if)#exit


Router(config)#int vlan 20
Router(config-if)#ip address 192.168.xxx.xxx 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shut
Router(config-if)#exit


!HwIC-4ESW interface
Router(config)#int fa0/0/0
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan 10
Router(config-if)#exit


!HWIC-4ESW Interface
Router(config)#int fa0/0/1
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan 20
Router(config-if)#exit
Router(config)#exit


Router#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]


Router#config t
Router(config)#ip name-server xxx.xxx.xxx.xxx
Router(config)#ip name-server xxx.xxx.xxx.xxx
Router(config)#exit


Regards,

Gerard Roy Mon, 12/06/2010 - 16:03
User Badges:

Sooooo....


Example: 1841

!On-board interface

Router(config)#int fa0/0

!On-board interface
Router(config)#int fa0/1


Install HWIC-4ESW and we get the following attachments?

!HwIC-4ESW interface get attached to fa0/0 and becomes fa0/0/0

Router(config)#int fa0/0/0

!HwIC-4ESW interface get attached to fa0/0 and becomes fa0/0/1
Router(config)#int fa0/0/1


!HwIC-4ESW interface get attached to fa0/0 and becomes fa0/0/2

Router(config)#int fa0/0/2

!HwIC-4ESW interface get attached to fa0/0 and becomes fa0/0/3
Router(config)#int fa0/0/3

But no routing of any of these since they are switch ports that get added to the Fa0/0 routed port?

So If we need another routed port we would need the HWIC-1FE at $450 retail?

http://www.cisco.com/en/US/prod/collateral/routers/ps5854/product_data_sheet0900aecd80581fe6_ps5853_Products_Data_Sheet.html

glen.grant Mon, 12/06/2010 - 19:36
User Badges:
  • Purple, 4500 points or more

  HWIC 4 port models are not attached to the fasterthernet interfaces .  It is basically a standalone L2/3 4 port switch that can route .  In order to route off the hwic create a layer 2 vlan and then create the corresponding layer 3 SVI with an ip address  and put the switchport into that vlan .

Raul Armas Mon, 12/22/2014 - 13:56
User Badges:

I know this is a quite old post but I have been trying to configure an 1841 with a HWIC-4ESW in order to connect to a branch office and after configuring corresponding VLAN, assigning its IP address and assuring the right port belongs to that VLAN it still does not work.

I even tried with a static route removing the one I use to access my ISP and it did not work either.

I set RIP as my routing protocol just to manage connections between my LAN and branch office's. The rest of my configuration is just NAT and ACLs.

Please see small diagram attached. Any help will be greatly appreciated.

Attachment: 
Hitesh Vinzoda Tue, 12/23/2014 - 02:02
User Badges:
  • Silver, 250 points or more

Please post show ip route, show arp, show ip protocols from both the routers.

 

Thanks

Hitesh

Raul Armas Tue, 12/23/2014 - 13:03
User Badges:

Hi Hitesh,

I only have control over Router0 because Office "B" is under another IT team, neverless I am sure the point to point link works fine because I have tested it connecting a Laptop direclty to that link and I can perfectly reach 10.0.3.22.

Router0#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is ***Public-Address*** to network 0.0.0.0

C    ***Public-Address*** is directly connected, FastEthernet0/1
C    192.168.0.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via ***Public-Address***

 

 

 

Router0#show ip protocols
Routing Protocol is "rip"
  Sending updates every 30 seconds, next due in 21 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: rip
  Default version control: send version 1, receive any version
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       1     1 2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

 

With "show arp" I just see public addresses and the ones from my servers and hosts (only Office "A").

 

Thanks

Actions

This Discussion