QOS

Answered Question
Jun 10th, 2010

Hi


Branch_Office connects to HQ using service_provider MPLS network.
In order to improve Voice Quality between branches and HQ, QOS is needed.


Can someone help with steps needed to configure QOS at HQ and branch end.

Attachment: 
Correct Answer by gatlin007 about 6 years 8 months ago

That would work if you are tag switching (MPLS) on your LAN interface. The class-map above is matching MPLS experimental bits. These bits are only found in the MPLS header that’s between the frame and IP headers. 

|frame header|MPLS header|IP Header|

Generally folks don’t tag switch inside their enterprise network.  You may be better severed matching the DSCP value in the IP Header in the following manner.

class-map hero
match ip dscp EF
exit

Chris

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
gatlin007 Thu, 06/10/2010 - 08:53

1. Negotiate a ‘Gold CAR’ value with your service provider for each site.  The values may be different for ingress vs. egress and you’ll need to know both.

2. Will the phone mark the traffic DSCP value EF?

3. Will this marking be trusted through your switched network all the way to your CE router?  Will non-voice traffic be remarked to ensure it’s not able to enter the priority queue?

4. Create a class-map that matches DSCP value EF

class-map victor
Match ip dscp EF
exit


5. Create a policy-map that references the pervious class-map and allocates the service providers ingress Gold CAR value (this is your egress value) in a priority queue.

Policy-map MPLS-VPN-Egress
Class victor
  priority XXX
Exit
Exit

6. Apply this policy map as outbound policy on WAN interface.  How this gets applied Depends on the encapsulation of the interface



Christopher Gatlin
http://travelingtech.net

saquib.tandel Thu, 06/10/2010 - 15:27

Hi


Service provider will not help anything related to QOS.

Looking for config help which can gurantee bandwidth for voice and give priority to voice traffic.

DialerString_2 Fri, 06/11/2010 - 12:48

Dayummm!!!! Who is your service provider?  If they have MPLS they should be able to offer some form of QOS through their network.  My service provider matches the DSCP values I specify and those packets are handles accordingly across the MPLS. Keep in mind that you don't have control over what happens inside the MPLS network.  If you provider is AT&T or Verizon - they have QOS.

vmiller Fri, 06/11/2010 - 13:53

Chris Gatlin is correct. He and I hammered some of this out a year or two ago. At a

minimum, the provider should not re mark traffic. The provider probably has various

service options available for a small fee.


For starters, I'd take a good look at the various design guides for classification and marking

at the edge.

saquib.tandel Fri, 06/11/2010 - 22:49

Hi


My SP doesnt support QOS yet..... its sad but the fact


Looking for config input to be applied on the edge.

saquib.tandel Mon, 06/14/2010 - 06:53

Hi,


Is this config correct to reserve 50K for VOIP traffic


class-map match-any voip

match mpls experimental topmost 5

!

policy-map mpls-qos

class voip

priority 50

class class-default


interface GigabitEthernet0/0

description To_2811_One

ip address 10.1.1.2 255.255.255.0

service-policy output mpls-qos

duplex auto

speed auto







Correct Answer
gatlin007 Mon, 06/14/2010 - 07:07

That would work if you are tag switching (MPLS) on your LAN interface. The class-map above is matching MPLS experimental bits. These bits are only found in the MPLS header that’s between the frame and IP headers. 

|frame header|MPLS header|IP Header|

Generally folks don’t tag switch inside their enterprise network.  You may be better severed matching the DSCP value in the IP Header in the following manner.

class-map hero
match ip dscp EF
exit

Chris

vmiller Mon, 06/14/2010 - 07:34

Listed below is a pretty fair link that will help with the overall design of a QOS strategy. I would suggest that you at least make sure your carrier does not do anything with the markings, and just passes them along.


http://tools.cisco.com/search/display?url=http%3A%2F%2Fwww.cisco.com%2Fen%2FUS%2Fdocs%2Fsolutions%2FEnterprise%2FWAN_and_MAN%2FQoS_SRND%2FQoS-SRND-Book.html&pos=1&strqueryid=1&websessionid=KpFRGKtYpVJ_qqMnYmRQMG8

Mohamed Sobair Mon, 06/14/2010 - 07:46

This is wrong...


If you want to implement end to end Quality of Service, and you want to preserve your marking across the MPLS provider , then the Service provider has to support QoS in thier Network.


The MPLS provider can do one of the following methods to support QoS on thier MPLS Network:


1- Uniform Model.

2-Short Pipe Model

3- Pipe Model


each model has different characterstics and configuration, However, According to your situation, you dont need marking to be carried between your branches, all you need is to configure QoS inbound (Trusted boundar) and applied your QoS policy Outbound of each connection. by reserving the appropriate bandwidth for your voice using LLQ.


Another point is that, when QoS is configured across MPLS and you need to mark across MPLS boundary, The proper to mark based on IP precedence rather than DSCP as the Experemental bits are only 3 bits in the MPLS header and your IP precedence values are copied into these bits.



Please ask questions here if you need further assistance,


Mohamed

saquib.tandel Mon, 06/14/2010 - 13:16

Hi Mohd


Is This config Ok



class-map match-any voip

match mpls  experimental topmost 5

!

policy-map  mpls-qos

class voip

priority 50

class  class-default


interface GigabitEthernet0/0

description  To_2811_One

ip address 10.1.1.2 255.255.255.0

service-policy output mpls-qos

duplex  auto

speed auto

kvanorman Thu, 06/17/2010 - 13:02

Hi Saquib,


Your policy assumes that you have MPLS running in your enterprise network.  This is most likely not the case.  The traffic exiting and entering your network to/from your service provider is 99% likely not MPLS.  The MPLS frame will only appear in the SP's network and your devices will not see that.


You will need to match on DSCP or IP precedence as Chris states above.


My company actually makes a QoS management tool that you can use to graphically create and push out a policy like this.  There's a 14-day trial that you can use for free with full functionality for 10 devices.  It takes about 20 mins to install and set up.  The trial period would likely be enough time for you to create the policy, push it out, and check that it's working (there's QoS and netflow monitoring as well).


http://www.actionpacked.com/liveaction-1.8-download


Regards,


-Ken Van Orman

Actions

This Discussion