Changing Calling number on redirects

Answered Question
Jun 11th, 2010
User Badges:

Hi

Hope anyone can help me on this ,problem i have is that we are using Nortel Voicemail system with our CUCM 7 cluster ,when you forward your Cisco phone to voicemail you get the main welcome message of the Nortel VM instead of your personal VM ,now it seems that the problem is when the Cisco forwards the call to the VM pilot it sends the original calling party number and not the number that`s forwarding the call ,so the Nortel does not recognize the number as a valid extension.

Any ideas ?

Thanks in advance

Correct Answer by Md. Mijanur Rahman about 6 years 11 months ago

Hi, never forget to bounce the MGCP process even for any small change to take effect. Just issue a 'no mgcp' and right after 'mgcp' to take effect the change.

Again, you don't need to put both of them, if your remote site is calling through PRI at MGCP then you will need that 'inbound' option on that PRI and for going out the redirected number you will need 'outbound' option on the QSIG PRI, both PRI should not be the same, right?


HTH.


Please rate helpful posts!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Md. Mijanur Rahman Fri, 06/11/2010 - 04:04
User Badges:
  • Silver, 250 points or more

Hi, are you trying dialing from remote site (i.e. SRST site)? or pressing the phone message button and getting general mailbox greeting instead of personal?

If you are trying from SRST/remote site, then you have to configure something on CUCM (for MGCP gateway)/H.323 gateway voice serial interface. If you are trying from home site and after pressing message button you are getting the general mailbox greeting then check from Nortel VM server if you have configured the user profile correctly, CUCM has nothing to do for this.


HTH.

rynard.coetzee Fri, 06/11/2010 - 04:18
User Badges:

Hi ,yes i am dialling from remote site ,MGCP gateway. I have QSIG trunk from my Cisco MGCP gateway to the Nortel system.

Md. Mijanur Rahman Fri, 06/11/2010 - 04:42
User Badges:
  • Silver, 250 points or more

OK, that's clear now.

Select the option on 'Redirecting Number IE Delivery - outbound' under 'PRI Protocol Type Specific Information' under your QSIG PRI configuration.


Again, if your remote site is sending calls through PRI as well (not over IP), you will also need to configure 'Redirecting Number IE Delivery - inbound' under that PRI config.


HTH.


Please help helpful posts!

rynard.coetzee Fri, 06/11/2010 - 04:50
User Badges:

I have ticked those boxes under the PRI config in CUCM ,but i think i might need to reload MGCP on the gateway for it to take effect. SO those are the only config changes needed for this ?

Correct Answer
Md. Mijanur Rahman Fri, 06/11/2010 - 04:58
User Badges:
  • Silver, 250 points or more

Hi, never forget to bounce the MGCP process even for any small change to take effect. Just issue a 'no mgcp' and right after 'mgcp' to take effect the change.

Again, you don't need to put both of them, if your remote site is calling through PRI at MGCP then you will need that 'inbound' option on that PRI and for going out the redirected number you will need 'outbound' option on the QSIG PRI, both PRI should not be the same, right?


HTH.


Please rate helpful posts!

rynard.coetzee Fri, 06/11/2010 - 05:07
User Badges:

Thanks for the reply ,i will have to wait for after hours before bouncing the MGCP ,i will then be able to test

Actions

This Discussion