CUCIMOC deskphone

Unanswered Question
Jun 11th, 2010
User Badges:

Hello,


I'm trying to configure CUCIMOC with CUCM 7.1(2) and OCS 2007 R2.   I can make and recieve calls from my pc fine but am having problems with the desk phone control.   I get no options to select from the "select device for conversation pane"   I've associate the phone/line with the user, added the user to the standard CTI group and enabled cti control on the phone/line.   What am I missing?


Thanks,

Glenn

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htluo Fri, 06/11/2010 - 13:37
User Badges:
  • Red, 2250 points or more

You may also check:


1) If CUCIMOC got the CTIManager adddress properly.

2) If CUCM was using LDAP authentication.  If yes, we it using Global Catalog port (3268) for authentication.


Michae

http://htluo.blogspot.com

glenn.martindel... Fri, 06/11/2010 - 13:51
User Badges:

I actually was able to get desk phone control to work but had to disassociate my CSF from the username first.   Now I have a problem with LDAP.   In the server status for LDAP, it shows the status as disconnected.


Any thoughts?


Thanks,

Glenn

htluo Fri, 06/11/2010 - 13:59
User Badges:
  • Red, 2250 points or more

I guess you use the ADM instead of the BAT to populate registries?


For some reason, the ADM was missing an entry for the LDAP attributes.  (I don't recall if it's sAMAccountName or what).  Please edit the BAT file and use that to update the registry.


Michael

http://htluo.blogspot.com

glenn.martindel... Fri, 06/11/2010 - 14:11
User Badges:

I used the batch file to populate the registry.   How can I find out what attribute I'm missing?


Thanks,

Glenn

htluo Fri, 06/11/2010 - 14:24
User Badges:
  • Red, 2250 points or more

There are two ways to find out:


1) Do a packet capture while recreating the problem (re-login to CUCIMOC).


2) Generate a problem report.  (you want to delete the old logs, or it'll be very huge).  The log location is %userprofile%\Local Settings\Application Data\Cisco\Unified Communications\Client Services Framework\Logs


Michael

http://htluo.blogspot.com

david.keedy Mon, 06/14/2010 - 07:19
User Badges:

Hey,


Just got this working a couple of weeks ago and found that the registry settings are very particular.  The LDAP attribute names had to be added in their entirity for it to work properly.  Once the data fields were entered correctly, it worked fine.  I opened a TAC case, and got a great technician who helped us.


You can also download LDP and watch what happens with regard to LDAP.  Great tool.

glenn.martindel... Mon, 06/14/2010 - 10:20
User Badges:

TAC helped me figure this out.   I had the LDAP search base specified incorrectly.


Thanks for everyone's assistance with this.


Glenn

e.silva_2 Wed, 07/21/2010 - 19:53
User Badges:

Hi David,


Do you have an example for the registry settings that it need to be filled ?


cause i have the same Issue


Thanks

david.keedy Thu, 07/22/2010 - 07:29
User Badges:

Hello,


I have attached an example of the registry settings I used to make this work.  You will have to modify it, entering the information I noted within the quotes.  Also, I dont know if this is common knowledge, but if you are running any anti virus software, you may need to disable it temporarily while the TFTP config loads.  Our system has TFTP disabled, so TFTP would fail.  It seems to be fine once the initial TFTP is able to happen.


Once you modify the registry settings and then run the registry update, you should see the changes within your registry under the location specified.


The only fields you need to place network specific information in are;


"CcmcipServer1"="Enter IP address of CUCM server to register to"
"LDAP_Server_1"="Enter Domain Server FQDN"
"LDAP_SearchBaseDN_1"="OU=Users,OU=XX,OU=XX,DC=XX,DC=XX,DC=XX,DC=XX"
"VoicemailPilotNumber"="Enter voicemail pilot number"
"CtiServer2"="Enter CTI server address"
"TftpServer1"="Place TFTP server address here"
"LDAP_UserLogonDomain"="Enter Logon Domain"


Leave the rest of the registry entries as they are and they should be good...hope this helps!

e.silva_2 Thu, 07/22/2010 - 16:15
User Badges:

Hi David,


Thanks for your reply....


I´m using the SampleCUCIMOC-CUCSFAdminData.bat running directly to the client pc, i think this is used for standallone installations, I check it and has the same registry settings but different path HKCU\Software\Cisco Systems, Inc.\Client Services Framework\AdminData, here are my settings:

TFTP1="192.168.1.100"
TFTP2="192.168.1.100"
TFTP3="192.168.1.100"
CTI1="192.168.1.100"
CTI2="192.168.1.100"


LDAP_Server_1="ldap://192.168.1.110:389"
LDAP_SearchBaseDN_1="OU=Users,DC=ocslab,DC=com"
LDAP_SearchBaseDN_2=""
LDAP_SearchBaseDN_3=""
LDAP_SearchBaseDN_4=""
LDAP_SearchBaseDN_5=""
LDAP_MaxCacheSize="1000"
LDAP_ResultMaxSize="250"
LDAP_ScheduleInterval="0"
LDAP_EnableWildcardMatchesForPhoneNumberSearches="false"
LDAP_UserLogonDomain="ocslab.com"
LDAP_AttributeName_objectclassKey="objectclass"
LDAP_AttributeName_objectclassValue="person"
LDAP_AttributeName_userLogonName="userPrincipalName"
LDAP_AttributeName_displayName="displayName"
LDAP_AttributeName_commonName="cn"
LDAP_AttributeName_firstName="givenName"
LDAP_AttributeName_lastName="sn"
LDAP_AttributeName_email="mail"
LDAP_AttributeName_uri="msRTCSIP-PrimaryUserAddress"
LDAP_AttributeName_photoUri="photoUri"
LDAP_AttributeName_businessPhone="telephoneNumber"
LDAP_AttributeName_homePhone="homePhone"
LDAP_AttributeName_mobilePhone="mobile"
LDAP_AttributeName_otherPhone="otherTelephone"
LDAP_AttributeName_title="title"
LDAP_AttributeName_companyName="company"
LDAP_AttributeName_userAccountName="sAMAccountName"
LDAP_AttributeName_primaryPhoneNumberForSearches=""


POLICY_CREDENTIALS_IsLdapSynchronizedWithCucm="false"

SECURITY_CertificateDirectory=""

VMPilot="8000"

CCMCIP1="192.168.1.100"
CCMCIP2="192.168.1.100"

david.keedy Thu, 07/22/2010 - 16:26
User Badges:

I don't use the LDAP IP address, it wouldn't work for me unless I used the FQDN.


David

Actions

This Discussion