Avaya IPOffice 500 and Cisco Gateway

Unanswered Question
Jun 12th, 2010

Hello All,

This is my first time doing integration between  Cisco and Avaya . I am integrating an Avaya IP Office 500 with Cisco Call Manager v 7 . I have a 2911 GW . All on the same side . At the moment Avaya IP Office 500 connect to PRI line . The plan is use Cisco 2911 gateway for Voice service provider connection and connect Avaya box to second E1 card on Cisco 2911 gateway . Configured on CM the port connected to PBX with MGCP , but controller still down , cable for connection tested in lab between cisco gateways  E1 to E1 conection . What should be configured on CM MGCP Gateway port setting for this type of connection ? Any configuration should be done on Avaya or i can use current configuration for PRI line ? Thanks for answers ! Alex

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Md. Mijanur Rahman Sun, 06/13/2010 - 02:47

Hi, can you post your router configuration (highlighted on controller and voice serial ports configs) and 'sh isdn status' output? Also a short description on what you have done on CUCM?

alexserstjuk Sun, 06/13/2010 - 04:33

hi , i have no connection to site at the moment - but i remember that isdn status was DEACTIVATED , on call manager i  was configured  MGCP gateway , it showed ip address of the gateway and unregistred , i tried different protocols setting - but not get registration of the gateway on call manager . Regards Alex

Attachment: 
James Hawkins Sun, 06/13/2010 - 04:49

With PRI connections one device has to be the network side and the other the user side. The network side would typically provide clocking.

If the E1 on the Avaya was previously used to connect to the PSTN it will be configured as a user device so you need to set the Cisco router up as a network device using the commands below:

interface Serial0/0/0:15
 no ip address
 isdn protocol-emulate network
 isdn switch-type ??????
 no cdp enable

You will also need to tell the E1 controller to use an internal clock as shown below:

controller E1 0/0/0
 clock source internal
 
These commands should hopefully help you move forward but you will probably need some others to get it working completely.

It would be useful if you could post your config as requested by the previous poster. 


alexserstjuk Sun, 06/13/2010 - 05:40

hi James

i tried use this way first - create no MGCP controller and assign internal clocking , but the controller was down , i didn't apply   isdn protocol-emulate network    command , where this command should be applyed - on controller or on serial interface ? Regards Alex

Md. Mijanur Rahman Sun, 06/13/2010 - 05:56

I think you shouldn't use the command 'isdn protocol-emulate network'. Becuase your gateway is going to be connected to the Service-Provider switch and their switch will act as the 'network' and your 2911 controller gonna be the user end. Configure your controller (connected to Avaya switch) later on.

Did you rebooted your router once? MGCP gateways sometime need a reboot when behaving strange. And additionally, did you configure the HWIC module/sub-module correctly on the CUCM? And also the network switch-type?

alexserstjuk Sun, 06/13/2010 - 06:28

hi , Gateway was restarted after configuration of MGCP , switch type is correct  , modul set up correct - i see endpoint on gateway , the gateway visible on CM ( if setting is incorrect you not will see ip address on the gateway page in CM ) , but MGCP stay in non-register stage - that mean the port not talk to far end properly - something wrong with config but i cannot understand what . Regards . Alex

Md. Mijanur Rahman Sun, 06/13/2010 - 06:43

I can see some conflicting commands on your configuration:


/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

!

interface GigabitEthernet0/0

description ### VOIP INTERFACE ###

ip address 192.168.42.2 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.42.2

!

Again:

!

mgcp bind control source-interface gig 0/0

mgcp bind media source-interface gig 0/0

!

That is you are using the same interface to bind both H.323 and MGCP signaling which really doesn't make any sense to me. Can you please check after removing the 'h323-gateway voip' commands from gig 0/0? Also don't forget to bounce MGCP by 'no mgcp' and right after 'mgcp' commands.

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;}

If you really need to make any H323 bind interface then create a loopback and use it to bind H323 signaling.

HTH.

James Hawkins Sun, 06/13/2010 - 08:21

I agree that a gateway port connecting to a service provider should be configured as a user device but the OP stated that he was trying to connect the Cisco gateway to the Avaya Office so one of these devices needs to emulate the network. I would assume that the Avaya defaults to user hence my suggestion to configure the Cisco interface to emulate the network. The suggested command is an interface command so the second PRI port in the Cisco unit that could act as a user device when connecting to the service provider.

The suggested command is applied the the D channel interface - e.g. serial 0/0/0:15

The link below may also be useful:

http://www.cisco.com/en/US/docs/ios/dial/configuration/guide/dia_cfg_ntwk_isdn_pri_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1088330

James Hawkins Sun, 06/13/2010 - 08:30

Hi,

Actually with MGCP you set the network mode within the CUCM configuration (apologies I am a H.323 fan!).

The document at the link below shows how to configure an MGCP gateway to link to a Siemens PBX with CallManager 4 but the principles are the same.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/pbx/interop/notes/417588si.pdf

Note on page 16 the Protocol Side value is set to Network.

alexserstjuk Mon, 06/14/2010 - 00:51

Hi All

thanks for a help , this customer has a window to reconnect the line and test it for weekend only , i will reconfigure gateway on Saturday and let you know result . Regards . Alex

Actions

This Discussion

Related Content