ap + repeater

Unanswered Question
Jun 13th, 2010

Hi Admins

I've trouble to set ap+repeater wifi.

Ap works well and there is no trouble with host connections.

Repeater doesn't associate with ap. I've tried to configure repeater both Dot11 0 and Dot11 1.

It doesn't work.

What should I do to associate them.

ROD2#sh running-config
Building configuration...

Current configuration : 2102 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ROD2
!
enable secret 5 $1$uC3P$Q07JY68dTVCUTcPerq0Uq/
!
username Cisco password 7 032752180500
ip subnet-zero
!
no aaa new-model
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid AR12
    authentication open
!
ssid ar12
    infrastructure-ssid
!
parent 1 000f.f858.85f8
parent 2 0011.20ee.cfce
parent 3 0013.1965.de96
parent 4 0013.1965.de9b
speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
ip address 10.0.12.2 255.255.255.0
no ip route-cache
!
ssid AR12
    authentication open
    infrastructure-ssid
!
parent 1 000f.f858.85f8
parent 2 0011.20ee.cfce
parent 3 0013.1965.de9b
speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
station-role repeater
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 10.0.12.2 255.255.255.0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1
logging snmp-trap emergencies
logging snmp-trap alerts
logging snmp-trap critical
logging snmp-trap errors
logging snmp-trap warnings
bridge 1 route ip
!
!
!
line con 0
transport preferred all
transport output all
line vty 0 4
login local
transport preferred all
transport input all
transport output all
line vty 5 15
login
transport preferred all
transport input all
transport output all
!
end

ROD2#

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Elliott Shawd Fri, 06/18/2010 - 17:03

Is the ap you are using a cisco ap? Cisco repeaters require CCX compatible aps in order to connect I'm pretty sure. Also, you shouldn't have to configure the parents. If it sees an available ssid, it should connect. Finally, are you running a dhcp server? If so, you don't have to statically set the ip. I would hard reset and use the gui to configure your repeater if thats not what you were using before.

Also, if you have the resources, I would set your "repeater" up as a workgroup bridge using the A radio as backhaul to the ap and the b/g radio to re-broadcast your ssid. It works much better, utilizing both radios.

abersven Sat, 06/19/2010 - 01:51

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

Hi,

I agree with Elliott that you should consider using 5GHz between the access points and 2,4GHz to the clients. This gives better throughput than a repeater. To do this you need to configure one of the access points to either an AP or a ROOT BRIDGE for 5GHz. I suggest that you go for ROOT BRIDGE on 5GHz not allowing ordinary clients to connect.

The other access point can be configured as workgroup-bridge but I suggest NON ROOT BRIDGE on the 5GHz radio. The 2,4GHz radio should be configured as an ordinary AP and you can use the same SSID on all your 2,4GHz radios.

I have compiled example configurations for you in my lab where I use a 40-bit WEP-key for the clients and WPA2 between the access points. As you see the SSIDs are defined in the global configuration and then assigned to the interfaces. THE-NET is the SSID for the clients, AP-to-AP is a hidden SSID used between the access points on 5GHz. ‘guest-mode’ that is configured for the SSID ‘THE-NET’ is how you get the access point to broadcast the SSID in order to get it visible for the clients.

ROOT#

!

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname ROOT

!

enable secret cisco

!

clock timezone CET 1

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

ip subnet-zero

ip domain name la1npa.com

!

!

ip ssh version 2

no aaa new-model

dot11 syslog

!

dot11 ssid THE-NET

   authentication open

   guest-mode

   infrastructure-ssid

!

dot11 ssid AP-to-AP

   authentication open

   authentication key-management wpa

   infrastructure-ssid

   wpa-psk ascii secretwpapassword

!

!

!

username abersven privilege 15 secret mypassword

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 40bit 1122334455 transmit-key

encryption mode wep mandatory

!

ssid THE-NET

!

station-role root access-point

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid AP-to-AP

!

dfs band 3 block

channel dfs

station-role root bridge

bridge-group 1

bridge-group 1 spanning-disabled

!

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

!

interface BVI1

ip address 192.168.1.230 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http authentication local

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input telnet ssh

!

sntp server 192.36.143.153

sntp server 192.36.143.234

sntp server 192.36.143.150

sntp server 192.36.143.151

end

NON-ROOT#

!

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname NON-ROOT

!

enable secret cisco

!

clock timezone CET 1

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

ip subnet-zero

ip domain name la1npa.com

!

!

ip ssh version 2

no aaa new-model

dot11 syslog

!

dot11 ssid THE-NET

   authentication open

   guest-mode

   infrastructure-ssid

!

dot11 ssid AP-to-AP

   authentication open

   authentication key-management wpa

   infrastructure-ssid

   wpa-psk ascii secretwpapassword

!

!

!

username abersven privilege 15 secret mypassword

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 40bit 1122334455 transmit-key

encryption mode wep mandatory

!

ssid THE-NET

!

station-role root access-point

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid AP-to-AP

!

dfs band 3 block

channel dfs

station-role non-root bridge

bridge-group 1

bridge-group 1 spanning-disabled

!

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

!

interface BVI1

ip address 192.168.1.231 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http authentication local

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input telnet ssh

!

sntp server 192.36.143.153

sntp server 192.36.143.234

sntp server 192.36.143.150

sntp server 192.36.143.151

end

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

BTW: You cannot connect a Cisco AP as a repeater or WGB to a non Cisco or CCX AP.

/André

Elliott Shawd Sat, 06/19/2010 - 09:58

The reason I suggest the workgroup bridge on the dot11radio1 is because it does in fact leave it available to clients. What you can do, as you have shown, is  set different passwords for the "root" device, regardless if it is an ap or root bridge, but you don't have to. So, you have the ability to control whether or not you want your clients to connect to the a radio when you have the dot11radio1 interface set to Access Point depending on which SSIDs you apply to which interface.

Also, I haven't tried it in a minute, but back when I was playing around with it, I think I preferred the wgb's because I could set the root device to ap/ap then configure both ap/wgb and wgb/ap and sort of create an indoor mesh for all a/b/g. Needless to say, it was sweet.

abersven Sat, 06/19/2010 - 02:13

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin-top:0cm; mso-para-margin-right:0cm; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0cm; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

And now how to use the access point as a repeater if that is what really you want.

With the following configuration the AP is a repeater on 2,4GHz and an AP on 5GHz.

REPEATER#

!

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname REPEATER

!

enable secret cisco

!

clock timezone CET 1

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

ip subnet-zero

ip domain name la1npa.com

!

!

ip ssh version 2

no aaa new-model

dot11 syslog

!

dot11 ssid THE-NET

   authentication open

   guest-mode

   infrastructure-ssid

!

!

!

!

username abersven privilege 15 secret mypassword

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption key 1 size 40bit 1122334455 transmit-key

encryption mode wep mandatory

!

ssid THE-NET

!

station-role repeater

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid THE-NET

!

dfs band 3 block

channel dfs

station-role root access-point

bridge-group 1

bridge-group 1 spanning-disabled

!

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

bridge-group 1

!

interface BVI1

ip address 192.168.1.232 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http authentication local

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input telnet ssh

!

sntp server 192.36.143.153

sntp server 192.36.143.234

sntp server 192.36.143.150

sntp server 192.36.143.151

end

BTW: You cannot connect a Cisco AP as a repeater or WGB to a non Cisco or CCX AP.

/André

Actions

This Discussion