Problems upgrading 7940 firmware on CCM 7.1(5)

Unanswered Question
Jun 14th, 2010

We have some problems installing new firmware on CCM 7.1(5). After installing the .cop.sgn file we receive a message that everything is ok, but we cannot see any new file in the TFTP server, and the device defaults remain the original file. Any solution?

Regards.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Mon, 06/14/2010 - 03:44

Hi

Did you restart the TFTP server?

If you know the filename of the firmware you can try pulling it using the following command to verify if it's available:

tftp -i ccmipaddress GET filename.bin

Regards

Aaron

Please rate helpful posts...

victorgarciaternero Mon, 06/14/2010 - 04:22

The problem I have detected is the file name. The file name is P00308010200, and I supposed the file name was SCCP-7940-7960-8.1.2.

victorgarciaternero Mon, 06/14/2010 - 05:18

Really it does not work well. I am looking at 7960 phones, and they do not load the firmware correctly. I have connected wireshark and it download the file from tftp server, but in the phone menu the firmware version is the older.

gsidhu Wed, 07/21/2010 - 10:11

I had a similar issue....

Downgrade to version 8.0(9).

This should fix your issue.

Make sure you restart the TFTP service

HTH

victorgarciaternero Wed, 07/21/2010 - 13:59

Hello, the problem was in the file we uploaded to the tftp server. We used the cop.sgn file which is installed in the server, but id didn't work. The solution was upload the files manually to the tftp server and reload it; then it worked perfectly.


Regards.

Actions

This Discussion