Calls from the PSTN disconnect before ringing

Answered Question
Jun 14th, 2010

hi,

i need some urgent assistance please guys.

i have a 2851 SRST router with an ISDN30 (E1) to the PSTN. i can make outgoing calls but i cannot receive incoming calls. the SP is cable and wireless. attached is a copy of my config. am i missing something here? do i need to change my incoming dial peer to match the digits presented by the SP?

many thanks

Dimitri

Attachment: 
I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 6 months ago

OK, could be failing further down the path.

1) In CCM, have you added the gateway as a H.323 gateway?

2) In the device name field of the GW in CCM, you need to specify the gateway's IP. You then have to Reset the gateway from CCMAdmin (this brings it into service; if you don't do that it will get rejected).

3) Do you have a CSS assigned in the 'Inbound' section of the gateway config in CCM that allows access to the partition containing the 73xx extensions? Maybe use DNA to verify this...

Regards

Aaron

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Aaron Harrison Mon, 06/14/2010 - 04:12

Hi Dimitri

I guess you got this circuit working in the end? It would be useful to other people using the forum if you could update the other thread with the resolution you found.

I see from your configuration that your dial-peers are configured to expect four digits starting 1,3,4 or 8.

If the SP is sending in a different digit length these may not match; run a 'debug isdn q931' and then make a test call inbound. You should see a SETUP message with a called number in it; your dial-peers need to match this number (or we can translate them if required, but best to keep things simple).

Run that debug and post back the results if it's not clear.

Regards

Aaron


Please rate helpful posts and mark answered questions that you've got a satisfactory response from to help identify useful content in the forums...
https://supportforums.cisco.com/docs/DOC-6212

dnicolaides Mon, 06/14/2010 - 04:19

Hi Aaron,

yes at about 22:30 last night it was resolved and it was exactly as we had said, the SP. i will definitely be updating the last discussion as soon as i get a chance. thanks for all the help by the way.

here is the debug.

GPO-VoiceGW-11#
*Jun 14 11:26:23.418: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x000A
        Sending Complete
        Bearer Capability i = 0x9090A3
                Standard = CCITT
                Transfer Capability = 3.1kHz Audio
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98382
                Exclusive, Channel 2
        Progress Ind i = 0x8A81 - Call not end-to-end ISDN, may have in-band info
        Called Party Number i = 0x80, '300'
                Plan:Unknown, Type:Unknown
*Jun 14 11:26:23.426: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x800A
        Channel ID i = 0xA98382
                Exclusive, Channel 2
*Jun 14 11:26:23.430: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x800A
        Cause i = 0x8081 - Unallocated/unassigned number
*Jun 14 11:26:23.446: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x000A
        Cause i = 0x8295 - Call rejected
*Jun 14 11:26:23.450: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x800A

i can change the dial-peers to match 73xx as the main number is 0141 568 7300 - 7349.

many thanks

Dimitri

Aaron Harrison Mon, 06/14/2010 - 04:32

Hi Dimitri

OK - so in that debug, called number is '300'.

SP is sending in the last three digits.

Now - if you just have the 7300-7349 range on this E1, then the easiest fix would be to update your dial-peers like so:

destination-pattern 3..

prefix 7

Router will insert 7 to make up four digits, which I guess will match your CCM extensions.

If you actually need the other ranges (1xxx etc) to arrive on this E1, then we'll have to do something different. Bear in mind the only numbers this router needs to have in these dial-peers are the ones that are arriving on that E1.

The only time the other numbers would be dialled would be if a phone was registered to SRST, and dialled them - in this case, those dial-peers wouldn't work anyway (no CCM available, or no connection to CCM available). Sometimes people like to have those translated out to the full PSTN number so short dialling is still possible.

Regards

Aaron

Please rate helpful posts...

dnicolaides Mon, 06/14/2010 - 04:38

hi Aaron,

i have tried this but the router wont accept the prefix 7 command under the dial-peer???

this is the only range we need to accept on this E1.

this is an SRST router so will these dial peers work in that instance?

thanks again

Dimitri

Aaron Harrison Mon, 06/14/2010 - 04:48

Hi Dimitri

Sorry - not as awake as I should be this morning.

Set up a translation-profile for your inbound dial-peer, this will remap to four digits on inbound and will apply in SRST mode as well.

That way when your phone register with the GW, they will register with 4 digits and work OK.

The command I listed previously just works on POTS dial peers... oops.

Throw in these commands:

translate 3.. to 73..

!

voice translation-rule 1
rule 1 /^\(3..\)$/ /7\1/
!
!
voice translation-profile PSTN-Inbound
translate called 1

Apply the trans profile to the inbound direct-inward-dial peer

dial-peer voice 1 pots

translation-profile incoming PSTN-Inbound

Regards

Aaron

Aaron Harrison Mon, 06/14/2010 - 05:23

Hi

We've overwritten a translation that inserts 9 there..

Need to put that back:

voice translation-rule 2
rule 1 /^0/ /90/

Then add it to the PSTN-Inbound profile:

voice translation-profile PSTN-Inbound

translate calling 2

Then try taking it off that dial-peer and putting in on the E1 port:

dial-peer voice 1 pots
no translation-profile incoming PSTN-Inbound

voice-port 0/0/0:15

translation-profile incoming PSTN-Inbound

Regards

dnicolaides Mon, 06/14/2010 - 05:30

thanks Aaron,

i have made the changes but still nothing??

here is a debug isdn q931 output

n 14 12:39:50.290: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8  callref = 0x0025
        Sending Complete
        Bearer Capability i = 0x9090A3
                Standard = CCITT
                Transfer Capability = 3.1kHz Audio
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98381
                Exclusive, Channel 1
        Progress Ind i = 0x8A81 - Call not end-to-end ISDN, may have in-band info
        Called Party Number i = 0x80, '302'
                Plan:Unknown, Type:Unknown
*Jun 14 12:39:50.298: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8  callref = 0x8025
        Channel ID i = 0xA98381
                Exclusive, Channel 1
*Jun 14 12:39:50.302: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8  callref = 0x8025
        Cause i = 0x8081 - Unallocated/unassigned number
*Jun 14 12:39:50.314: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8  callref = 0x0025
        Cause i = 0x8295 - Call rejected
*Jun 14 12:39:50.318: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8  callref = 0x8025
GPO-VoiceGW-11#

i dialled 0141 568 7302

Correct Answer
Aaron Harrison Mon, 06/14/2010 - 05:41

OK, could be failing further down the path.

1) In CCM, have you added the gateway as a H.323 gateway?

2) In the device name field of the GW in CCM, you need to specify the gateway's IP. You then have to Reset the gateway from CCMAdmin (this brings it into service; if you don't do that it will get rejected).

3) Do you have a CSS assigned in the 'Inbound' section of the gateway config in CCM that allows access to the partition containing the 73xx extensions? Maybe use DNA to verify this...

Regards

Aaron

dnicolaides Mon, 06/14/2010 - 05:53

1) yes i have and the device name is the ip address of the

gateway.

3) yes i do have a CSS assigned. although, i have it set to ALL significant digits? is that correct?

Aaron Harrison Mon, 06/14/2010 - 06:08

Hi

Yes, 'ALL' is OK, provided that the four digits we are sending (e.g. 7300) matches the DN on CCM.

Try running a debug cch323 on the gateway and make another test call, then post back the info.

Regards

dnicolaides Mon, 06/14/2010 - 06:50

all sorted Aaron,

the problem was the destination pattern. i never corrected it to be 73.. after we changed the voice translation rules.

thanks again for all your help.

Dimitri

Actions

This Discussion