Transfer flash memory between routers

Unanswered Question
Jun 14th, 2010
User Badges:

Hi,


I'm trying to install 32MB of flash from a 3640 into another 3640.  The flash works in the original 3640.  I can erase it and boot images from it.  When I put the same flash in the other 3640 I get:



get_man_dev: Unknown device - probably NOT formatted.

unknown flash device - mandev code = 0x0

cannot read flash info

getdevnum warning: device "flash" has size of zero

get_man_dev: Unknown device - probably NOT formatted.

unknown flash device - mandev code = 0x0

cannot read flash info

getdevnum warning: device "flash" has size of zero

open: read error...requested 0x4 bytes, got 0x0

trouble reading device magic number

boot: cannot open "flash:"

boot: cannot determine first file name on device "flash:"       


I booted the new 3640 off of a disk in slot1 and tried to ease it but after running for about an hour I finally got:



Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...NOT erased

Erase of flash: complete   


If I put the flash back into the original router and I can erase it, copy an image to it, and boot off of it.


I also switched the bootrom on the routers since the 3640 that I was trying to upgrade had an older version but it made no difference.


I did an erase and squeeze on the original 3640 and installed the flash in the new 3640.  I boot off of slot1 and now get a crash after the OS boots:


00:00:02 UTC Fri Mar 1 2002: TLB (load or instruction fetch) exception, CPU signal 10, PC = 0x60F6E7DC


This causes the router to continuously crash and reboot.  If I put the original flash in it boots without a problem.


Any ideas?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion