Decrypt errors occurred for client

Unanswered Question
Jun 14th, 2010

I am getting error messages for clients:


11 Mon Jun 14 09:11:56 2010 Decrypt errors occurred for client 00:13:ce:54:57:3c using WPA key on 802.11b/g interface of AP 00:16:9c:91:97:c0
12 Mon Jun 14 09:11:56 2010 Decrypt errors occurred for client 00:16:6f:91:d8:60 using WPA2 key on 802.11b/g interface of AP 00:16:9c:91:97:c0


These are only occuring for clients that are disconnecting....


They can reconnect after a WLC reboot....


We have swapped APs.....


I have seen this error in other forums but it says not to worry about it. There has to be a connection between this and clients getting disconnected. We have anywhere between 10-50 clients on the system at any one time.


Is this a client issue (nic firmware, version) or is this an error in  the controller??



AIR-WLC2106-K9

IOS ver: 6.0.196.0


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
sterlingmoses Tue, 11/02/2010 - 09:58

We too are receiving these error messages on our 4402-K12 system. Clients dropping connections are only related to those client mac addresses listed in the errors.


Anyone care to elaborate on what we can do to correct this?


Thank you

Nicolas Darchis Thu, 11/04/2010 - 00:42

This means that the client is using a different key than the one he agreed on using with the AP. There were bugs about this long time ago but nothing recent.

I've seen this happening a lot with old/not updated clients. It rarely happens on intel adapters with latest drivers for example.

So I'd suggest checking the client pattern (are the clients facing this all having old wireless drivers ?).


It can also happen if you offer funny encryption combinations that client doesn't like (wpa1+aes, wpa2+tkip). Try to only enable wpa2/aes and see if it helps.


Nicolas

18091988n Wed, 01/18/2012 - 00:06

and we had such logs on our controller when the clients of iPad devices were connecting to the APs (802.11b/g/n) - we could see from the controller that the device has got an ip, but could not even ping it, otherwise there were no problems with the connections to APs (802.11a/n). there were also no problems on both kinds of APs for other Apple devices.

So we used your advise, but left only WPA2+TKIP encryption for the Apple WLAN - as yet - everything is ok! hope, we have solved the problem.

Georgios Nikitas Tue, 07/03/2012 - 06:32

Hello,

actually you misunderstood the advice!

WPA2 normally supports AES and WPA supports TKIP.

So the normal configuration would be:

WPA2 with AES

or

WPA with TKIP


Can you verify that the configuration of WPA2 with TKIP actually solved your problem?

I have experienced similars errors with iPads but I didn't have time to investigate just yet.

Martin Bosch Tue, 06/10/2014 - 00:16

Just a heads up, I had the same thing. But this was due to an external DHCP server going down.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode