One way audio following transfer from AA

Unanswered Question
Jun 14th, 2010

Hi,  I just setup SPA9000, SPA400 and a couple of SPA942/962 IP phones at my wife's small business.   Our setup includes one ITSP line on Line 1 and a PSTN connection through the SPA400 on Line 2.  Everything is working as expected except for the AA on inbound calls from the ITSP.  After the call is transfered to an extension, that extension cannot hear the calling party.  With inbound calls on the PSTN line, the issue does not exist.

I've tried to troubleshoot this for days and am stumped at this point.  Has anyone incountered a similar issue and found a resolution ??

BTW, all the equipment is upgraded to the latest firmware release available on Cisco's website.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
nseto Wed, 06/16/2010 - 09:39

Check for these a general rule, I use these settings...

1.  In SIP tab, under PBX Parameters, Force Media Proxy to yes.

2.  In Line 1 tab, under Proxy and Registration, XFER Bridge Mode to all and CFWD Bridge Mode to all.

If this still fails, then in the Contact List for Line 1, please try putting the extension number instead of aa to see if audio is received by the internal extension.  This will help narrow the problem.  Thank you.

lehighleo Wed, 06/16/2010 - 10:24

Thanks for the reply.  Yes, I've tried toggling these settings and the issue still exists.  If I bypass the AA, by placing an extension number in the Contact list, the call completes correctly with two-way audio.  This issue only appears to occur when the AA answers an inbound call and then transfers it to an extension.

Also, my network setup uses a Dlink router (DIR-825).  I have tried using other routers with the same results.  I also tried testing this with the SPA9000 and all the IP phones on publicly routable IPs .... this worked as expected.   However, this setup is not desireable in practice sinse I will only have one public IP at the office.


nseto Wed, 06/16/2010 - 13:41

is the link to get the software to capture the log and instructions on how to generate the log.

You'll need to capture a log of the fail and successful call so we can see the difference.  Sounds like ip address or port being routed elsewhere when using the router.

lehighleo Fri, 06/18/2010 - 09:14

OK.  Here are the log files you asked for.  The file named "Successfull call_via AA(public IPs).log is for the setup where the SPA9000 and SPA901 phones are on a public IPs.  This call was handled successfully by the AA.

The other two files show logs of the setup when all the equipment is behind a Dlink router.

Thanks in advance.

PS:  I rebooted the equipment at the beginning of each log capture.

nseto Fri, 06/18/2010 - 13:03

The audio packets doesn't know how to get back to your internal ip address of 192.168.x.x.

Does your ITSP have an outbound proxy?  You can set it up in the parameter 'outbound proxy' in line 1 of the spa9000.

If not, you'll have to try a STUN server, the settings are in the SIP tab under NAT support parameters.  STUN isn't as good as you'll have to make sure your router isn't doing symmetric NAT.

lehighleo Fri, 06/18/2010 - 13:19

Yes the ITSP uses an outbound proxy and I've setup the SPA9000 to use it.  If you look at the log file "success call _ no AA.log", this call was made with the SPA9000 contact list set to extension 11.  In this case, the audio path success fully comes into the private network and goes to the extension.

The one-way audio seems to only occure when AA is used in the contact list of the SPA9000.  Is there something with the way the SPA9000 AA handles SIP for inbound calls when they are transferred to an extension???

I'd like to also try setting port forwarding on the router ... which ports (SIP and RTP) should I set on the router?  Other than 5060, do I have to forward the the signaling/rtp ports for the extensions?

nseto Fri, 06/18/2010 - 14:32

From the looks of the log, it should have forwarded the audio packets correctly.  Are you able to get ethereal trace so you can see where the audio packets are going to after enters the spa9000?  The sip port is fine.  The rtp ports are for the audio packets.  Default is range of 16384-16482,  check under SIP tab under RTP parameters.

lehighleo Thu, 06/24/2010 - 08:47


Here are the captures on the lan and also on the wan-side of the router.  I noticed that the SDP of the second Invite contains the IP address of the IP phone.  I tried enabled the VIA settings on the SPA9000 and also setting  the "Ext IP" to the the WAN IP of my router.  Neither setting worked.  Any other recommendations ??


This Discussion

Related Content