Need route on CCME or CUE to send voicemail to email?

Answered Question
Jun 14th, 2010
User Badges:

I am trying to enable voicemail notification to email. I set it up with my email server information but the CUE doesnt seem to reach it.


I can log into the CCME and ping the email server successfully which exists on the same 10.0.0.0 subnet. When I log into the CUE at ip 10.0.101.1 I cant ping anything in the 10.0.0.0 subnet except for my CCME. So I am guessing the CUE cant see the email server to send the message and needs a route statement? Do I need a route on the CCME or the CUE? If so what is the syntax?



Thanks,

-Kenny

Correct Answer by Aaron Harrison about 6 years 9 months ago

Hi


Yes - If you have a client on the 10.0.0.0/255.255.248.0 network, and you change the client's default gateway to 10.0.0.140 you should find you can ping the CUE. This just proves the config of the CUE and host router, you wouldn't want to make this change permanently.


If another device on the 10.0.0.0/255.255.248.0 network is the default gateway, then that device will require a route like this:


ip route 10.0.101.0 255.255.255.0 10.0.0.140


This should give you the ability to route to the CUE from the 10.0.0.0 subnet at least - obviously if you have other sites or further l3 devices that route will need to be propogated throughout your network (or at least far enough to reach your mail server)


Regards


Aaron


Please rate helpful posts and mark answered questions that you've got a satisfactory response from to help identify useful content in the forums...
https://supportforums.cisco.com/docs/DOC-6212

Correct Answer by Aaron Harrison about 6 years 9 months ago

Hi


Three steps:


1) The default gateway for CUE is configured on the service engine interface:

e.g.:

service-module ip address 10.0.101.1 255.255.255.0
       service-module ip default-gateway 10.0.101.2


In that example 10.0.101.2 would be the router's service-engine interface IP, or if it's configured with ip unnumbered, the IP of the interface it is unnumbered to.


2) Uf using IP unnumbered, the router then needs a host route back to the CUE module :


ip route 10.0.101.1 255.255.255.255 interface service-engine x/x      <-- obviously substitute your service engine interface name


3) Finally, if this router is not the default gateway for the clients in 10.0.0.0, the device that is the default gw will need a route for the 10.0.101.x subnet pointing back to the gateway (if not using ip unnumbered), or a route for the 10.0.101.1 host if using ip unnumbered.


If this doesn't help, post back your router config, and detail any other layer 3 devices present on this network.


Regards


Aaron


Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Aaron Harrison Mon, 06/14/2010 - 14:38
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Three steps:


1) The default gateway for CUE is configured on the service engine interface:

e.g.:

service-module ip address 10.0.101.1 255.255.255.0
       service-module ip default-gateway 10.0.101.2


In that example 10.0.101.2 would be the router's service-engine interface IP, or if it's configured with ip unnumbered, the IP of the interface it is unnumbered to.


2) Uf using IP unnumbered, the router then needs a host route back to the CUE module :


ip route 10.0.101.1 255.255.255.255 interface service-engine x/x      <-- obviously substitute your service engine interface name


3) Finally, if this router is not the default gateway for the clients in 10.0.0.0, the device that is the default gw will need a route for the 10.0.101.x subnet pointing back to the gateway (if not using ip unnumbered), or a route for the 10.0.101.1 host if using ip unnumbered.


If this doesn't help, post back your router config, and detail any other layer 3 devices present on this network.


Regards


Aaron


Please rate helpful posts...

Kenneth McCoig Mon, 06/14/2010 - 14:50
User Badges:

Hi Aaron, thanks for the quick reply. I am kind of understanding... I may need to add a route on the default gateway, right? I took an excerpt from my current running-config:



interface Loopback0
ip address 10.0.101.1 255.255.255.0


interface GigabitEthernet0/0
no ip address
duplex auto
speed auto


interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 10.0.0.140 255.255.248.0


interface GigabitEthernet0/0.101
encapsulation dot1Q 101
ip address 10.0.100.1 255.255.255.0


interface GigabitEthernet0/1
no ip address
duplex auto
speed auto


interface Integrated-Service-Engine1/0
ip unnumbered Loopback0
service-module ip address 10.0.101.2 255.255.255.0
service-module ip default-gateway 10.0.101.1
no keepalive


ip default-gateway 10.0.0.140
ip forward-protocol nd

ip route 10.0.101.2 255.255.255.255 Integrated-Service-Engine1/0

Correct Answer
Aaron Harrison Mon, 06/14/2010 - 23:32
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Yes - If you have a client on the 10.0.0.0/255.255.248.0 network, and you change the client's default gateway to 10.0.0.140 you should find you can ping the CUE. This just proves the config of the CUE and host router, you wouldn't want to make this change permanently.


If another device on the 10.0.0.0/255.255.248.0 network is the default gateway, then that device will require a route like this:


ip route 10.0.101.0 255.255.255.0 10.0.0.140


This should give you the ability to route to the CUE from the 10.0.0.0 subnet at least - obviously if you have other sites or further l3 devices that route will need to be propogated throughout your network (or at least far enough to reach your mail server)


Regards


Aaron


Please rate helpful posts and mark answered questions that you've got a satisfactory response from to help identify useful content in the forums...
https://supportforums.cisco.com/docs/DOC-6212

Kenneth McCoig Tue, 06/29/2010 - 06:53
User Badges:

Aaron,

Thank you thus far for your assistance. I did have one other related queston:


My network admin does not want to add any routes to our default gateway and would like me to find another solution. I did think about this so please let me know if it would work:


On the CUE I have an ethernet port currently unused. Is it possible for me to set a static IP for this port in the 10.0.0.0 network and then just patch from there back to my network equipment? Then I should be able to route to that network without any problems correct?


Thanks again!

-Kenny

Actions

This Discussion