How to change the User Agent string

Unanswered Question

Hi All,

Hope someone can help me with this one. We work with several SIP providers and they all seem to be working fine except for one. Although we are able to connect to the this provider, setting up a call isn't working. We get a message back that the account is not valid.

We checked everything and according to the provider there is an issue with the user agent string sent when setting up a connection. This string contains de word CISCO and for the provider this is a reserverd word in his system. The suggestion is to change the user agent string.

Does anybody know how to do this? I can't find it in the config...



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Robert Thomas Tue, 04/12/2011 - 07:59

You can do something like

voice class sip-profiles 2
  request INVITE sip-header User-Agent modify "Cisco-SIPGateway/IOS-12.x" "test/IOS"


This Discussion

Related Content