CUPS 7.0.4 - Exchange 2003 Calendar Status Issue

Answered Question
Jun 15th, 2010
User Badges:

Hi,

I have deployed CUPS 7.0.4 with CUCM 7.0.3 and all is ok, except the status does not change for a user when a meeting is scheduled.


I have carried out the following,


Created the account, delegated view only administrator and added receive as permission

Uploaded all the Certificates in the chain

Set up the outlook gateway in CUPS, using the correct name for the presence gateway, CN from the certificate

Ticked the show me in a meeting box for a user in CUPC


Yet the status does not change. DNS is enabled and the correct domain is set on the CUPS. Form based authentication is also disabled.


I have tried putting the domain in front of the cups account, no joy

I can use the service account to access the end users mailbox so I don't think it's a permission issue.


From the log I can't see the cupc trying to retrieve calendar information.


Any help would be appreciated.


Thanks


Mike

Correct Answer by htluo about 7 years 6 days ago

Can you go to CUPS > System > Service Parameters > Cisco UP SIP Proxy?  See what's the proxy domain?


If it's ABZ.IMESGROUP.COM, could you change it to abz.imesgroup.com?  Then reboot the server.


Thanks!

Michael

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
htluo Tue, 06/15/2010 - 10:42
User Badges:
  • Red, 2250 points or more

Could you try the following?


1) Set "Presence Engine" trace level to "debug"

2) Restart "Presence Engine"

3) Restart CUPC and make sure the status goes to "Available"

4) Collect "Presence Engine" logs from 5 minutes prior you restarted the engine to the point when CUPC went to "Available".


Thanks!

Michael

http://htluo.blogspot.com

htluo Wed, 06/16/2010 - 06:13
User Badges:
  • Red, 2250 points or more

I saw the Outlook Gateway initialized (smtp.imesgroup.com), but I didn't see any request from CUPC for calendar information.


Could you go to CUPC > File > Preferences > Status, see if "Show me as In-a-meeting" option was enabled?


If it was, please re-do the test (restart Presence Engine, restart CUPC).  Make sure you use a larger time frame to collect traces (-/+ 15 minutes).  So we can capture all the logs.


Thanks!

Michael

http://htluo.blogspot.com

mikee2112 Thu, 06/17/2010 - 05:34
User Badges:

Hi Michael,


I can confirm that the tick box is checked on the cupc. I carried out the test again and have the logs for about 20 mins before hand to 15 mins after.


Please find attached the logs.


Thanks


Mike

htluo Thu, 06/17/2010 - 07:43
User Badges:
  • Red, 2250 points or more

Haven't seen the logs yet.


Michael

htluo Thu, 06/17/2010 - 07:53
User Badges:
  • Red, 2250 points or more

Still the same, no request from end user.


Try this:


1) Go to CUPS > Presence > Gateways.  Delete and recreate the Outlook Gateway.


2) Go to CUPC > File > Preferences > Status.  Uncheck/check the "Show me as in-a-meeting".


3) Restart Presence Engine and Restart CUPC.  Write down the time of the engine restart.


4) Wait until CUPC goes to 'Available'.  Collect Presence Engine logs.


5) Give me the time the engine restart and the time CUPC went to 'Available'


Michael

mikee2112 Fri, 06/18/2010 - 03:37
User Badges:

Hi Michael,


I deleted and re-created the Gateway, unchecked then checked the tick box on the cupc.


Presence engine restarted at 10:37:01, back up at 10:37:50, singned into CUPC at 10:39:32, status changed to available at 10:39:48.


Please find attached the log.


Thanks


Mike

Attachment: 
Correct Answer
htluo Fri, 06/18/2010 - 11:14
User Badges:
  • Red, 2250 points or more

Can you go to CUPS > System > Service Parameters > Cisco UP SIP Proxy?  See what's the proxy domain?


If it's ABZ.IMESGROUP.COM, could you change it to abz.imesgroup.com?  Then reboot the server.


Thanks!

Michael

mikee2112 Mon, 06/21/2010 - 04:40
User Badges:

Hi Michael,


Thats the problem fixed, I changed the name to all lowercase and rebooted the box and it's now working.


Many thanks for your assistance with this.


Thanks


Mike

Actions

This Discussion